summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-09-24 22:51:13 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-09-24 22:51:13 +0000
commitb525e8d88670af08e94527b2d2133be2398f0faa (patch)
treec3a85b06f078f905bc2242333c8f39e76ce13d78
parentBump to 2.22.0, gdk-pixbuf has been split off and the pixbuf directories changed (diff)
downloadgentoo-2-b525e8d88670af08e94527b2d2133be2398f0faa.tar.gz
gentoo-2-b525e8d88670af08e94527b2d2133be2398f0faa.tar.bz2
gentoo-2-b525e8d88670af08e94527b2d2133be2398f0faa.zip
Add gdk-pixbuf, split off gtk+ so it can be shared b/w gtk+:2 and gtk+:3. Inherits gtk's keywords.
(Portage version: 2.1.9.10/cvs/Linux x86_64)
-rw-r--r--x11-libs/gdk-pixbuf/ChangeLog12
-rw-r--r--x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-fix-automagic-x11.patch24
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.0.ebuild82
-rw-r--r--x11-libs/gdk-pixbuf/metadata.xml9
4 files changed, 127 insertions, 0 deletions
diff --git a/x11-libs/gdk-pixbuf/ChangeLog b/x11-libs/gdk-pixbuf/ChangeLog
new file mode 100644
index 000000000000..8bff3b811613
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-libs/gdk-pixbuf
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.1 2010/09/24 22:51:13 nirbheek Exp $
+
+*gdk-pixbuf-2.22.0 (24 Sep 2010)
+
+ 24 Sep 2010; <nirbheek@gentoo.org>
+ +files/gdk-pixbuf-2.21.4-fix-automagic-x11.patch,
+ +gdk-pixbuf-2.22.0.ebuild, +metadata.xml:
+ Add gdk-pixbuf, split off gtk+ so it can be shared b/w gtk+:2 and gtk+:3.
+ Inherits gtk's keywords.
+
diff --git a/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-fix-automagic-x11.patch b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-fix-automagic-x11.patch
new file mode 100644
index 000000000000..ae7ec2c905a6
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-fix-automagic-x11.patch
@@ -0,0 +1,24 @@
+Adds a new configure option to remove the automagic dependency on libX11.
+
+--- configure.ac
++++ configure.ac
+@@ -929,7 +929,18 @@ GDK_PIXBUF_XLIB_PACKAGES=
+ GDK_PIXBUF_XLIB_EXTRA_CFLAGS=
+ GDK_PIXBUF_XLIB_EXTRA_LIBS=
+
+-if $PKG_CONFIG --exists x11; then
++AC_ARG_WITH(x11,
++ AC_HELP_STRING([--with-x11=@<:@no/auto/yes@:>@],
++ [build X11 support @<:@default=auto@:>@]),,
++ [
++ if $PKG_CONFIG --exists x11; then
++ with_x11=yes
++ else
++ with_x11=no
++ fi
++ ])
++
++if test x$with_x11 = xyes; then
+ AM_CONDITIONAL(USE_X11, true)
+ PKG_CHECK_MODULES(GDK_PIXBUF_XLIB_DEP, x11 gobject-2.0)
+ else
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.0.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.0.ebuild
new file mode 100644
index 000000000000..0d3d12cb3e5d
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.0.ebuild,v 1.1 2010/09/24 22:51:13 nirbheek Exp $
+
+EAPI="3"
+
+inherit gnome.org flag-o-matic multilib libtool autotools virtualx
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+X debug doc +introspection jpeg jpeg2k tiff test"
+
+# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
+RDEPEND="
+ >=dev-libs/glib-2.25.9
+ >=media-libs/libpng-1.2.43-r2:0
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( >=media-libs/jpeg-6b-r9:0 )
+ jpeg2k? ( media-libs/jasper )
+ tiff? ( >=media-libs/tiff-3.9.2 )
+ X? ( x11-libs/libX11 )
+ !<gnome-base/gail-1000
+ !<gnome-base/librsvg-2.31.0
+ !<x11-libs/gtk+-2.21.3:2
+ !<x11-libs/gtk+-2.90.4:3"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=sys-devel/gettext-0.17
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )"
+
+src_prepare() {
+ # Only build against libX11 if the user wants to do so
+ epatch "${FILESDIR}"/${PN}-2.21.4-fix-automagic-x11.patch
+
+ elibtoolize
+ eautoreconf
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ local myconf="
+ $(use_enable doc gtk-doc)
+ $(use_with jpeg libjpeg)
+ $(use_with jpeg2k libjasper)
+ $(use_with tiff libtiff)
+ $(use_enable introspection)
+ $(use_with X x11)
+ --with-libpng"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS NEWS* README* || die "dodoc failed"
+}
+
+pkg_postinst() {
+ gdk-pixbuf-query-loaders > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+
+ if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
+ elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
+ fi
+}
diff --git a/x11-libs/gdk-pixbuf/metadata.xml b/x11-libs/gdk-pixbuf/metadata.xml
new file mode 100644
index 000000000000..e86947c98b6e
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ </use>
+</pkgmetadata>