summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-11-21 19:16:50 +0000
committerVlastimil Babka <caster@gentoo.org>2009-11-21 19:16:50 +0000
commitb5d9cfa4e3aa4d1fb33de7fbe65468342336a8b0 (patch)
treee1542ce69cece516f50fa3d00355dbeba757efae
parentppc stable #293031 (diff)
downloadgentoo-2-b5d9cfa4e3aa4d1fb33de7fbe65468342336a8b0.tar.gz
gentoo-2-b5d9cfa4e3aa4d1fb33de7fbe65468342336a8b0.tar.bz2
gentoo-2-b5d9cfa4e3aa4d1fb33de7fbe65468342336a8b0.zip
Call econf in src_configure, spotted by maekke in bug #290199. Add doc USE flag to install html and pdf docs.
(Portage version: 2.2_rc50/cvs/Linux x86_64)
-rw-r--r--net-misc/omniORB/ChangeLog6
-rw-r--r--net-misc/omniORB/omniORB-4.1.4.ebuild29
2 files changed, 22 insertions, 13 deletions
diff --git a/net-misc/omniORB/ChangeLog b/net-misc/omniORB/ChangeLog
index 166eb3c9fa8b..4d0050c133bf 100644
--- a/net-misc/omniORB/ChangeLog
+++ b/net-misc/omniORB/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/omniORB
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.54 2009/11/17 19:52:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.55 2009/11/21 19:16:50 caster Exp $
+
+ 21 Nov 2009; Vlastimil Babka <caster@gentoo.org> omniORB-4.1.4.ebuild:
+ Call econf in src_configure, spotted by maekke in bug #290199. Add doc USE
+ flag to install html and pdf docs.
17 Nov 2009; Brent Baude <ranger@gentoo.org> omniORB-4.1.4.ebuild:
Marking omniORB-4.1.4 ppc64 for bug 290199
diff --git a/net-misc/omniORB/omniORB-4.1.4.ebuild b/net-misc/omniORB/omniORB-4.1.4.ebuild
index 8062ff9c43fd..f1836e389870 100644
--- a/net-misc/omniORB/omniORB-4.1.4.ebuild
+++ b/net-misc/omniORB/omniORB-4.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-4.1.4.ebuild,v 1.3 2009/11/17 19:52:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-4.1.4.ebuild,v 1.4 2009/11/21 19:16:50 caster Exp $
EAPI="2"
@@ -13,7 +13,7 @@ HOMEPAGE="http://omniorb.sourceforge.net/"
LICENSE="LGPL-2 GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 ~ppc ppc64 ~sparc ~x86"
-IUSE="ssl"
+IUSE="doc ssl"
RDEPEND="dev-lang/python
ssl? ( >=dev-libs/openssl-0.9.6b )"
@@ -26,31 +26,36 @@ src_prepare() {
mk/platforms/i586_linux_2.0*.mk || die "sed failed"
}
-src_compile() {
- mkdir build || die
- cd build
+src_configure() {
+ mkdir build && cd build || die
- MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg \
+ local MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg \
--with-omniNames-logdir=/var/log/omniORB --libdir=/usr/$(get_libdir)"
use ssl && MY_CONF="${MY_CONF} --with-openssl=/usr"
python_version
- PYTHON=/usr/bin/python${PYVER} ECONF_SOURCE=".." econf ${MY_CONF} \
- || die "./configure failed"
+ PYTHON=/usr/bin/python${PYVER} ECONF_SOURCE=".." econf ${MY_CONF}
+}
- emake OPTCFLAGS="${OPTCFLAGS}" OPTCXXFLAGS="${CXXFLAGS}" || die "emake failed"
+src_compile() {
+ cd build
+ emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}" || die "emake failed"
}
src_install () {
- cd "${S}/build"
+ cd build
emake DESTDIR="${D}" install || die "emake install failed"
cd "${S}"
dodoc COPYING* CREDITS README* ReleaseNotes* || die
- docinto print
- #dodoc doc/*.ps doc/*.pdf || die
+ if use doc; then
+ dohtml doc/*.html || die
+ dohtml -r doc/omniORB || die
+ docinto print
+ dodoc doc/*.pdf || die
+ fi
dodir /etc/env.d/
cat <<- EOF > "${T}/90omniORB"