summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-28 00:23:27 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-28 00:23:27 +0000
commitb6268c784bdae4839545596be8f01aea56e42cd9 (patch)
treeaabbf386ed4f940cbd90539600c48d406439d22a
parentold (diff)
downloadgentoo-2-b6268c784bdae4839545596be8f01aea56e42cd9.tar.gz
gentoo-2-b6268c784bdae4839545596be8f01aea56e42cd9.tar.bz2
gentoo-2-b6268c784bdae4839545596be8f01aea56e42cd9.zip
Version bump.
(Portage version: 2.1.3.7)
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.133
-rw-r--r--sys-apps/util-linux/util-linux-2.13.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index ed100052c3ed..e6e43cad0cfa 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.198 2007/08/10 14:40:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.199 2007/08/28 00:23:27 vapier Exp $
+
+*util-linux-2.13 (28 Aug 2007)
+
+ 28 Aug 2007; Mike Frysinger <vapier@gentoo.org> +util-linux-2.13.ebuild:
+ Version bump.
*util-linux-2.13_rc3 (10 Aug 2007)
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.13 b/sys-apps/util-linux/files/digest-util-linux-2.13
new file mode 100644
index 000000000000..a2e47b157d36
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.13
@@ -0,0 +1,3 @@
+MD5 2175a6e64ba0cf8ff05402eaee33e4b0 util-linux-ng-2.13.tar.bz2 2702618
+RMD160 499b1c5c2060b23d8bf504122a22122af99eb7fa util-linux-ng-2.13.tar.bz2 2702618
+SHA256 002412e93d8e85b1796fdbe65bbb0a4d193d0317a7155fda4270667e08bdfbfc util-linux-ng-2.13.tar.bz2 2702618
diff --git a/sys-apps/util-linux/util-linux-2.13.ebuild b/sys-apps/util-linux/util-linux-2.13.ebuild
new file mode 100644
index 000000000000..d11bf07ff9f7
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.13.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13.ebuild,v 1.1 2007/08/28 00:23:27 vapier Exp $
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
+inherit eutils git
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-ng-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls old-linux selinux"
+
+RDEPEND="!sys-process/schedutils
+ !sys-apps/setarch
+ >=sys-libs/ncurses-5.2-r2
+ >=sys-fs/e2fsprogs-1.34
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-fsprobe=blkid \
+ $(use_enable nls) \
+ --enable-agetty \
+ --enable-cramfs \
+ $(use_enable old-linux elvtune) \
+ --disable-init \
+ --disable-kill \
+ --disable-last \
+ --disable-mesg \
+ --enable-partx \
+ --enable-raw \
+ --enable-rdev \
+ --enable-rename \
+ --disable-reset \
+ --disable-login-utils \
+ --enable-schedutils \
+ --disable-wall \
+ --enable-write \
+ --without-pam \
+ $(use_with selinux) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS NEWS README* TODO docs/*
+}