summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-03-03 13:44:25 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-03-03 13:44:25 +0000
commitb6bc66fa249b709224cfc6d3ad83dc14128b14ab (patch)
tree6d9d846c3106efbfc70f681a6efd56ec85d002dd
parentversion bump wrt security #212170 (diff)
downloadgentoo-2-b6bc66fa249b709224cfc6d3ad83dc14128b14ab.tar.gz
gentoo-2-b6bc66fa249b709224cfc6d3ad83dc14128b14ab.tar.bz2
gentoo-2-b6bc66fa249b709224cfc6d3ad83dc14128b14ab.zip
Version bump (bug #212179).
(Portage version: 2.1.4.4)
-rw-r--r--dev-python/pygame/ChangeLog10
-rw-r--r--dev-python/pygame/pygame-1.8.0_rc4.ebuild59
2 files changed, 67 insertions, 2 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 36f294ab6568..a00c6b62680c 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygame
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.43 2007/07/07 19:14:21 lucass Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.44 2008/03/03 13:44:25 dev-zero Exp $
+
+*pygame-1.8.0_rc4 (03 Mar 2008)
+
+ 03 Mar 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +pygame-1.8.0_rc4.ebuild:
+ Version bump (bug #212179).
07 Jul 2007; Lukasz Strzygowski <lucass@gentoo.org> -pygame-1.6.2.ebuild:
Dropped old version.
diff --git a/dev-python/pygame/pygame-1.8.0_rc4.ebuild b/dev-python/pygame/pygame-1.8.0_rc4.ebuild
new file mode 100644
index 000000000000..6a2dbc37e445
--- /dev/null
+++ b/dev-python/pygame/pygame-1.8.0_rc4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.8.0_rc4.ebuild,v 1.1 2008/03/03 13:44:25 dev-zero Exp $
+
+inherit distutils
+
+MY_P="${PN}-${PV/_}"
+
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+HOMEPAGE="http://www.pygame.org/"
+SRC_URI="http://rene.f0o.com/~rene/stuff/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4
+ dev-python/numpy
+ >=media-libs/smpeg-0.4.4-r1"
+DEPEND="${DEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+
+src_unpack() {
+ unpack ${A}
+ # Search correct libdir for existing sdl libs
+ sed -i -e "s:/lib:/$(get_libdir):" ${S}/config_unix.py || die
+}
+
+src_compile() {
+ distutils_src_install
+
+ # Copy missing icon-file
+ cp lib/pygame_icon.bmp build/lib.*/pygame/
+}
+
+src_install() {
+ DOCS=WHATSNEW
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ insinto /usr/share/doc/${PF}/examples/data
+ doins ${S}/examples/data/*
+ fi
+}
+
+src_test() {
+ python_version
+ PYTHONPATH="$(ls -d build/lib.*)" "${python}" run_tests.py || die "tests failed"
+}