summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-09-30 12:20:39 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-09-30 12:20:39 +0000
commitb7d30dedd668be50e28e644d9f49f3d05bd1bb9d (patch)
treef90b5785d99c6325fb9785f957bc6aa66f8a3f0a
parentNotify the user to manually remove /etc/X11/gtk/gtkrc (diff)
downloadgentoo-2-b7d30dedd668be50e28e644d9f49f3d05bd1bb9d.tar.gz
gentoo-2-b7d30dedd668be50e28e644d9f49f3d05bd1bb9d.tar.bz2
gentoo-2-b7d30dedd668be50e28e644d9f49f3d05bd1bb9d.zip
Updated older abiword to add gnome menu entries
-rw-r--r--app-office/abiword/abiword-0.7.14.ebuild12
-rw-r--r--gnome-office/abiword/abiword-0.7.14.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/app-office/abiword/abiword-0.7.14.ebuild b/app-office/abiword/abiword-0.7.14.ebuild
index 66662bc99cac..f6710eba5294 100644
--- a/app-office/abiword/abiword-0.7.14.ebuild
+++ b/app-office/abiword/abiword-0.7.14.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-0.7.14.ebuild,v 1.4 2001/08/11 04:34:35 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-0.7.14.ebuild,v 1.5 2001/09/30 12:20:39 azarah Exp $
A="abi-${PV}.tar.gz abidistfiles-${PV}.tar.gz expat-${PV}.tar.gz psiconv-${PV}.tar.gz
unixfonts-${PV}.tar.gz wv-${PV}.tar.gz"
@@ -58,6 +58,16 @@ src_install() {
rm -f AbiWord
ln -s ../AbiSuite/bin/AbiWord AbiWord
ln -s ../AbiSuite/bin/AbiWord abiword
+
+ # Install icon and .desktop for menu entry (hopefully this works for this version,
+ # as I have only tested it for 0.9.3
+ if [ "`use gnome`" ] ; then
+ insinto ${GNOME_PATH}/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto ${GNOME_PATH}/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ fi
+
}
diff --git a/gnome-office/abiword/abiword-0.7.14.ebuild b/gnome-office/abiword/abiword-0.7.14.ebuild
index 88223403d26b..8aa78e5f8b06 100644
--- a/gnome-office/abiword/abiword-0.7.14.ebuild
+++ b/gnome-office/abiword/abiword-0.7.14.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-office/abiword/abiword-0.7.14.ebuild,v 1.4 2001/08/11 04:34:35 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-office/abiword/abiword-0.7.14.ebuild,v 1.5 2001/09/30 12:20:39 azarah Exp $
A="abi-${PV}.tar.gz abidistfiles-${PV}.tar.gz expat-${PV}.tar.gz psiconv-${PV}.tar.gz
unixfonts-${PV}.tar.gz wv-${PV}.tar.gz"
@@ -58,6 +58,16 @@ src_install() {
rm -f AbiWord
ln -s ../AbiSuite/bin/AbiWord AbiWord
ln -s ../AbiSuite/bin/AbiWord abiword
+
+ # Install icon and .desktop for menu entry (hopefully this works for this version,
+ # as I have only tested it for 0.9.3
+ if [ "`use gnome`" ] ; then
+ insinto ${GNOME_PATH}/share/pixmaps
+ newins ${WORKDIR}/${P}/abidistfiles/icons/abiword_48.png AbiWord.png
+ insinto ${GNOME_PATH}/share/gnome/apps/Applications
+ doins ${FILESDIR}/AbiWord.desktop
+ fi
+
}