summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-08 20:31:26 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-08 20:31:26 +0000
commitb90a8a2bf6cb59adc5bce2d2a6bc7a80f78dd65b (patch)
tree1fc50301fe8f4a75521b7b1ec19d36c9e3490946
parentstable on ia64 (diff)
downloadgentoo-2-b90a8a2bf6cb59adc5bce2d2a6bc7a80f78dd65b.tar.gz
gentoo-2-b90a8a2bf6cb59adc5bce2d2a6bc7a80f78dd65b.tar.bz2
gentoo-2-b90a8a2bf6cb59adc5bce2d2a6bc7a80f78dd65b.zip
add ia64 version
-rw-r--r--dev-java/jrockit/ChangeLog7
-rw-r--r--dev-java/jrockit/Manifest4
-rw-r--r--dev-java/jrockit/jrockit-8.1.ebuild20
3 files changed, 22 insertions, 9 deletions
diff --git a/dev-java/jrockit/ChangeLog b/dev-java/jrockit/ChangeLog
index 298f23e82ac8..a84389af0ddc 100644
--- a/dev-java/jrockit/ChangeLog
+++ b/dev-java/jrockit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/jrockit
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jrockit/ChangeLog,v 1.1 2003/05/23 17:27:50 tberman Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jrockit/ChangeLog,v 1.2 2004/01/08 20:31:19 agriffis Exp $
+
+ 08 Jan 2004; <agriffis@gentoo.org> jrockit-8.1.ebuild:
+ Add ia64 version of jrockit for bug 37528
*jrockit-8.1 (23 May 2003)
diff --git a/dev-java/jrockit/Manifest b/dev-java/jrockit/Manifest
index 3791c48482f1..eb398ae8af2c 100644
--- a/dev-java/jrockit/Manifest
+++ b/dev-java/jrockit/Manifest
@@ -1,5 +1,5 @@
-MD5 ab134c2afa2a7155653f167ad11a22b2 ChangeLog 415
-MD5 fb75b22ae4992e499a7ac517053a1393 jrockit-8.1.ebuild 1604
+MD5 16ce3e30f35ca0dd8f0cf6ae0a3964ae ChangeLog 518
+MD5 9f613179309343ea3e85ba73d3357cd2 jrockit-8.1.ebuild 1753
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-jrockit-8.1 0
MD5 526353109877a591e6417c72c2aa6392 files/jrockit-8.1 293
diff --git a/dev-java/jrockit/jrockit-8.1.ebuild b/dev-java/jrockit/jrockit-8.1.ebuild
index 70e7a6e02785..299fcc8e3e13 100644
--- a/dev-java/jrockit/jrockit-8.1.ebuild
+++ b/dev-java/jrockit/jrockit-8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jrockit/jrockit-8.1.ebuild,v 1.5 2003/09/11 01:07:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jrockit/jrockit-8.1.ebuild,v 1.6 2004/01/08 20:31:19 agriffis Exp $
IUSE=""
@@ -9,14 +9,19 @@ RESTRICT="nostrip"
inherit java
-At="jrockit-8.1-j2se1.4.1-linux32.bin"
+if [[ $ARCH == ia64 ]]; then
+ At="jrockit-8.1-j2se1.4.1-linux64.bin"
+else
+ At="jrockit-8.1-j2se1.4.1-linux32.bin"
+fi
+
S="${WORKDIR}"
SRC_URI=""
DESCRIPTION="BEA WebLogic's J2SE Development Kit, version 8.1"
HOMEPAGE="http://commerce.bea.com/downloads/weblogic_jrockit.jsp"
LICENSE="jrockit"
SLOT="1.4"
-KEYWORDS="x86"
+KEYWORDS="x86 ia64"
DEPEND="virtual/glibc
>=dev-java/java-config-0.2.5
>=app-arch/unzip-5.50-r1"
@@ -26,8 +31,13 @@ PROVIDE="virtual/jre-1.4
virtual/java-scheme-2"
src_unpack() {
+ local b=32
+ [[ $ARCH == ia64 ]] && b=64
+
if [ ! -f ${DISTDIR}/${At} ] ; then
- eerror "Please download ${At} from ${HOMEPAGE} (select the \"Linux (32 bit)\" package format of \"WebLogic JRockit 8.1\") and move it to ${DISTDIR}."
+ eerror "Please download ${At} from ${HOMEPAGE}"
+ eerror "(select the \"Linux ($b bit)\" package format of \"WebLogic JRockit 8.1\")"
+ eerror "and move it to ${DISTDIR}."
eerror "NOTE: This download REQUIRES a fairly extensive registration process."
die "Download ${At} and put it into ${DISTDIR}."
fi