summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2015-04-17 15:07:25 +0000
committerSven Vermeulen <swift@gentoo.org>2015-04-17 15:07:25 +0000
commitba04f9af1b46da9d370fd2962740d5fbf6cf08ad (patch)
tree0132c9c3e4b32c78139d2afef133f921abb4b88d
parentVersion bump. Fix security bug 546678. (diff)
downloadgentoo-2-ba04f9af1b46da9d370fd2962740d5fbf6cf08ad.tar.gz
gentoo-2-ba04f9af1b46da9d370fd2962740d5fbf6cf08ad.tar.bz2
gentoo-2-ba04f9af1b46da9d370fd2962740d5fbf6cf08ad.zip
Fix bug #540096 - Do not treat # Note as a preprocessor directive (build failure occurs otherwise)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
-rw-r--r--sys-auth/pambase/ChangeLog7
-rw-r--r--sys-auth/pambase/files/pambase-20150213-selinux-note.patch11
-rw-r--r--sys-auth/pambase/pambase-20150213.ebuild6
3 files changed, 22 insertions, 2 deletions
diff --git a/sys-auth/pambase/ChangeLog b/sys-auth/pambase/ChangeLog
index 628abbb4d0ba..66e75a74bb3f 100644
--- a/sys-auth/pambase/ChangeLog
+++ b/sys-auth/pambase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pambase
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.142 2015/02/21 18:51:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/ChangeLog,v 1.143 2015/04/17 15:07:25 swift Exp $
+
+ 17 Apr 2015; Sven Vermeulen <swift@gentoo.org> pambase-20150213.ebuild,
+ +files/pambase-20150213-selinux-note.patch:
+ Fix note in system-login so it is not seen as a processor directive (bug
+ #540096)
21 Feb 2015; Mike Frysinger <vapier@gentoo.org> pambase-20150213.ebuild:
Fix typo in SRC_URI after typo fix
diff --git a/sys-auth/pambase/files/pambase-20150213-selinux-note.patch b/sys-auth/pambase/files/pambase-20150213-selinux-note.patch
new file mode 100644
index 000000000000..1cb018f34508
--- /dev/null
+++ b/sys-auth/pambase/files/pambase-20150213-selinux-note.patch
@@ -0,0 +1,11 @@
+--- system-login.in.orig 2015-04-17 16:58:02.247000000 +0200
++++ system-login.in 2015-04-17 16:58:07.684000000 +0200
+@@ -48,7 +48,7 @@
+ session optional pam_ck_connector.so nox11
+ #endif
+ #if HAVE_SELINUX
+-# Note: modules that run in the user's context must come after this line.
++ # Note: modules that run in the user's context must come after this line.
+ session required pam_selinux.so multiple open
+ #endif
+ #if HAVE_GNOME_KEYRING
diff --git a/sys-auth/pambase/pambase-20150213.ebuild b/sys-auth/pambase/pambase-20150213.ebuild
index 02c4bbc87252..1be4d9d64417 100644
--- a/sys-auth/pambase/pambase-20150213.ebuild
+++ b/sys-auth/pambase/pambase-20150213.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20150213.ebuild,v 1.3 2015/02/21 18:51:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pambase/pambase-20150213.ebuild,v 1.4 2015/04/17 15:07:25 swift Exp $
EAPI=5
inherit eutils
@@ -42,6 +42,10 @@ RDEPEND="
DEPEND="app-portage/portage-utils
app-arch/xz-utils"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-selinux-note.patch #540096
+}
+
src_compile() {
local implementation linux_pam_version
if has_version sys-libs/pam; then