summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 21:41:19 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 21:41:19 +0000
commitbbe6dbb190fde057dcb4fdb7dd55e6e02f33ec84 (patch)
tree866ede14d7ac9f9166d92c735ae1b09ca2fb0fe3
parentChanged src_install () to src_install() (diff)
downloadgentoo-2-bbe6dbb190fde057dcb4fdb7dd55e6e02f33ec84.tar.gz
gentoo-2-bbe6dbb190fde057dcb4fdb7dd55e6e02f33ec84.tar.bz2
gentoo-2-bbe6dbb190fde057dcb4fdb7dd55e6e02f33ec84.zip
Changed econf||die to econf
-rw-r--r--app-misc/uptimed/uptimed-0.2.0-r1.ebuild17
-rw-r--r--app-misc/wipe/wipe-2.1.0.ebuild9
-rw-r--r--app-misc/worker/worker-2.3.1.ebuild10
-rw-r--r--app-misc/worker/worker-2.7.0.ebuild10
4 files changed, 20 insertions, 26 deletions
diff --git a/app-misc/uptimed/uptimed-0.2.0-r1.ebuild b/app-misc/uptimed/uptimed-0.2.0-r1.ebuild
index 3bc30dd27841..8921c44626ae 100644
--- a/app-misc/uptimed/uptimed-0.2.0-r1.ebuild
+++ b/app-misc/uptimed/uptimed-0.2.0-r1.ebuild
@@ -1,18 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/uptimed-0.2.0-r1.ebuild,v 1.6 2002/10/20 18:40:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/uptimed/uptimed-0.2.0-r1.ebuild,v 1.7 2002/11/30 21:37:19 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Standard informational utilities and process-handling tools"
SRC_URI="mirror://sourceforge/uptimed/${P}.tar.bz2"
-HOMEPAGE="http://unixcode.org/uptimed"
+HOMEPAGE="http://unixcode.org/uptimed/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
-DEPEND="virtual/glibc"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -20,7 +17,7 @@ src_unpack() {
}
src_compile() {
- econf || die
+ econf
emake || die
}
@@ -36,8 +33,8 @@ src_install() {
}
pkg_postinst() {
- echo -e "\e[32;01m To start uptimed, you must enable the /etc/init.d/uptimed rc file \033[0m"
- echo -e "\e[32;01m You may start uptimed now with: \033[0m"
- echo -e "\e[32;01m /etc/init.d/uptimed start \033[0m"
- echo -e "\e[32;01m To view your uptimes, use the command 'uprecords'.\033[0m"
+ einfo "To start uptimed, you must enable the /etc/init.d/uptimed rc file"
+ einfo "You may start uptimed now with:"
+ einfo "/etc/init.d/uptimed start"
+ einfo "To view your uptimes, use the command 'uprecords'."
}
diff --git a/app-misc/wipe/wipe-2.1.0.ebuild b/app-misc/wipe/wipe-2.1.0.ebuild
index 128e1033f073..6f0de3b9e2c7 100644
--- a/app-misc/wipe/wipe-2.1.0.ebuild
+++ b/app-misc/wipe/wipe-2.1.0.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.1.0.ebuild,v 1.1 2002/10/29 18:06:37 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.1.0.ebuild,v 1.2 2002/11/30 21:39:08 vapier Exp $
DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
-HOMEPAGE="http://wipe.sourceforge.net"
-LICENSE="GPL"
+HOMEPAGE="http://wipe.sourceforge.net/"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
src_compile() {
- econf || die "configure problem"
+ econf
emake || die "compile problem"
}
diff --git a/app-misc/worker/worker-2.3.1.ebuild b/app-misc/worker/worker-2.3.1.ebuild
index 35905a4704d0..4298b6475380 100644
--- a/app-misc/worker/worker-2.3.1.ebuild
+++ b/app-misc/worker/worker-2.3.1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/worker/worker-2.3.1.ebuild,v 1.6 2002/10/20 18:40:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/worker/worker-2.3.1.ebuild,v 1.7 2002/11/30 21:40:40 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone."
SRC_URI="http://www.boomerangsworld.de/worker/downloads/${P}.tar.bz2"
-HOMEPAGE="http://www.boomerangsworld.de/worker"
+HOMEPAGE="http://www.boomerangsworld.de/worker/"
SLOT="0"
LICENSE="GPL-2"
@@ -14,12 +13,11 @@ KEYWORDS="x86"
DEPEND="virtual/x11"
src_compile() {
- econf || die
+ econf
emake || die "Parallel make failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "Installation failed"
-
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS
}
diff --git a/app-misc/worker/worker-2.7.0.ebuild b/app-misc/worker/worker-2.7.0.ebuild
index 47aaae03ccfc..5a255989a08d 100644
--- a/app-misc/worker/worker-2.7.0.ebuild
+++ b/app-misc/worker/worker-2.7.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/worker/worker-2.7.0.ebuild,v 1.1 2002/10/27 01:11:51 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/worker/worker-2.7.0.ebuild,v 1.2 2002/11/30 21:41:19 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone."
SRC_URI="http://www.boomerangsworld.de/worker/downloads/${P}.tar.bz2"
-HOMEPAGE="http://www.boomerangsworld.de/worker"
+HOMEPAGE="http://www.boomerangsworld.de/worker/"
SLOT="0"
LICENSE="GPL-2"
@@ -14,12 +13,11 @@ KEYWORDS="~x86"
DEPEND="virtual/x11"
src_compile() {
- econf || die "configure problem"
+ econf
emake || die "compile problem"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install problem"
-
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS
}