summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-08-28 11:31:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-08-28 11:31:11 +0000
commitbc6f810ab57d637fd0948a71378fdece3789b745 (patch)
treeefccb71fdb572f7bf290eef14dfb9640d4ef73d5
parentChange version scheme (diff)
downloadgentoo-2-bc6f810ab57d637fd0948a71378fdece3789b745.tar.gz
gentoo-2-bc6f810ab57d637fd0948a71378fdece3789b745.tar.bz2
gentoo-2-bc6f810ab57d637fd0948a71378fdece3789b745.zip
Bump to latest version. Punt older. Add patch for binaries installation.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
-rw-r--r--net-analyzer/nmapsi/ChangeLog12
-rw-r--r--net-analyzer/nmapsi/files/0.2.1-install-binaries.patch26
-rw-r--r--net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch188
-rw-r--r--net-analyzer/nmapsi/metadata.xml2
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.2.1.ebuild (renamed from net-analyzer/nmapsi/nmapsi-0.2_beta3.ebuild)17
-rw-r--r--net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild35
6 files changed, 45 insertions, 235 deletions
diff --git a/net-analyzer/nmapsi/ChangeLog b/net-analyzer/nmapsi/ChangeLog
index d05773c640cf..037bbdadaaa4 100644
--- a/net-analyzer/nmapsi/ChangeLog
+++ b/net-analyzer/nmapsi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/nmapsi
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.4 2010/10/08 08:04:16 wired Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/ChangeLog,v 1.5 2011/08/28 11:31:10 scarabeus Exp $
+
+*nmapsi-0.2.1 (28 Aug 2011)
+
+ 28 Aug 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.2.1-install-binaries.patch, -nmapsi-0.2_alpha3.ebuild,
+ -nmapsi-0.2_beta3.ebuild, +nmapsi-0.2.1.ebuild,
+ -files/nmapsi-0.2_alpha3-gcc45.patch, metadata.xml:
+ Bump to latest version. Punt older. Add patch for binaries installation.
*nmapsi-0.2_beta3 (08 Oct 2010)
diff --git a/net-analyzer/nmapsi/files/0.2.1-install-binaries.patch b/net-analyzer/nmapsi/files/0.2.1-install-binaries.patch
new file mode 100644
index 000000000000..f76c32af841d
--- /dev/null
+++ b/net-analyzer/nmapsi/files/0.2.1-install-binaries.patch
@@ -0,0 +1,26 @@
+diff -urN nmapsi4-0.2.1.old/nmapsi4/CMakeLists.txt nmapsi4-0.2.1/nmapsi4/CMakeLists.txt
+--- nmapsi4-0.2.1.old/nmapsi4/CMakeLists.txt 2011-08-28 13:25:03.415019910 +0200
++++ nmapsi4-0.2.1/nmapsi4/CMakeLists.txt 2011-08-28 13:27:13.995019092 +0200
+@@ -120,8 +120,8 @@
+
+
+ if (Q_WS_X11)
++ install(TARGETS nmapsi4 DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+ install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/nmapsi4/locale)
+- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/nmapsi4" DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+ install(FILES "kde/nmapsi4.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
+ install(FILES "kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
+ install(FILES "../icons/16x16/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps/)
+diff -urN nmapsi4-0.2.1.old/nmapsi4-logr/CMakeLists.txt nmapsi4-0.2.1/nmapsi4-logr/CMakeLists.txt
+--- nmapsi4-0.2.1.old/nmapsi4-logr/CMakeLists.txt 2011-08-28 13:25:03.405019910 +0200
++++ nmapsi4-0.2.1/nmapsi4-logr/CMakeLists.txt 2011-08-28 13:27:51.915018855 +0200
+@@ -66,8 +66,8 @@
+
+
+ if (Q_WS_X11)
++ install(TARGETS nmapsi4-logr DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+ install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/nmapsi4/locale)
+- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/nmapsi4-logr" DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)
+ install(FILES "src/nmapsi4-logr.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
+ # install(FILES "src/kde/nmapsi4-admin.desktop" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/applications/kde/)
+ # install(FILES "icons/16x16/nmapsi4.png" DESTINATION ${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/16x16/apps/)
diff --git a/net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch b/net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch
deleted file mode 100644
index 692af44ee794..000000000000
--- a/net-analyzer/nmapsi/files/nmapsi-0.2_alpha3-gcc45.patch
+++ /dev/null
@@ -1,188 +0,0 @@
-diff -ur nmapsi4-0.2-alpha3.orig/lib/history/loghistory.cpp nmapsi4-0.2-alpha3/lib/history/loghistory.cpp
---- nmapsi4-0.2-alpha3.orig/lib/history/loghistory.cpp 2010-01-14 18:37:42.000000000 +0200
-+++ nmapsi4-0.2-alpha3/lib/history/loghistory.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -105,7 +105,7 @@
- qDeleteAll(ItemListHistory);
- ItemListHistory.clear();
- logTree->clear();
-- logTree->setIconSize(QSize::QSize(32, 32));
-+ logTree->setIconSize(QSize(32, 32));
-
- QFile *tmpFile = new QFile();
- short index = 0;
-@@ -166,7 +166,7 @@
- qDeleteAll(ItemListHistory);
- ItemListHistory.clear();
- logTree->clear();
-- logTree->setIconSize(QSize::QSize(22, 22));
-+ logTree->setIconSize(QSize(22, 22));
-
- if (!urlList.isEmpty() && urlList.first().compare("NULL") && urlListTime.first().compare("NULL")) {
- #ifndef HISTORY_NO_DEBUG
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/digSupport/digSupport.cpp nmapsi4-0.2-alpha3/nmapsi4/core/digSupport/digSupport.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4/core/digSupport/digSupport.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4/core/digSupport/digSupport.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -88,7 +88,7 @@
- QTextStream stream1(&buff1);
- QString line;
-
-- Wview->setIconSize(QSize::QSize(32, 32));
-+ Wview->setIconSize(QSize(32, 32));
- QTreeWidgetItem *rootLook = new QTreeWidgetItem(Wview);
- itemList.push_front(rootLook);
-
-@@ -107,7 +107,7 @@
- #endif
- itemLook = new QTreeWidgetItem(rootLook);
- itemList.push_front(itemLook);
-- itemLook->setSizeHint(0, QSize::QSize(22, 22));
-+ itemLook->setSizeHint(0, QSize(22, 22));
- itemLook->setIcon(0, QIcon(QString::fromUtf8(":/images/images/view-web-browser-dom-tree.png")));
- itemLook->setText(0,line);
- if(!resultFlag) {
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/hostCheck.cpp nmapsi4-0.2-alpha3/nmapsi4/core/hostCheck.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4/core/hostCheck.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4/core/hostCheck.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -30,7 +30,7 @@
- this->delMonitorHost(scanMonitor,hostname);
- return;
- }
-- treeLookup->setIconSize(QSize::QSize(32, 32));
-+ treeLookup->setIconSize(QSize(32, 32));
- treeLookup->header()->setResizeMode(0, QHeaderView::Interactive);
-
- rootLook = new QTreeWidgetItem(treeLookup);
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/nmapParser.cpp nmapsi4-0.2-alpha3/nmapsi4/core/nmapParser.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4/core/nmapParser.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4/core/nmapParser.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -187,17 +187,17 @@
- *out << nmap_command << endl << endl;
- }
-
-- listWscan->setIconSize(QSize::QSize(32, 32));
-+ listWscan->setIconSize(QSize(32, 32));
- listWscan->header()->setResizeMode(0, QHeaderView::Interactive);
-- listScanError->setIconSize(QSize::QSize(32, 32));
-+ listScanError->setIconSize(QSize(32, 32));
- listScanError->header()->setResizeMode(0, QHeaderView::Interactive);
-- listScan->setIconSize(QSize::QSize(32, 32));
-+ listScan->setIconSize(QSize(32, 32));
- listScan->header()->setResizeMode(0, QHeaderView::Interactive);
-- treeWinfo->setIconSize(QSize::QSize(32, 32));
-+ treeWinfo->setIconSize(QSize(32, 32));
- treeWinfo->header()->setResizeMode(0, QHeaderView::Interactive);
-- treeTraceroot->setIconSize(QSize::QSize(32, 32));
-+ treeTraceroot->setIconSize(QSize(32, 32));
- treeTraceroot->header()->setResizeMode(0, QHeaderView::Interactive);
-- treeNSS->setIconSize(QSize::QSize(32, 32));
-+ treeNSS->setIconSize(QSize(32, 32));
- treeNSS->header()->setResizeMode(0, QHeaderView::Interactive);
-
- int tmpBox = toolBox->currentIndex();
-@@ -270,16 +270,16 @@
- || b2_line.contains("unfiltered")) {
-
- if (b2_line.contains("filtered") || b2_line.contains("unfiltered")) {
-- item2->setSizeHint(0, QSize::QSize(22, 22));
-+ item2->setSizeHint(0, QSize(22, 22));
- item2->setIcon(0, QIcon(QString::fromUtf8(":/images/images/flag_yellow.png")));
- filtered_port++;
- } else {
-- item2->setSizeHint(0, QSize::QSize(22, 22));
-+ item2->setSizeHint(0, QSize(22, 22));
- item2->setIcon(0, QIcon(QString::fromUtf8(":/images/images/flag_green.png")));
- open_port++;
- }
- } else {
-- item2->setSizeHint(0, QSize::QSize(22, 22));
-+ item2->setSizeHint(0, QSize(22, 22));
- item2->setIcon(0, QIcon(QString::fromUtf8(":/images/images/flag_red.png")));
- close_port++;
- }
-@@ -392,7 +392,7 @@
- itemList.push_front(infoItemObj); // reference to address
-
- if (!b3_line.isEmpty()) {
-- infoItemObj->setSizeHint(0, QSize::QSize(22, 22));
-+ infoItemObj->setSizeHint(0, QSize(22, 22));
- infoItemObj->setIcon(0, QIcon(QString::fromUtf8(":/images/images/messagebox_info.png")));
- infoItemObj->setText(0, b3_line);
- infoItemObj->setToolTip(0, b3_line); // field information
-@@ -451,7 +451,7 @@
- }
- // ------------------------------------------------------------------------
-
-- infoTracerootObj->setSizeHint(0, QSize::QSize(22, 22));
-+ infoTracerootObj->setSizeHint(0, QSize(22, 22));
- infoTracerootObj->setIcon(0, QIcon(QString::fromUtf8(":/images/images/traceroute.png")));
- if ((PFile) && (!verboseLog)) *out << infoTracerootObj->text(0) << endl;
- }
-@@ -475,7 +475,7 @@
- infoNSSObj = new QTreeWidgetItem(infoNSS);
- itemList.push_front(infoNSSObj);
-
-- infoNSSObj->setSizeHint(0, QSize::QSize(22, 22));
-+ infoNSSObj->setSizeHint(0, QSize(22, 22));
- infoNSSObj->setIcon(0, QIcon(QString::fromUtf8(":/images/images/traceroute.png")));
- infoNSSObj->setText(0, bNSS_line);
- infoNSSObj->setToolTip(0, bNSS_line); // field information
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/resizeNmapsi4.cpp nmapsi4-0.2-alpha3/nmapsi4/core/resizeNmapsi4.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4/core/resizeNmapsi4.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4/core/resizeNmapsi4.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -96,7 +96,7 @@
-
- void nmapClass::optionListCreate() {
-
-- optionsListScan->setIconSize(QSize::QSize(52, 52));
-+ optionsListScan->setIconSize(QSize(52, 52));
-
- scanW = new QListWidgetItem(optionsListScan);
- scanW->setIcon(QIcon(QString::fromUtf8(":/images/images/viewmag.png")));
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/core/scanMonitor.cpp nmapsi4-0.2-alpha3/nmapsi4/core/scanMonitor.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4/core/scanMonitor.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4/core/scanMonitor.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -20,7 +20,7 @@
- #include "../mainwin.h"
-
- void nmapClass::addMonitorHost(QTreeWidget* monitor, const QString host) {
-- scanMonitor->setIconSize(QSize::QSize(32, 32));
-+ scanMonitor->setIconSize(QSize(32, 32));
- scanMonitor->header()->setResizeMode(0, QHeaderView::Interactive);
- tabWidget->setTabIcon(2,QIcon(QString::fromUtf8(":/images/images/reload.png")));
- QTreeWidgetItem *hostThread = new QTreeWidgetItem(monitor);
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/preference/listExtension.cpp nmapsi4-0.2-alpha3/nmapsi4/preference/listExtension.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4/preference/listExtension.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4/preference/listExtension.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -26,7 +26,7 @@
- vulnExt = extension.value("vulnFlag", "false").toBool();
- extList->clear(); // clear listWidget for reload use
-
-- extList->setIconSize(QSize::QSize(48, 48));
-+ extList->setIconSize(QSize(48, 48));
- QIcon imgA = QIcon(QString::fromUtf8(":/images/nmapsi4/preference/images/preferences-pluginA.png"));
- QIcon imgD = QIcon(QString::fromUtf8(":/images/nmapsi4/preference/images/preferences-pluginD.png"));
-
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4/preference/profilemain.cpp nmapsi4-0.2-alpha3/nmapsi4/preference/profilemain.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4/preference/profilemain.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4/preference/profilemain.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -90,7 +90,7 @@
-
- // Create listview items
- // TODO insert history item and window setup
-- listViewOptions->setIconSize(QSize::QSize(52, 52));
-+ listViewOptions->setIconSize(QSize(52, 52));
-
- profileItem = new QListWidgetItem(listViewOptions);
- profileItem->setIcon(QIcon(QString::fromUtf8(":/images/images/preferences-system-windows.png")));
-diff -ur nmapsi4-0.2-alpha3.orig/nmapsi4-logr/mainwin.cpp nmapsi4-0.2-alpha3/nmapsi4-logr/mainwin.cpp
---- nmapsi4-0.2-alpha3.orig/nmapsi4-logr/mainwin.cpp 2010-01-14 18:37:43.000000000 +0200
-+++ nmapsi4-0.2-alpha3/nmapsi4-logr/mainwin.cpp 2010-05-06 13:13:18.000000000 +0300
-@@ -99,7 +99,7 @@
- QTextStream buffer(logF);
- QString tmpLine;
-
-- treeLogView->setIconSize(QSize::QSize(32, 32));
-+ treeLogView->setIconSize(QSize(32, 32));
-
- while (!buffer.atEnd()) {
- tmpLine = buffer.readLine();
diff --git a/net-analyzer/nmapsi/metadata.xml b/net-analyzer/nmapsi/metadata.xml
index 3cbebd85b7e2..ab02f994fdd2 100644
--- a/net-analyzer/nmapsi/metadata.xml
+++ b/net-analyzer/nmapsi/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>qt</herd>
+ <herd>qt</herd>
</pkgmetadata>
diff --git a/net-analyzer/nmapsi/nmapsi-0.2_beta3.ebuild b/net-analyzer/nmapsi/nmapsi-0.2.1.ebuild
index f35a907029c7..9c006c1976ac 100644
--- a/net-analyzer/nmapsi/nmapsi-0.2_beta3.ebuild
+++ b/net-analyzer/nmapsi/nmapsi-0.2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.2_beta3.ebuild,v 1.1 2010/10/08 08:04:16 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.2.1.ebuild,v 1.1 2011/08/28 11:31:11 scarabeus Exp $
-EAPI=2
-inherit cmake-utils eutils
+EAPI=4
+inherit base cmake-utils
MY_P=${PN}4-${PV/_/-}
@@ -23,9 +23,8 @@ RDEPEND="${DEPEND}
S=${WORKDIR}/${MY_P}
-DOCS="AUTHORS NEWS README TODO Translation"
+DOCS=( AUTHORS NEWS README TODO Translation )
-src_install() {
- cmake-utils_src_install
- fperms 755 /usr/bin/nmapsi4{,-logr}
-}
+PATCHES=(
+ "${FILESDIR}/0.2.1-install-binaries.patch"
+)
diff --git a/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild b/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild
deleted file mode 100644
index d59d59fa5dd8..000000000000
--- a/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmapsi/nmapsi-0.2_alpha3.ebuild,v 1.2 2010/05/06 10:14:30 ssuominen Exp $
-
-EAPI=2
-inherit cmake-utils eutils
-
-MY_P=${PN}4-${PV/_/-}
-
-DESCRIPTION="A Qt4 frontend to nmap"
-HOMEPAGE="http://www.nmapsi4.org/"
-SRC_URI="http://nmapsi4.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND="x11-libs/qt-gui:4
- x11-libs/qt-webkit:4"
-RDEPEND="${DEPEND}
- net-analyzer/nmap"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS="AUTHORS NEWS README TODO Translation"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc45.patch
-}
-
-src_install() {
- cmake-utils_src_install
- fperms 755 /usr/bin/nmapsi4{,-logr}
-}