summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2009-05-02 18:28:38 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2009-05-02 18:28:38 +0000
commitbd834270809ecb4d392b1abd18ee3fd6075ee403 (patch)
tree7491db5b53cb374dd1279f7556e0c2b9b6c040ab
parentBlock g-p-m-2.24-4-r1 and less, due to policy file conflict (diff)
downloadgentoo-2-bd834270809ecb4d392b1abd18ee3fd6075ee403.tar.gz
gentoo-2-bd834270809ecb4d392b1abd18ee3fd6075ee403.tar.bz2
gentoo-2-bd834270809ecb4d392b1abd18ee3fd6075ee403.zip
new developer branch
(Portage version: 2.1.6.11/cvs/Linux i686, RepoMan options: --force)
-rw-r--r--media-tv/w_scan/ChangeLog9
-rw-r--r--media-tv/w_scan/files/w_scan-20090502-build-and-path-fixes.patch48
-rw-r--r--media-tv/w_scan/w_scan-20090502.ebuild38
3 files changed, 94 insertions, 1 deletions
diff --git a/media-tv/w_scan/ChangeLog b/media-tv/w_scan/ChangeLog
index 2e2f2694fc9f..5431e1d911c6 100644
--- a/media-tv/w_scan/ChangeLog
+++ b/media-tv/w_scan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/w_scan
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.9 2009/05/02 13:43:32 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.10 2009/05/02 18:28:38 hd_brummy Exp $
+
+*w_scan-20090502 (02 May 2009)
+
+ 02 May 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +w_scan-20090502.ebuild,
+ +files/w_scan-20090502-build-and-path-fixes.patch:
+ new developer branch
02 May 2009; Joerg Bornkessel <hd_brummy@gentoo.org>
w_scan-20081106.ebuild, metadata.xml:
diff --git a/media-tv/w_scan/files/w_scan-20090502-build-and-path-fixes.patch b/media-tv/w_scan/files/w_scan-20090502-build-and-path-fixes.patch
new file mode 100644
index 000000000000..f15aca4ca78b
--- /dev/null
+++ b/media-tv/w_scan/files/w_scan-20090502-build-and-path-fixes.patch
@@ -0,0 +1,48 @@
+* Honour CC, CFLAGS, LDFLAGS and DESTDIR.
+* Use absolute paths so it doesn't assume w_scan is ran from the build dir.
+* Joerg Bornkessel <hd_brummy@gentoo.org> 2009 May 02
+diff -Naur w_scan-20090502.orig/Makefile w_scan-20090502/Makefile
+--- w_scan-20090502.orig/Makefile 2009-05-02 15:51:09.203776903 +0200
++++ w_scan-20090502/Makefile 2009-05-02 15:55:27.847392092 +0200
+@@ -1,7 +1,7 @@
+
+-CC = gcc
+-CFLAGS = -MD -g -Wall -O2
+-LFLAGS = -g -Wall
++CC ?= gcc
++CFLAGS ?= -MD -g -Wall -O2
++LDFLAGS ?= -g -Wall
+
+ OBJS = dump-vdr.o dump-xine.o dump-dvbscan.o dump-kaffeine.o scan.o section.o atsc_psip_section.o countries.o
+ OBJS += dvbscan.o parse-dvbscan.o descriptors.o satellites.o lnb.o diseqc.o
+@@ -12,6 +12,9 @@
+ OLDVERSION = $(shell sed -n '/SCRIPT_VERSION="/p' w_scan_start.sh | sed -e 's/SCRIPT_VERSION=//' | sed -e 's/;//')
+ TMPDIR = w_scan-$(VERSION)
+
++BINDIR = /usr/bin
++SHAREDIR = /usr/share/w_scan
++
+ $(TARGET): $(OBJS)
+ $(CC) $(LFLAGS) -o $(TARGET) $(OBJS)
+ $(RM) *.o *.d
+@@ -40,13 +44,13 @@
+ echo "" >> version.h
+
+ install:
+- install -m 755 $(TARGET) /usr/bin
+- install -m 755 w_scan_start.sh /usr/bin
+- mkdir -p /usr/share/w_scan
+- install pci.ids /usr/share/w_scan
+- install pci.classes /usr/share/w_scan
+- install usb.ids /usr/share/w_scan
+- install usb.classes /usr/share/w_scan
++ @mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(SHAREDIR)
++ install -m 755 $(TARGET) $(DESTDIR)$(BINDIR)
++ install -m 755 w_scan_start.sh $(DESTDIR)$(BINDIR)
++ install pci.ids $(DESTDIR)$(SHAREDIR)
++ install pci.classes $(DESTDIR)$(SHAREDIR)
++ install usb.ids $(DESTDIR)$(SHAREDIR)
++ install usb.classes $(DESTDIR)$(SHAREDIR)
+
+ dist: version scriptversion createpackage
+
diff --git a/media-tv/w_scan/w_scan-20090502.ebuild b/media-tv/w_scan/w_scan-20090502.ebuild
new file mode 100644
index 000000000000..947292e38b93
--- /dev/null
+++ b/media-tv/w_scan/w_scan-20090502.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/w_scan-20090502.ebuild,v 1.1 2009/05/02 18:28:38 hd_brummy Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Scan for DVB-C/DVB-T/DVB-C channels without prior knowledge of frequencies and modulations"
+HOMEPAGE="http://wirbel.htpc-forum.de/w_scan/index2.html"
+SRC_URI="http://wirbel.htpc-forum.de/w_scan/dev/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-tv/linuxtv-dvb-headers"
+RDEPEND="${DEPEND}
+ >=sys-kernel/linux-headers-2.6.29"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build-and-path-fixes.patch"
+ emake clean || die "emake clean failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ echo
+ elog "This is a new developer branch an need some tests"
+ elog "with different DVB-S Cards, LNB's, diseqc switches ..."
+ echo
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=268320"
+}