summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-08-22 02:25:13 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-08-22 02:25:13 +0000
commitbdca3e62b81f1ee6f0070a050b94b49152d6ce9d (patch)
treeecae75a325076c4be759a9e7250cf338d2e6faae
parentThis is the experimental objprelink for qt/kde. Support for all other kde pac... (diff)
downloadgentoo-2-bdca3e62b81f1ee6f0070a050b94b49152d6ce9d.tar.gz
gentoo-2-bdca3e62b81f1ee6f0070a050b94b49152d6ce9d.tar.bz2
gentoo-2-bdca3e62b81f1ee6f0070a050b94b49152d6ce9d.zip
gettext tries to install some emacs .el files even if emacs is not
merged. /usr/bin/emacs exists, though.
-rw-r--r--sys-devel/gettext/files/gettext-0.10.38-gentoo.diff22
-rw-r--r--sys-devel/gettext/gettext-0.10.38.ebuild12
2 files changed, 33 insertions, 1 deletions
diff --git a/sys-devel/gettext/files/gettext-0.10.38-gentoo.diff b/sys-devel/gettext/files/gettext-0.10.38-gentoo.diff
new file mode 100644
index 000000000000..f6339550a79e
--- /dev/null
+++ b/sys-devel/gettext/files/gettext-0.10.38-gentoo.diff
@@ -0,0 +1,22 @@
+diff -r -C2 gettext-0.10.38.orig/misc/Makefile.in gettext-0.10.38/misc/Makefile.in
+*** gettext-0.10.38.orig/misc/Makefile.in Wed May 23 16:54:14 2001
+--- gettext-0.10.38/misc/Makefile.in Tue Aug 21 22:05:17 2001
+***************
+*** 176,183 ****
+ done
+ .el.elc:
+! @echo 'WARNING: Warnings can be ignored. :-)'
+! if test $(EMACS) != no; then \
+! EMACS=$(EMACS) $(SHELL) $(srcdir)/elisp-comp $<; \
+! fi
+
+ mostlyclean-lisp:
+--- 176,183 ----
+ done
+ .el.elc:
+! #@echo 'WARNING: Warnings can be ignored. :-)'
+! #if test $(EMACS) != no; then \
+! # EMACS=$(EMACS) $(SHELL) $(srcdir)/elisp-comp $<; \
+! #fi
+
+ mostlyclean-lisp:
diff --git a/sys-devel/gettext/gettext-0.10.38.ebuild b/sys-devel/gettext/gettext-0.10.38.ebuild
index 6f1fe55773cf..baa397e7427a 100644
--- a/sys-devel/gettext/gettext-0.10.38.ebuild
+++ b/sys-devel/gettext/gettext-0.10.38.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.10.38.ebuild,v 1.3 2001/06/18 12:31:06 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.10.38.ebuild,v 1.4 2001/08/22 02:25:13 chadh Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -14,6 +14,16 @@ if [ -z "`use build`" ] ; then
DEPEND="virtual/glibc"
fi
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ # this patch stops gettext from installing some emacs .el
+ # files. The problem with this is that it tries to use
+ # /usr/bin/emacs, which is a link to e3em in the build
+ # system.
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
src_compile() {
local myconf
if [ -z "`use nls`" ]