summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-01-30 06:47:52 +0000
committerUlrich Müller <ulm@gentoo.org>2009-01-30 06:47:52 +0000
commitbfa62e38ccf425303cde29c37a065503dd64b7d5 (patch)
treeb1fb17c95af0d1f41d59f97d215b75b65d527a76
parentuse emake for install (diff)
downloadgentoo-2-bfa62e38ccf425303cde29c37a065503dd64b7d5.tar.gz
gentoo-2-bfa62e38ccf425303cde29c37a065503dd64b7d5.tar.bz2
gentoo-2-bfa62e38ccf425303cde29c37a065503dd64b7d5.zip
Version bump. Remove missing file from dodoc arguments, bug 256683.
(Portage version: 2.2_rc23/cvs/Linux i686)
-rw-r--r--app-emacs/proofgeneral/ChangeLog10
-rw-r--r--app-emacs/proofgeneral/proofgeneral-3.7.1.ebuild45
-rw-r--r--app-emacs/proofgeneral/proofgeneral-3.7.ebuild8
3 files changed, 57 insertions, 6 deletions
diff --git a/app-emacs/proofgeneral/ChangeLog b/app-emacs/proofgeneral/ChangeLog
index f32f32230ce0..c4f8ac1f04f9 100644
--- a/app-emacs/proofgeneral/ChangeLog
+++ b/app-emacs/proofgeneral/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/proofgeneral
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/ChangeLog,v 1.24 2008/12/06 17:23:50 fauli Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/ChangeLog,v 1.25 2009/01/30 06:47:52 ulm Exp $
+
+*proofgeneral-3.7.1 (30 Jan 2009)
+
+ 30 Jan 2009; Ulrich Mueller <ulm@gentoo.org> proofgeneral-3.7.ebuild,
+ +proofgeneral-3.7.1.ebuild:
+ Version bump. Remove missing file from dodoc arguments, bug 256683.
06 Dec 2008; Christian Faulhammer <fauli@gentoo.org>
-files/proofgeneral-3.5_isabelle-non-interactive.patch,
diff --git a/app-emacs/proofgeneral/proofgeneral-3.7.1.ebuild b/app-emacs/proofgeneral/proofgeneral-3.7.1.ebuild
new file mode 100644
index 000000000000..783877b567ab
--- /dev/null
+++ b/app-emacs/proofgeneral/proofgeneral-3.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/proofgeneral-3.7.1.ebuild,v 1.1 2009/01/30 06:47:52 ulm Exp $
+
+inherit elisp
+
+MY_PN="ProofGeneral"
+DESCRIPTION="A generic interface for proof assistants"
+HOMEPAGE="http://proofgeneral.inf.ed.ac.uk/"
+SRC_URI="http://proofgeneral.inf.ed.ac.uk/releases/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake compile EMACS=emacs
+}
+
+src_install() {
+ emake install EMACS=emacs PREFIX="${D}"/usr
+
+ dohtml doc/*.html doc/*.jpg
+ doinfo doc/*.info*
+ dodoc AUTHORS BUGS CHANGES COMPATIBILITY FAQ FUTURE INSTALL README REGISTER
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" ${MY_PN} \
+ || die "elisp-site-file-install failed"
+
+ # clean up
+ rm -rf "${D}/usr/share/emacs/site-lisp/site-start.d"
+ rm -rf "${D}/usr/share/application-registry"
+ rm -rf "${D}/usr/share/mime-info"
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please register your use of Proof General on the web at:"
+ elog " http://proofgeneral.inf.ed.ac.uk/register "
+ elog "(see the REGISTER file for more information)"
+}
diff --git a/app-emacs/proofgeneral/proofgeneral-3.7.ebuild b/app-emacs/proofgeneral/proofgeneral-3.7.ebuild
index a58a2baa0dfd..dd6bd8f37fb4 100644
--- a/app-emacs/proofgeneral/proofgeneral-3.7.ebuild
+++ b/app-emacs/proofgeneral/proofgeneral-3.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/proofgeneral-3.7.ebuild,v 1.4 2008/04/12 08:58:07 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/proofgeneral/proofgeneral-3.7.ebuild,v 1.5 2009/01/30 06:47:52 ulm Exp $
inherit elisp
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ppc x86"
IUSE=""
S="${WORKDIR}/${MY_PN}-${PV}"
-SITEFILE=50${PN}-gentoo.el
+SITEFILE="50${PN}-gentoo.el"
src_compile() {
emake compile EMACS=emacs
@@ -26,7 +26,7 @@ src_install() {
dohtml doc/*.html doc/*.jpg
doinfo doc/*.info*
- dodoc AUTHORS BUGS CHANGES COMPATIBILITY FAQ INSTALL README REGISTER TODO
+ dodoc AUTHORS BUGS CHANGES COMPATIBILITY FAQ INSTALL README REGISTER
elisp-site-file-install "${FILESDIR}/${SITEFILE}" ${MY_PN} \
|| die "elisp-site-file-install failed"