summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-04-11 15:12:26 +0000
committerJim Ramsay <lack@gentoo.org>2008-04-11 15:12:26 +0000
commitc12fd7747beeda285acc28d98323cda5cd9dda4e (patch)
tree7b04b0d5f4e5f3b207f6c30b223bf96d96f52fd2
parentStable on ppc64; bug #217075 (diff)
downloadgentoo-2-c12fd7747beeda285acc28d98323cda5cd9dda4e.tar.gz
gentoo-2-c12fd7747beeda285acc28d98323cda5cd9dda4e.tar.bz2
gentoo-2-c12fd7747beeda285acc28d98323cda5cd9dda4e.zip
Fixes build problems with fftw-2 by using fftw-3 instead (Bug 204569)
(Portage version: 2.1.4.1)
-rw-r--r--x11-plugins/gkrellmss/ChangeLog9
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/x11-plugins/gkrellmss/ChangeLog b/x11-plugins/gkrellmss/ChangeLog
index 4df911823c0c..f58ff446f042 100644
--- a/x11-plugins/gkrellmss/ChangeLog
+++ b/x11-plugins/gkrellmss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrellmss
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/ChangeLog,v 1.25 2007/06/12 21:07:35 lack Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/ChangeLog,v 1.26 2008/04/11 15:12:26 lack Exp $
+
+*gkrellmss-2.6-r1 (11 Apr 2008)
+
+ 11 Apr 2008; Jim Ramsay <lack@gentoo.org> +gkrellmss-2.6-r1.ebuild:
+ Fixes build problems with fftw-2 by using fftw-3 instead (Bug 204569)
12 Jun 2007; Jim Ramsay <lack@gentoo.org> -gkrellmss-2.3.ebuild,
-gkrellmss-2.4.ebuild:
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
new file mode 100644
index 000000000000..d3cd1fba0730
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild,v 1.1 2008/04/11 15:12:26 lack Exp $
+
+inherit gkrellm-plugin
+
+IUSE="alsa esd nls"
+
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
+SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+
+RDEPEND="=sci-libs/fftw-3*
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )"
+
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+PLUGIN_SO="src/gkrellmss.so"
+PLUGIN_DOCS="Themes"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="${myconf} enable_nls=1"
+
+ addpredict /dev/snd
+ emake ${myconf} || die
+}