summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 23:26:25 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 23:26:25 +0000
commitc432f200cec511839a5fa9ae2ff6dc3b27a59ce4 (patch)
treefc0b4122dc8610b3cd6ed7ccaf04e7c81bc433b5
parentReorder mainainters. (diff)
downloadgentoo-2-c432f200cec511839a5fa9ae2ff6dc3b27a59ce4.tar.gz
gentoo-2-c432f200cec511839a5fa9ae2ff6dc3b27a59ce4.tar.bz2
gentoo-2-c432f200cec511839a5fa9ae2ff6dc3b27a59ce4.zip
Fix UMS unresolved symbol when loading radeon in xorg-server-1.12.
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-pcitag.patch41
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3-r1.ebuild31
3 files changed, 79 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 1e801d03b2cb..11a01febd023 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.163 2012/03/08 00:54:03 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.164 2012/03/18 23:26:25 chithanh Exp $
+
+*xf86-video-ati-6.14.3-r1 (18 Mar 2012)
+
+ 18 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-video-ati-6.14.3-pcitag.patch, +xf86-video-ati-6.14.3-r1.ebuild:
+ Fix UMS unresolved symbol when loading radeon in xorg-server-1.12.
08 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
xf86-video-ati-6.14.3.ebuild,
diff --git a/x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-pcitag.patch b/x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-pcitag.patch
new file mode 100644
index 000000000000..96b2b815e7c2
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/xf86-video-ati-6.14.3-pcitag.patch
@@ -0,0 +1,41 @@
+From 89452c08048c98fb5cc3dc551b3824be40d52cf2 Mon Sep 17 00:00:00 2001
+From: Michel Dänzer <michel.daenzer@amd.com>
+Date: Tue, 08 Nov 2011 10:23:11 +0000
+Subject: UMS: Guard references to PCITAG / pciTag with XSERVER_LIBPCIACCESS (bug #42690)
+
+Should fix https://bugs.freedesktop.org/show_bug.cgi?id=42690 .
+
+Signed-off-by: Michel Dänzer <michel.daenzer@amd.com>
+---
+diff --git a/src/radeon.h b/src/radeon.h
+index da95f8b..34f6f53 100644
+--- a/src/radeon.h
++++ b/src/radeon.h
+@@ -792,7 +792,9 @@ struct radeon_accel_state {
+ typedef struct {
+ EntityInfoPtr pEnt;
+ pciVideoPtr PciInfo;
++#ifndef XSERVER_LIBPCIACCESS
+ PCITAG PciTag;
++#endif
+ int Chipset;
+ RADEONChipFamily ChipFamily;
+ RADEONErrata ChipErrata;
+diff --git a/src/radeon_driver.c b/src/radeon_driver.c
+index 293897a..a9abd66 100644
+--- a/src/radeon_driver.c
++++ b/src/radeon_driver.c
+@@ -3023,9 +3023,11 @@ Bool RADEONPreInit(ScrnInfoPtr pScrn, int flags)
+ }
+
+ info->PciInfo = xf86GetPciInfoForEntity(info->pEnt->index);
++#ifndef XSERVER_LIBPCIACCESS
+ info->PciTag = pciTag(PCI_DEV_BUS(info->PciInfo),
+ PCI_DEV_DEV(info->PciInfo),
+ PCI_DEV_FUNC(info->PciInfo));
++#endif
+ info->MMIOAddr = PCI_REGION_BASE(info->PciInfo, 2, REGION_MEM) & ~0xffULL;
+ info->MMIOSize = PCI_REGION_SIZE(info->PciInfo, 2);
+ xf86DrvMsg(pScrn->scrnIndex, X_INFO, "TOTO SAYS %016llx\n",
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3-r1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3-r1.ebuild
new file mode 100644
index 000000000000..fefa97fc6a2f
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.14.3-r1.ebuild,v 1.1 2012/03/18 23:26:25 chithanh Exp $
+
+EAPI=4
+
+XORG_EAUTORECONF=yes
+XORG_DRI=always
+inherit xorg-2
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libdrm[video_cards_radeon]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.14.3-xorg-server-1.12.patch
+ "${FILESDIR}"/${PN}-6.14.3-pcitag.patch
+)
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ --enable-dri
+ --enable-kms
+ --enable-exa
+ )
+}