summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-02-19 11:48:54 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-02-19 11:48:54 +0000
commitc7ab217eee1bc19671843b60916ad819b1dff4a5 (patch)
tree1424b204556117c57ea8470b9874b19cdfd37bf1
parentVersion bump. (diff)
downloadgentoo-2-c7ab217eee1bc19671843b60916ad819b1dff4a5.tar.gz
gentoo-2-c7ab217eee1bc19671843b60916ad819b1dff4a5.tar.bz2
gentoo-2-c7ab217eee1bc19671843b60916ad819b1dff4a5.zip
Version bump. Fix also live. Add new useflag.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--net-irc/quassel/ChangeLog8
-rw-r--r--net-irc/quassel/metadata.xml4
-rw-r--r--net-irc/quassel/quassel-0.3.1-r2.ebuild4
-rw-r--r--net-irc/quassel/quassel-0.4.0.ebuild131
-rw-r--r--net-irc/quassel/quassel-9999.ebuild14
5 files changed, 151 insertions, 10 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 9b57f51b3b71..f34ed9934092 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.43 2009/01/25 14:02:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.44 2009/02/19 11:48:54 scarabeus Exp $
+
+*quassel-0.4.0 (19 Feb 2009)
+
+ 19 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org> metadata.xml,
+ +quassel-0.4.0.ebuild, quassel-9999.ebuild:
+ Version bump. Fix also live. Add new useflag.
25 Jan 2009; Raúl Porcel <armin76@gentoo.org> quassel-0.3.0.3.ebuild:
Drop ~sparc
diff --git a/net-irc/quassel/metadata.xml b/net-irc/quassel/metadata.xml
index 147c175d516c..b2edd897939b 100644
--- a/net-irc/quassel/metadata.xml
+++ b/net-irc/quassel/metadata.xml
@@ -16,6 +16,10 @@
client/server model. The server and X flags are not needed in this
case but it is possible to enable them too.
</flag>
+ <flag name="oxygen">
+ Install oxygen icons. Highly recommended for KDE-4.1 and KDE-4.2 (or
+ usage without kde). KDE-4.3 will ship the icons by default.
+ </flag>
<flag name="phonon">
Build client with phonon backend support. This enables sound
playback in client.
diff --git a/net-irc/quassel/quassel-0.3.1-r2.ebuild b/net-irc/quassel/quassel-0.3.1-r2.ebuild
index 8dd16180474e..034d77833b5c 100644
--- a/net-irc/quassel/quassel-0.3.1-r2.ebuild
+++ b/net-irc/quassel/quassel-0.3.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r2.ebuild,v 1.2 2008/12/31 03:39:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r2.ebuild,v 1.3 2009/02/19 11:48:54 scarabeus Exp $
EAPI=1
diff --git a/net-irc/quassel/quassel-0.4.0.ebuild b/net-irc/quassel/quassel-0.4.0.ebuild
new file mode 100644
index 000000000000..184336c54ed1
--- /dev/null
+++ b/net-irc/quassel/quassel-0.4.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.0.ebuild,v 1.1 2009/02/19 11:48:54 scarabeus Exp $
+
+EAPI="2"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
+HOMEPAGE="http://quassel-irc.org/"
+SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
+
+LANGS="cs da de fr nb_NO ru tr"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+RDEPEND="
+ x11-libs/qt-core:4
+ dbus? ( x11-libs/qt-dbus:4 )
+ monolithic? (
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ !monolithic? (
+ server? (
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ )
+ X? (
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ )
+ ssl? (
+ dev-libs/openssl
+ x11-libs/qt-core:4[ssl]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6"
+
+DOCS="AUTHORS ChangeLog README"
+
+pkg_setup() {
+ if ! use monolithic && ! use server && ! use X ; then
+ eerror "You have to build at least one of the monolithic client (USE=monolithic),"
+ eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
+ die "monolithic, server and X flag unset."
+ fi
+}
+
+src_configure() {
+# Comment this out and invoke _common_configure_code and cmake manually until cmake-utils.eclass
+# supports space separated strings as arguments for cmake options or quassel changes the
+# separator. Until now multiple languages are not passed to -DLINGUAS and only the first
+# language is considered.
+ local mycmakeargs="$(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want X QTCLIENT)
+ $(cmake-utils_use_want monolithic MONO)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with oxygen OXYGEN)
+ $(cmake-utils_use_with ssl OPENSSL)
+ -DEMBED_DATA=OFF"
+
+ if use kde ; then
+ # We don't use our own phonon backend, so don't enable it; also use system icon themes
+ mycmakeargs="${mycmakeargs} -DWITH_PHONON=0"
+ else
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with phonon PHONON)"
+ fi
+
+ _common_configure_code
+
+ mkdir -p "${WORKDIR}"/${PN}_build
+ pushd "${WORKDIR}"/${PN}_build > /dev/null
+
+ cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
+ ${mycmakeargs} \
+ -DLINGUAS="${LINGUAS}" \
+ "${S}" || die "Cmake failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server ; then
+ newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
+ newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
+
+ insinto /usr/share/doc/${PF}
+ doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn
+ ewarn "In order to use the quassel init script you must set the"
+ ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
+ ewarn "Note: This is the user who runs the quasselcore and is independent"
+ ewarn "from the users you set up in the quasselclient."
+ elog
+ elog "Adding more than one user or changing username/password is not"
+ elog "possible via the quasselclient yet. If you need to do these things"
+ elog "you have to use the manageusers.py script, which has been installed in"
+ elog "/usr/share/doc/${PF}".
+ elog "Please make sure that the quasselcore is stopped before adding more users."
+ fi
+
+ if ( use server || use monolithic ) && use ssl ; then
+ elog
+ elog "To enable SSL support for client/core connections the quasselcore needs"
+ elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."
+ elog "To create the certificate use the following command:"
+ elog "openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout ~/.quassel/quasselCert.pem -out ~/.quassel/quasselCert.pem"
+ fi
+}
diff --git a/net-irc/quassel/quassel-9999.ebuild b/net-irc/quassel/quassel-9999.ebuild
index 07d2291fcc41..8f024065e215 100644
--- a/net-irc/quassel/quassel-9999.ebuild
+++ b/net-irc/quassel/quassel-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.17 2009/01/21 08:39:39 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-9999.ebuild,v 1.18 2009/02/19 11:48:54 scarabeus Exp $
EAPI="2"
@@ -15,7 +15,7 @@ HOMEPAGE="http://quassel-irc.org/"
LICENSE="GPL-3"
KEYWORDS=""
SLOT="0"
-IUSE="dbus debug kde monolithic phonon +server +ssl webkit +X"
+IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
LANGS="cs da de fr nb_NO ru tr"
for l in ${LANGS}; do
@@ -74,15 +74,15 @@ src_configure() {
$(cmake-utils_use_with webkit WEBKIT)
$(cmake-utils_use_with dbus DBUS)
$(cmake-utils_use_with kde KDE)
- $(cmake-utils_use_with phonon PHONON)
- $(cmake-utils_use_with ssl OPENSSL)"
+ $(cmake-utils_use_with oxygen OXYGEN)
+ $(cmake-utils_use_with ssl OPENSSL)
+ -DEMBED_DATA=OFF"
if use kde ; then
# We don't use our own phonon backend, so don't enable it; also use system icon themes
- mycmakeargs="${mycmakeargs} -DWITH_PHONON=0 -DOXYGEN_ICONS=External -DQUASSEL_ICONS=External"
+ mycmakeargs="${mycmakeargs} -DWITH_PHONON=0"
else
- mycmakeargs="${mycmakeargs} $(cmake-utils_use_with phonon PHONON)
- -DOXYGEN_ICONS=Builtin -DQUASSEL_ICONS=Builtin"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with phonon PHONON)"
fi
_common_configure_code