summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-23 23:42:11 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-23 23:42:11 +0000
commitcb1a8f991437c85dd944a74e0ec2aa6845202649 (patch)
treed6e4512a0db138d290745240b0028471e6a4d27e
parentNew ebuild. Bug #2953 (diff)
downloadgentoo-2-cb1a8f991437c85dd944a74e0ec2aa6845202649.tar.gz
gentoo-2-cb1a8f991437c85dd944a74e0ec2aa6845202649.tar.bz2
gentoo-2-cb1a8f991437c85dd944a74e0ec2aa6845202649.zip
added changelog, updated to new version, fixed init scripts
-rw-r--r--sys-apps/openmosix-user/ChangeLog9
-rw-r--r--sys-apps/openmosix-user/files/openmosix.init2
-rw-r--r--sys-apps/openmosix-user/openmosix-user-0.2.0.ebuild70
3 files changed, 80 insertions, 1 deletions
diff --git a/sys-apps/openmosix-user/ChangeLog b/sys-apps/openmosix-user/ChangeLog
new file mode 100644
index 000000000000..da64dfb46320
--- /dev/null
+++ b/sys-apps/openmosix-user/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/openmosix-user
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openmosix-user/ChangeLog,v 1.1 2002/06/23 23:42:10 lostlogic Exp $
+
+* openmosix-user-0.2.0 (23 Jun 2002)
+
+ 01 Feb 2002; G.Bevin <gbevin@gentoo.org> openmosix-0.2.0.ebuild:
+
+ Version bump to 0.2.0 for new openmosix-sources
diff --git a/sys-apps/openmosix-user/files/openmosix.init b/sys-apps/openmosix-user/files/openmosix.init
index a8a8ce644d1e..c12a883aee69 100644
--- a/sys-apps/openmosix-user/files/openmosix.init
+++ b/sys-apps/openmosix-user/files/openmosix.init
@@ -6,7 +6,7 @@ depend() {
stop() {
ebegin "Stopping openMosix"
- echo 0 > /proc/mosix/admin/mospe
+ setpe -off
rm -f /var/lock/subsys/mosix
eend
}
diff --git a/sys-apps/openmosix-user/openmosix-user-0.2.0.ebuild b/sys-apps/openmosix-user/openmosix-user-0.2.0.ebuild
new file mode 100644
index 000000000000..3f44b2294761
--- /dev/null
+++ b/sys-apps/openmosix-user/openmosix-user-0.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# /space/gentoo/cvsroot/gentoo-x86/sys-apps/openmosix-user/openmosix-user-0.1.3.ebuild,v 1.4 2002/05/27 17:27:39 drobbins Exp
+
+S=${WORKDIR}/openMosixUserland-${PV}
+DESCRIPTION="User-land utilities for openMosix process migration (clustering) software"
+SRC_URI="mirror://sourceforge/openmosix/openMosixUserland-${PV}.tar.gz"
+HOMEPAGE="http://www.openmosix.com"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-kernel/openmosix-sources-2.4.17"
+RDEPEND="${DEPEND}
+ sys-apps/findutils
+ sys-devel/perl"
+SLOT="0"
+LICENSE="GPL-2"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat > configuration << EOF
+OPENMOSIX=/usr/src/linux
+PROCDIR=/proc/hpc
+MONNAME=mmon
+CC=gcc
+INSTALLDIR=/usr
+CFLAGS=-I/m/include -I./ -I/usr/include -I\$(OPENMOSIX)/include ${CFLAGS}
+INSTALL=/usr/bin/install
+EOF
+# #use perl, find and xargs to convert /usr/man references to /usr/share/man (FHS)
+# find . -iname Makefile | xargs perl -pi.orig -e "s:INSTALLDIR\)/man:INSTALLDIR)/share/man:g"
+}
+
+src_compile() {
+ cd ${S}
+ make clean build
+}
+
+src_install () {
+ sed -e "s:INSTALLEXTRADIR:INSTALLBASEDIR:" moslib/Makefile > moslib/Makefile.hacked
+ mv moslib/Makefile.hacked moslib/Makefile
+ dodir /usr/lib
+ dodir /usr/sbin
+ dodir /usr/include
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ make INSTALLBASEDIR=${D}usr \
+ INSTALLEXTRADIR=${D}usr/share \
+ DESTDIR=${D} \
+ INSTALLDIR=${D}usr \
+ install
+
+ dodoc COPYING README
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmosix.init openmosix
+ insinto /etc
+ #stub mosix.map file
+ doins ${FILESDIR}/mosix.map
+}
+
+pkg_postinst() {
+ einfo
+ einfo " To complete openMosix installation, edit /etc/mosix.map and then type:
+ einfo "# rc-update add openmosix default
+ einfo " ...to add openMosix to the default runlevel. This particular version of"
+ einfo " openmosix-user has been designed to work with the linux-2.4.17-openmosix-r1"
+ einfo " or later kernel (>=sys-kernel/openmosix-sources-2.4.17)"
+ einfo
+}