summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-17 13:02:10 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-17 13:02:10 +0000
commitce2c1ebaf25f71b3351cbd524f253f88b2c73059 (patch)
treeb66a6c371f71043fef67873c9f014fa5c4efff48
parentapp-crypt/johntheripper: Drop gpu specific compiler flags (diff)
downloadgentoo-2-ce2c1ebaf25f71b3351cbd524f253f88b2c73059.tar.gz
gentoo-2-ce2c1ebaf25f71b3351cbd524f253f88b2c73059.tar.bz2
gentoo-2-ce2c1ebaf25f71b3351cbd524f253f88b2c73059.zip
syntax fix, drop vulnerable versions wrt Bug #521324
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-1.4.14.ebuild87
-rw-r--r--dev-python/django/django-1.5.9.ebuild85
-rw-r--r--dev-python/django/django-1.6.6.ebuild88
-rw-r--r--dev-python/django/django-1.6.7.ebuild4
-rw-r--r--dev-python/django/django-1.7.ebuild4
6 files changed, 10 insertions, 265 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index d027b1039323..6a80b695f1ab 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.146 2014/09/14 11:26:44 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.147 2014/09/17 13:02:10 idella4 Exp $
+
+ 17 Sep 2014; Ian Delaney <idella4@gentoo.org> -django-1.4.14.ebuild,
+ -django-1.5.9.ebuild, -django-1.6.6.ebuild, django-1.6.7.ebuild,
+ django-1.7.ebuild:
+ syntax fix, drop vulnerable versions wrt Bug #521324
14 Sep 2014; Ian Delaney <idella4@gentoo.org> -files/1.7-test_serialize.patch:
remove redundant upstream patch
diff --git a/dev-python/django/django-1.4.14.ebuild b/dev-python/django/django-1.4.14.ebuild
deleted file mode 100644
index 943f87e0bcc4..000000000000
--- a/dev-python/django/django-1.4.14.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.4.14.ebuild,v 1.3 2014/09/02 07:35:08 ago Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='sqlite?'
-
-inherit bash-completion-r1 distutils-r1 versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/mysql-python-1.2.3[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-python_prepare_all() {
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py || die
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. \
- "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- # Port conflict in django.test.testcases.LiveServerTestCase.
- # Several other races with temp files.
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- webapp_src_install
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newbashcomp extras/django_bash_completion ${PN}
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/.
-}
-
-pkg_postinst() {
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- elog
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
-
- # XXX: call webapp_pkg_postinst? the old ebuild didn't do that...
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.5.9.ebuild b/dev-python/django/django-1.5.9.ebuild
deleted file mode 100644
index fc5e291b8f18..000000000000
--- a/dev-python/django/django-1.5.9.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.5.9.ebuild,v 1.3 2014/09/02 07:35:08 ago Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3} pypy )
-PYTHON_REQ_USE='sqlite?'
-WEBAPP_NO_AUTO_INSTALL="yes"
-
-inherit bash-completion-r1 distutils-r1 versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-PY23_USEDEP=$(python_gen_usedep python2_7 'python{3_3,3_4}')
-RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PY23_USEDEP}] )
- mysql? ( >=dev-python/mysql-python-1.2.3[${PY2_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
- test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
-
-REQUIRED_USE="mysql? ( $(python_gen_useflags python2_7) )
- postgres? ( || ( $(python_gen_useflags 'python{2_7,3_2,3_3}') ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5.4-objects.patch \
- "${FILESDIR}"/${PN}-1.5-py3tests.patch )
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- fi
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- # https://code.djangoproject.com/ticket/20514
- PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- # Port conflict in django.test.testcases.LiveServerTestCase.
- # Several other races with temp files.
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- webapp_src_install
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/.
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "A copy of the admin media is available to webapp-config for installation in a"
- elog "webroot, as well as the traditional location in python's site-packages dir"
- elog "for easy development."
- webapp_pkg_postinst
-}
diff --git a/dev-python/django/django-1.6.6.ebuild b/dev-python/django/django-1.6.6.ebuild
deleted file mode 100644
index 2ad0489d7d43..000000000000
--- a/dev-python/django/django-1.6.6.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.6.6.ebuild,v 1.3 2014/09/02 07:35:08 ago Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-PYTHON_REQ_USE='sqlite?'
-WEBAPP_NO_AUTO_INSTALL="yes"
-
-inherit bash-completion-r1 distutils-r1 versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_USEDEP}]' python2_7 'python{3_3,3_4}') )
- mysql? ( $(python_gen_cond_dep '>=dev-python/mysql-python-1.2.3[${PYTHON_USEDEP}]' python2_7) )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
- test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.5-py3tests.patch \
- "${FILESDIR}"/${PN}-1.6-objects.patch )
-
-python_prepare_all() {
- # Avoid test failures with unittest2 and Python 3.
- sed -e "s/from unittest2 import \*/raise ImportError/" -i django/utils/unittest/__init__.py
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- fi
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- # https://code.djangoproject.com/ticket/20514
- # https://code.djangoproject.com/ticket/21093
- PYTHONPATH=. \
- "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- # Port conflict in django.test.testcases.LiveServerTestCase.
- # Several other races with temp files.
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- webapp_src_install
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/.
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "A copy of the admin media is available to webapp-config for installation in a"
- elog "webroot, as well as the traditional location in python's site-packages dir"
- elog "for easy development."
- webapp_pkg_postinst
-}
diff --git a/dev-python/django/django-1.6.7.ebuild b/dev-python/django/django-1.6.7.ebuild
index d474d3cc0eee..ebc5987baa21 100644
--- a/dev-python/django/django-1.6.7.ebuild
+++ b/dev-python/django/django-1.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.6.7.ebuild,v 1.3 2014/09/13 17:24:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.6.7.ebuild,v 1.4 2014/09/17 13:02:10 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -21,7 +21,7 @@ KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~
IUSE="doc mysql postgres sqlite test"
RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_USEDEP}]' python2_7 'python{3_3,3_4}') )
+ postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_USEDEP}]' python2_7 python{3_3,3_4}) )
mysql? ( $(python_gen_cond_dep '>=dev-python/mysql-python-1.2.3[${PYTHON_USEDEP}]' python2_7) )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
diff --git a/dev-python/django/django-1.7.ebuild b/dev-python/django/django-1.7.ebuild
index 135776db8836..5c98b0841e2c 100644
--- a/dev-python/django/django-1.7.ebuild
+++ b/dev-python/django/django-1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.7.ebuild,v 1.1 2014/09/14 05:42:33 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.7.ebuild,v 1.2 2014/09/17 13:02:10 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -22,7 +22,7 @@ IUSE="doc mysql postgres sqlite test"
RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
- postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_USEDEP}]' python2_7 'python{3_3,3_4}') )
+ postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_USEDEP}]' python2_7 python{3_3,3_4}) )
mysql? ( $(python_gen_cond_dep '>=dev-python/mysql-python-1.2.3[${PYTHON_USEDEP}]' python2_7) )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )