summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-01 23:31:14 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-01 23:31:14 +0000
commitd13c048307f050928f9963d073cf6928a58b7873 (patch)
treee2165d7275b8213338b18d5e85d16349eee86b83
parentRemove 'e' language (my typo). Thanks to Jakub Moc in bug #135137. (diff)
downloadgentoo-2-d13c048307f050928f9963d073cf6928a58b7873.tar.gz
gentoo-2-d13c048307f050928f9963d073cf6928a58b7873.tar.bz2
gentoo-2-d13c048307f050928f9963d073cf6928a58b7873.zip
New revision including fixes from bug 126403, bug 114627 and RESTRICT=test for bug 118655
(Portage version: 2.1_rc3-r4)
-rw-r--r--app-text/a2ps/ChangeLog10
-rw-r--r--app-text/a2ps/a2ps-4.13c-r5.ebuild92
-rw-r--r--app-text/a2ps/files/a2ps-4.13c-emacs.patch10
-rw-r--r--app-text/a2ps/files/a2ps-4.13c-psset.patch11
-rw-r--r--app-text/a2ps/files/digest-a2ps-4.13c-r56
5 files changed, 128 insertions, 1 deletions
diff --git a/app-text/a2ps/ChangeLog b/app-text/a2ps/ChangeLog
index 18edf3d680a5..4c277a601515 100644
--- a/app-text/a2ps/ChangeLog
+++ b/app-text/a2ps/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/a2ps
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.46 2006/05/30 20:50:04 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.47 2006/06/01 23:31:14 genstef Exp $
+
+*a2ps-4.13c-r5 (01 Jun 2006)
+
+ 01 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/a2ps-4.13c-emacs.patch, +files/a2ps-4.13c-psset.patch,
+ +a2ps-4.13c-r5.ebuild:
+ New revision including fixes from bug 126403, bug 114627 and RESTRICT=test
+ for bug 118655
30 May 2006; <yvasilev@gentoo.org>
+files/a2ps-4.13c-fnmatch-replacement.patch, a2ps-4.13c-r4.ebuild:
diff --git a/app-text/a2ps/a2ps-4.13c-r5.ebuild b/app-text/a2ps/a2ps-4.13c-r5.ebuild
new file mode 100644
index 000000000000..519a14714485
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.13c-r5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.13c-r5.ebuild,v 1.1 2006/06/01 23:31:14 genstef Exp $
+
+inherit gnuconfig eutils autotools
+
+S=${WORKDIR}/${PN}-${PV:0:4}
+DESCRIPTION="Any to PostScript filter"
+HOMEPAGE="http://www.inf.enst.fr/~demaille/a2ps/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ cjk? ( http://dev.gentoo.org/~usata/distfiles/${P}-ja_nls.patch.gz ) "
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="nls tetex cjk vanilla"
+# bug 118655, restrict until a proper fix is found
+RESTRICT="test"
+
+DEPEND=">=sys-devel/automake-1.6
+ >=sys-devel/autoconf-2.57
+ >=dev-util/gperf-2.7.2
+ || ( >=dev-util/yacc-1.9.1 sys-devel/bison )
+ virtual/ghostscript
+ >=app-text/psutils-1.17
+ tetex? ( virtual/tetex )
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/ghostscript
+ >=app-text/psutils-1.17
+ tetex? ( virtual/tetex )
+ nls? ( virtual/libintl )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-4.13-select-freebsd.patch
+ epatch ${FILESDIR}/${P}-locale-gentoo.diff
+ epatch ${FILESDIR}/${PN}-4.13c-stdarg.patch
+ use vanilla || epatch ${FILESDIR}/${PN}-4.13-stdout.diff
+ epatch ${FILESDIR}/${PV}-gcc34.patch
+ use cjk && epatch ${DISTDIR}/${P}-ja_nls.patch.gz
+
+ # improve tempfile handling
+ epatch ${FILESDIR}/${P}-fixps.patch
+ epatch ${FILESDIR}/${P}-psmandup.diff
+
+ # fix fnmatch replacement, bug #134546
+ epatch ${FILESDIR}/${P}-fnmatch-replacement.patch
+
+ # fix sandbox violation, bug #79012
+ sed -i -e 's:$acroread -helpall:acroread4 -helpall:' configure configure.in
+
+ # fix emacs printing, bug #114627
+ epatch ${FILESDIR}/a2ps-4.13c-emacs.patch
+
+ # fix psset with sed-4.1, bug #126403
+ epatch ${FILESDIR}/a2ps-4.13c-psset.patch
+
+ gnuconfig_update || die "gnuconfig_update failed"
+ AT_M4DIR="m4" eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+
+ #export YACC=yacc
+ econf --sysconfdir=/etc/a2ps \
+ --includedir=/usr/include \
+ `use_enable nls` || die "econf failed"
+
+ export LANG=C
+
+ # sometimes emake doesn't work
+ make || die "make failed"
+}
+
+src_install() {
+ dodir /usr/share/emacs/site-lisp
+
+ einstall \
+ sysconfdir=${D}/etc/a2ps \
+ includedir=${D}/usr/include \
+ lispdir=${D}/usr/share/emacs/site-lisp \
+ || die "einstall failed"
+
+ dosed /etc/a2ps/a2ps.cfg
+
+ # bug #122026
+ sed -i "s:^countdictstack: \0:" ${D}/usr/bin/psset || die "sed failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog FAQ NEWS README* THANKS TODO
+}
diff --git a/app-text/a2ps/files/a2ps-4.13c-emacs.patch b/app-text/a2ps/files/a2ps-4.13c-emacs.patch
new file mode 100644
index 000000000000..f1cd5d9ebdfc
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.13c-emacs.patch
@@ -0,0 +1,10 @@
+--- a2ps-4.13/contrib/emacs/a2ps-print.el.orig 2005-12-05 08:03:48.000000000 +0100
++++ a2ps-4.13/contrib/emacs/a2ps-print.el 2005-12-06 16:38:14.000000000 +0100
+@@ -93,6 +93,7 @@
+ (concat "--center-title=" name)
+ (concat "--footer=" (concat name " Emacs buffer"))
+ (concat "--pretty-print=" filetype)
++ (concat "-d")
+ ;Uncommenting the following gives a print preview (only):
+ ; (concat "--output=/tmp/foo.ps")
+ )
diff --git a/app-text/a2ps/files/a2ps-4.13c-psset.patch b/app-text/a2ps/files/a2ps-4.13c-psset.patch
new file mode 100644
index 000000000000..f8fd4497f281
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.13c-psset.patch
@@ -0,0 +1,11 @@
+--- a2ps-4.13/contrib/psset.in.orig 2006-03-16 12:30:48.000000000 +0100
++++ a2ps-4.13/contrib/psset.in 2006-03-16 12:28:14.000000000 +0100
+@@ -241,7 +241,7 @@
+ # spaces with a `\' too...
+ pspagedevicelen=`echo "$pspagedevice" | wc -l`
+ pspagedevice=`echo "$pspagedevice" | \
+- sed -e "$pspagedevicelen!s/\$/\\\\\\/;s/^/\\\\\\/"`
++ sed -e "$pspagedevicelen!s/\$/\\\\\\/;s/^ /\\\\\\/"`
+
+ case $at in
+ 0) # Insert last in the Setup, so that we win over other requests.
diff --git a/app-text/a2ps/files/digest-a2ps-4.13c-r5 b/app-text/a2ps/files/digest-a2ps-4.13c-r5
new file mode 100644
index 000000000000..0cf5230e7350
--- /dev/null
+++ b/app-text/a2ps/files/digest-a2ps-4.13c-r5
@@ -0,0 +1,6 @@
+MD5 e315466f75d99c0c1ca563d82f2ace2e a2ps-4.13c-ja_nls.patch.gz 38189
+RMD160 932f430064f77d65768d2d1701ea650ae1103bb0 a2ps-4.13c-ja_nls.patch.gz 38189
+SHA256 8bc15ae152205b184a609777ac29430780eadacba2fd90bfa1fe318e43bd781f a2ps-4.13c-ja_nls.patch.gz 38189
+MD5 97164e84ba911e4604155507e0893669 a2ps-4.13c.tar.gz 2395885
+RMD160 d6464e88236a4efa8377e37e29e548411cd9c863 a2ps-4.13c.tar.gz 2395885
+SHA256 dfdd509ef79040fb300b2709a8fc54d9562f3ce141184958e3c2303cb3cf4890 a2ps-4.13c.tar.gz 2395885