summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-03-30 09:12:49 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-03-30 09:12:49 +0000
commitd2016d5518ae9810846a6fb7497fac48d7ec9a71 (patch)
tree05faca4843f115ab43796fb7a7eaafc04c4c1b97
parentClosing #43748. (Manifest recommit) (diff)
downloadgentoo-2-d2016d5518ae9810846a6fb7497fac48d7ec9a71.tar.gz
gentoo-2-d2016d5518ae9810846a6fb7497fac48d7ec9a71.tar.bz2
gentoo-2-d2016d5518ae9810846a6fb7497fac48d7ec9a71.zip
Potential fix for #43874.
-rw-r--r--app-crypt/heimdal/ChangeLog6
-rw-r--r--app-crypt/heimdal/files/heimdal-0.6-berkdb.patch22
-rw-r--r--app-crypt/heimdal/heimdal-0.6.ebuild7
3 files changed, 32 insertions, 3 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index 4b1311623d0b..f9df6be91300 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/heimdal
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.22 2004/03/21 09:37:23 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.23 2004/03/30 09:12:47 aliz Exp $
+
+ 30 Mar 2004; Daniel Ahlberg <aliz@gentoo.org> heimdal-0.6.ebuild,
+ files/heimdal-0.6-berkdb.patch:
+ Fixing berkdb support for heimdal. Should close #43874.
21 Mar 2004; Joshua Kinard <kumba@gentoo.org> heimdal-0.6.ebuild:
Marked stable on mips.
diff --git a/app-crypt/heimdal/files/heimdal-0.6-berkdb.patch b/app-crypt/heimdal/files/heimdal-0.6-berkdb.patch
new file mode 100644
index 000000000000..4b4ab86ca082
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-0.6-berkdb.patch
@@ -0,0 +1,22 @@
+--- cf/db.m4 2004-03-30 09:00:23.315562886 +0000
++++ cf/db.m4 2004-03-30 09:00:47.278672201 +0000
+@@ -14,6 +14,8 @@
+ if test "$enable_berkeley_db" != no; then
+
+ AC_CHECK_HEADERS([ \
++ db4.2/db.h \
++ db4.1/db.h \
+ db4/db.h \
+ db3/db.h \
+ db.h \
+@@ -24,6 +26,10 @@
+
+ AC_FIND_FUNC_NO_LIBS(db_create, db4 db3 db, [
+ #include <stdio.h>
++ #ifdef HAVE_DB4_2_DB_H
++ #include <db4.2/db.h>
++ #ifdef HAVE_DB4_1_DB_H
++ #include <db4.1/db.h>
+ #ifdef HAVE_DB4_DB_H
+ #include <db4/db.h>
+ #elif defined(HAVE_DB3_DB_H)
diff --git a/app-crypt/heimdal/heimdal-0.6.ebuild b/app-crypt/heimdal/heimdal-0.6.ebuild
index 7406cae373c0..ac98ed2eebbb 100644
--- a/app-crypt/heimdal/heimdal-0.6.ebuild
+++ b/app-crypt/heimdal/heimdal-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.6.ebuild,v 1.14 2004/03/21 09:37:23 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.6.ebuild,v 1.15 2004/03/30 09:12:47 aliz Exp $
inherit libtool eutils
@@ -17,7 +17,8 @@ PROVIDE="virtual/krb5"
DEPEND="
ssl? ( dev-libs/openssl )
berkdb? ( sys-libs/db )
- !app-crypt/kth-krb"
+ !app-crypt/kth-krb
+ sys-devel/autoconf"
# ldap? ( net-nds/openldap )
# With this enabled, we create a multiple stage
# circular dependency with USE="ldap kerberos"
@@ -28,12 +29,14 @@ src_unpack() {
epatch ${FILESDIR}/${P}-gcc3.patch
epatch ${FILESDIR}/${P}-rxapps.patch
+ epatch ${FILESDIR}/${P}-berkdb.patch
# Um, I don't think the below is doing anything since automake is
# run in src_compile(), but I'll leave it alone since this ebuild
# isn't mine... (16 Feb 2004 agriffis)
cd ${S}/lib/krb5 || die
sed -i "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in || die
+
}
src_compile() {