summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-27 01:55:16 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-27 01:55:16 +0000
commitd32bde296eb1ecbce35b5a1dee872a27773a667f (patch)
treec7b86a4126f88c370690b50c714f1d883f73661c
parentpropogating changes from amd64 to x86 relating to nvidia on hardened (diff)
downloadgentoo-2-d32bde296eb1ecbce35b5a1dee872a27773a667f.tar.gz
gentoo-2-d32bde296eb1ecbce35b5a1dee872a27773a667f.tar.bz2
gentoo-2-d32bde296eb1ecbce35b5a1dee872a27773a667f.zip
Version bump. Fix shebang for outline script (bug #386501 by Mathieu Zhang).
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--app-vim/vim-latex/ChangeLog10
-rw-r--r--app-vim/vim-latex/vim-latex-1.8.23.20121116.ebuild61
2 files changed, 69 insertions, 2 deletions
diff --git a/app-vim/vim-latex/ChangeLog b/app-vim/vim-latex/ChangeLog
index 0af751fad5d1..921163cf4a0c 100644
--- a/app-vim/vim-latex/ChangeLog
+++ b/app-vim/vim-latex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/vim-latex
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-latex/ChangeLog,v 1.11 2011/07/23 18:55:03 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-latex/ChangeLog,v 1.12 2012/11/27 01:55:16 radhermit Exp $
+
+*vim-latex-1.8.23.20121116 (27 Nov 2012)
+
+ 27 Nov 2012; Tim Harder <radhermit@gentoo.org>
+ +vim-latex-1.8.23.20121116.ebuild:
+ Version bump. Fix shebang for outline script (bug #386501 by Mathieu Zhang).
23 Jul 2011; Tim Harder <radhermit@gentoo.org>
-vim-latex-1.8.23.20100129.ebuild, -vim-latex-1.8.23.20101027.ebuild:
diff --git a/app-vim/vim-latex/vim-latex-1.8.23.20121116.ebuild b/app-vim/vim-latex/vim-latex-1.8.23.20121116.ebuild
new file mode 100644
index 000000000000..263562f12f9e
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.8.23.20121116.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-latex/vim-latex-1.8.23.20121116.ebuild,v 1.1 2012/11/27 01:55:16 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin versionator python
+
+MY_REV="784-git1c17b37"
+MY_P="${PN}-$( replace_version_separator 3 - ).${MY_REV}"
+
+DESCRIPTION="vim plugin: a comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="html"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ virtual/latex-base"
+
+S="${WORKDIR}/${MY_P}"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_prepare() {
+ # The makefiles do weird stuff, including running the svn command
+ rm Makefile Makefile.in || die "rm Makefile Makefile.in failed"
+}
+
+src_install() {
+ use html && dohtml -r doc/
+
+ # Don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # Don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # Use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+ python_convert_shebangs -r 2 "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ elog
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ elog
+}