summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-03-22 00:30:13 +0000
committerBrian Evans <grknight@gentoo.org>2015-03-22 00:30:13 +0000
commitd38048d889031db03cf96a7b6803ad600a034486 (patch)
tree20d842af5fcedf24dd6b539d491710294b33dd04
parentVersion bump (bug 543846). (diff)
downloadgentoo-2-d38048d889031db03cf96a7b6803ad600a034486.tar.gz
gentoo-2-d38048d889031db03cf96a7b6803ad600a034486.tar.bz2
gentoo-2-d38048d889031db03cf96a7b6803ad600a034486.zip
Drop old; Drop php 5.3 support; Clean up repoman warnings
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
-rw-r--r--dev-php/pecl-memcache/ChangeLog7
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-2.2.6-r2.ebuild41
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild6
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild46
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild4
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild8
6 files changed, 15 insertions, 97 deletions
diff --git a/dev-php/pecl-memcache/ChangeLog b/dev-php/pecl-memcache/ChangeLog
index 39d0a19f9ab9..267f76b94c5f 100644
--- a/dev-php/pecl-memcache/ChangeLog
+++ b/dev-php/pecl-memcache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-memcache
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/ChangeLog,v 1.18 2015/01/08 09:15:40 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/ChangeLog,v 1.19 2015/03/22 00:30:13 grknight Exp $
+
+ 22 Mar 2015; Brian Evans <grknight@gentoo.org> -pecl-memcache-2.2.6-r2.ebuild,
+ -pecl-memcache-3.0.7.ebuild, pecl-memcache-2.2.7.ebuild,
+ pecl-memcache-3.0.8-r1.ebuild, pecl-memcache-3.0.8.ebuild:
+ Drop old; Drop php 5.3 support; Clean up repoman warnings
08 Jan 2015; Ole Markus With <olemarkus@gentoo.org>
pecl-memcache-3.0.8-r1.ebuild:
diff --git a/dev-php/pecl-memcache/pecl-memcache-2.2.6-r2.ebuild b/dev-php/pecl-memcache/pecl-memcache-2.2.6-r2.ebuild
deleted file mode 100644
index f2dcb6cf25ff..000000000000
--- a/dev-php/pecl-memcache/pecl-memcache-2.2.6-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-2.2.6-r2.ebuild,v 1.2 2014/08/10 21:02:48 slyfox Exp $
-
-EAPI="4"
-PHP_EXT_NAME="memcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="README"
-
-inherit php-ext-pecl-r2
-
-KEYWORDS="amd64 hppa ppc64 x86"
-
-DESCRIPTION="PHP extension for using memcached"
-LICENSE="PHP-3"
-SLOT="0"
-IUSE="+session"
-
-DEPEND="sys-libs/zlib
- dev-lang/php[session?]"
-RDEPEND="${DEPEND}"
-
-# upstream does not ship any testsuite, so the PHPize test-runner fails.
-RESTRICT='test'
-
-src_configure() {
- my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-pecl-r2_src_install
-
- php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
- php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
- php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
- php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
- php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "standard"
- php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
-}
diff --git a/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
index ee684c9339e1..bf3ffdc57626 100644
--- a/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild,v 1.4 2014/10/15 15:37:04 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild,v 1.5 2015/03/22 00:30:13 grknight Exp $
EAPI=5
PHP_EXT_NAME="memcache"
@@ -20,7 +20,7 @@ SLOT="0"
IUSE="+session"
DEPEND="sys-libs/zlib
- dev-lang/php[session?]"
+ dev-lang/php:*[session?]"
RDEPEND="${DEPEND}"
# upstream does not ship any testsuite, so the PHPize test-runner fails.
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild
deleted file mode 100644
index 97f5e41b82bb..000000000000
--- a/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild,v 1.3 2014/08/10 21:02:48 slyfox Exp $
-
-EAPI="5"
-PHP_EXT_NAME="memcache"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS="README"
-
-USE_PHP="php5-5 php5-3 php5-4"
-
-inherit php-ext-pecl-r2
-
-KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
-
-DESCRIPTION="PHP extension for using memcached"
-LICENSE="PHP-3"
-SLOT="0"
-IUSE="+session"
-
-DEPEND="sys-libs/zlib
- dev-lang/php[session?]"
-RDEPEND="${DEPEND}"
-
-# upstream does not ship any testsuite, so the PHPize test-runner fails.
-RESTRICT='test'
-
-src_configure() {
- my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-pecl-r2_src_install
-
- php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
- php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
- php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
- php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
- php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "consistent"
- php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
- php-ext-source-r2_addtoinifiles "memcache.redundancy" "1"
- php-ext-source-r2_addtoinifiles "memcache.session_redundancy" "2"
- php-ext-source-r2_addtoinifiles "memcache.protocol" "ascii"
-}
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild
index 52047542b82d..4180d58674dd 100644
--- a/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild,v 1.2 2015/01/08 09:15:40 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.8-r1.ebuild,v 1.3 2015/03/22 00:30:13 grknight Exp $
EAPI="5"
PHP_EXT_NAME="memcache"
@@ -20,7 +20,7 @@ SLOT="0"
IUSE="+session"
DEPEND="sys-libs/zlib
- dev-lang/php[session?]"
+ dev-lang/php:*[session?]"
RDEPEND="${DEPEND}"
# The test suite requires memcached to be running.
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild
index 4d76b2aac7e4..e8700b65832f 100644
--- a/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild,v 1.6 2014/08/10 21:02:48 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.8.ebuild,v 1.7 2015/03/22 00:30:13 grknight Exp $
EAPI="5"
PHP_EXT_NAME="memcache"
@@ -8,7 +8,7 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="README"
-USE_PHP="php5-5 php5-3 php5-4"
+USE_PHP="php5-5 php5-4"
inherit php-ext-pecl-r2
@@ -20,7 +20,7 @@ SLOT="0"
IUSE="+session"
DEPEND="sys-libs/zlib
- dev-lang/php[session?]"
+ dev-lang/php:*[session?]"
RDEPEND="${DEPEND}"
# upstream does not ship any testsuite, so the PHPize test-runner fails.