summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-11-25 09:53:06 +0000
committerRoy Marples <uberlord@gentoo.org>2006-11-25 09:53:06 +0000
commitd57b6bf2f60b5c7febc566269a99d2a7d6b1192b (patch)
tree93214a57ce49d6d44d589281ffbfe5fbd6099a82
parentInitial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>. (diff)
downloadgentoo-2-d57b6bf2f60b5c7febc566269a99d2a7d6b1192b.tar.gz
gentoo-2-d57b6bf2f60b5c7febc566269a99d2a7d6b1192b.tar.bz2
gentoo-2-d57b6bf2f60b5c7febc566269a99d2a7d6b1192b.zip
New upstream release.
(Portage version: 2.1.2_rc2-r1)
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog8
-rw-r--r--net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.63
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.6-sigpoll.patch16
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.6.ebuild203
4 files changed, 229 insertions, 1 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index ffb9b9a9a5bb..86ec30e6fb88 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.84 2006/11/12 14:08:04 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.85 2006/11/25 09:53:06 uberlord Exp $
+
+*wpa_supplicant-0.5.6 (25 Nov 2006)
+
+ 25 Nov 2006; Roy Marples <uberlord@gentoo.org>
+ +files/wpa_supplicant-0.5.6-sigpoll.patch, +wpa_supplicant-0.5.6.ebuild:
+ New upstream release.
12 Nov 2006; Roy Marples <uberlord@gentoo.org>
wpa_supplicant-0.5.5.ebuild:
diff --git a/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.6 b/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.6
new file mode 100644
index 000000000000..4b6b5c50b91c
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.6
@@ -0,0 +1,3 @@
+MD5 c90eca479fa0cb58c7f447dc45d7cef1 wpa_supplicant-0.5.6.tar.gz 710441
+RMD160 a00dfdf4874a09b6ee89d7a691f0e48e75325133 wpa_supplicant-0.5.6.tar.gz 710441
+SHA256 892c6972b0940aa5d96d5a49ea924eb0f0504210213ba1134993e69dc395363f wpa_supplicant-0.5.6.tar.gz 710441
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.6-sigpoll.patch b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.6-sigpoll.patch
new file mode 100644
index 000000000000..6a9be745fb7f
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.6-sigpoll.patch
@@ -0,0 +1,16 @@
+--- ctrl_iface_dbus.h.orig 2006-11-25 09:01:16 +0000
++++ ctrl_iface_dbus.h 2006-11-25 09:00:53 +0000
+@@ -15,6 +15,13 @@
+ #ifndef CTRL_IFACE_DBUS_H
+ #define CTRL_IFACE_DBUS_H
+
++/* If we don't have SIGPOLL, so use SIGIO instead */
++#ifndef SIGPOLL
++#ifdef SIGIO
++#define SIGPOLL SIGIO
++#endif
++#endif
++
+ #ifdef CONFIG_CTRL_IFACE_DBUS
+
+ #include <dbus/dbus.h>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.6.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.6.ebuild
new file mode 100644
index 000000000000..acea134dea57
--- /dev/null
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.6.ebuild
@@ -0,0 +1,203 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.6.ebuild,v 1.1 2006/11/25 09:53:06 uberlord Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
+HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="|| ( GPL-2 BSD )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="dbus gsm madwifi qt3 qt4 readline ssl kernel_linux kernel_FreeBSD"
+
+#When dbus-core is out of package mask, this is how it works
+#RDEPEND="dbus? ( || ( sys-apps/dbus-core sys-apps/dbus ) )"
+RDEPEND="dbus? ( sys-apps/dbus )
+ kernel_linux? (
+ gsm? ( sys-apps/pcsc-lite )
+ madwifi? (
+ || ( net-wireless/madwifi-ng net-wireless/madwifi-old )
+ )
+ )
+ !kernel_linux? ( net-libs/libpcap )
+ qt4? ( =x11-libs/qt-4* )
+ !qt4? ( qt3? ( =x11-libs/qt-3* ) )
+ readline? ( sys-libs/ncurses sys-libs/readline )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use kernel_linux ; then
+ ewarn
+ ewarn "${PN} requires kernel support for Packet Socket (CONFIG_PACKET)."
+ ewarn
+ fi
+
+ if use qt3 && use qt4; then
+ einfo "You have USE=\"qt3 qt4\" selected, defaulting to USE=\"qt4\""
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # If we don't have SIGPOLL (like FreeBSD), use SIGIO instead
+ epatch "${FILESDIR}/${P}-sigpoll.patch"
+
+ # net/bpf.h needed for net-libs/libpcap on Gentoo FreeBSD
+ sed -i \
+ -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
+ l2_packet_freebsd.c || die
+
+ # toolchain setup
+ echo "CC = $(tc-getCC)" > .config
+
+ # basic setup
+ echo "CONFIG_CTRL_IFACE=y" >> .config
+ echo "CONFIG_BACKEND=file" >> .config
+
+ # basic authentication methods
+ # NOTE: we don't set GPSK or SAKE as they conflict
+ # with the below options
+ echo "CONFIG_EAP_GTC=y" >> .config
+ echo "CONFIG_EAP_MD5=y" >> .config
+ echo "CONFIG_EAP_OTP=y" >> .config
+ echo "CONFIG_EAP_PAX=y" >> .config
+ echo "CONFIG_EAP_PSK=y" >> .config
+ echo "CONFIG_EAP_TLV=y" >> .config
+ echo "CONFIG_IEEE8021X_EAPOL=y" >> .config
+ echo "CONFIG_PKCS12=y" >> .config
+ echo "CONFIG_PEERKEY=y" >> .config
+
+ if use dbus ; then
+ echo "CONFIG_CTRL_IFACE_DBUS=y" >> .config
+ fi
+
+ if use gsm ; then
+ # smart card authentication
+ echo "CONFIG_EAP_SIM=y" >> .config
+ echo "CONFIG_EAP_AKA=y" >> .config
+ echo "CONFIG_PCSC=y" >> .config
+ fi
+
+ if use readline ; then
+ # readline/history support for wpa_cli
+ echo "CONFIG_READLINE=y" >> .config
+ fi
+
+ if use ssl ; then
+ # SSL authentication methods
+ echo "CONFIG_EAP_LEAP=y" >> .config
+ echo "CONFIG_EAP_MSCHAPV2=y" >> .config
+ echo "CONFIG_EAP_PEAP=y" >> .config
+ echo "CONFIG_EAP_TLS=y" >> .config
+ echo "CONFIG_EAP_TTLS=y" >> .config
+ echo "CONFIG_SMARTCARD=y" >> .config
+ fi
+
+ if use kernel_linux ; then
+ # Linux specific drivers
+ echo "CONFIG_DRIVER_ATMEL=y" >> .config
+ #echo "CONFIG_DRIVER_BROADCOM=y" >> .config
+ #echo "CONFIG_DRIVER_HERMES=y" >> .config
+ echo "CONFIG_DRIVER_HOSTAP=y" >> .config
+ echo "CONFIG_DRIVER_IPW=y" >> .config
+ echo "CONFIG_DRIVER_NDISWRAPPER=y" >> .config
+ echo "CONFIG_DRIVER_PRISM54=y" >> .config
+ echo "CONFIG_DRIVER_WEXT=y" >> .config
+ echo "CONFIG_DRIVER_WIRED=y" >> .config
+
+ if use madwifi ; then
+ # Add include path for madwifi-driver headers
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> .config
+ echo "CONFIG_DRIVER_MADWIFI=y" >> .config
+ fi
+ fi
+
+ if use kernel_FreeBSD ; then
+ # FreeBSD specific driver
+ echo "CONFIG_DRIVER_BSD=y" >> .config
+ fi
+
+ # people seem to take the example configuration file too literally
+ # bug #102361
+ sed -i \
+ -e "s:^\(opensc_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_module_path\):#\1:" \
+ wpa_supplicant.conf || die
+
+ # Change configuration to match Gentoo locations, #143750
+ sed -i \
+ -e "s:/usr/lib/opensc:/usr/$(get_libdir):" \
+ -e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
+ wpa_supplicant.conf || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use qt4 ; then
+ qmake -o "${S}"/wpa_gui-qt4/Makefile "${S}"/wpa_gui-qt4/wpa_gui.pro
+ cd "${S}"/wpa_gui-qt4
+ emake || die "emake wpa_gui-qt4 failed"
+ elif use qt3 ; then
+ [[ -d ${QTDIR}/etc/settings ]] && addwrite "${QTDIR}"/etc/settings
+ /usr/qt/3/bin/qmake -o "${S}"/wpa_gui/Makefile "${S}"/wpa_gui/wpa_gui.pro
+ cd "${S}"/wpa_gui
+ emake || die "emake wpa_gui failed"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin wpa_supplicant
+ dobin wpa_cli wpa_passphrase
+
+ exeinto /etc/wpa_supplicant/
+ newexe "${FILESDIR}"/wpa_cli.sh wpa_cli.sh
+ insinto /etc/wpa_supplicant/
+ newins "${FILESDIR}"/wpa_supplicant.conf wpa_supplicant.conf
+
+ if use qt4 ; then
+ into /usr
+ dobin wpa_gui-qt4/wpa_gui
+ elif use qt3 ; then
+ into /usr
+ dobin wpa_gui/wpa_gui
+ fi
+
+ if use qt3 || use qt4; then
+ make_desktop_entry wpa_gui "WPA_Supplicant Administration GUI"
+ fi
+
+ dodoc ChangeLog COPYING eap_testing.txt README todo.txt
+ newdoc wpa_supplicant.conf wpa_supplicant.conf
+
+ doman doc/docbook/*.8
+ doman doc/docbook/*.5
+}
+
+pkg_postinst() {
+ einfo "A default configuration file has been installed to"
+ einfo "/etc/wpa_supplicant/wpa_supplicant.conf"
+ einfo
+ einfo "An example configuration file is available as"
+ einfo "/usr/share/doc/${PF}/wpa_supplicant.conf.gz"
+
+ if [[ -e ${ROOT}etc/wpa_supplicant.conf ]] ; then
+ echo
+ ewarn "WARNING: your old configuration file ${ROOT}etc/wpa_supplicant.conf"
+ ewarn "needs to be moved to ${ROOT}etc/wpa_supplicant/wpa_supplicant.conf"
+ fi
+
+ if use madwifi; then
+ echo
+ einfo "This package now compiles against the headers installed by"
+ einfo "the madwifi driver. You should reemerge ${PN} after"
+ einfo "upgrading your madwifi driver."
+ fi
+}