summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-04 01:52:09 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-04 01:52:09 +0000
commitd86cd2fcddf7040f13d324dfca357e2e620b4ac6 (patch)
treef527af72acdd99e094d550924a338c6b6eec6a01
parentclean ups (diff)
downloadgentoo-2-d86cd2fcddf7040f13d324dfca357e2e620b4ac6.tar.gz
gentoo-2-d86cd2fcddf7040f13d324dfca357e2e620b4ac6.tar.bz2
gentoo-2-d86cd2fcddf7040f13d324dfca357e2e620b4ac6.zip
ebuild cleanup
-rw-r--r--dev-python/ScientificPython/ChangeLog6
-rw-r--r--dev-python/ScientificPython/ScientificPython-2.2-r1.ebuild31
2 files changed, 17 insertions, 20 deletions
diff --git a/dev-python/ScientificPython/ChangeLog b/dev-python/ScientificPython/ChangeLog
index 1711c499fe5c..cc6c3f403869 100644
--- a/dev-python/ScientificPython/ChangeLog
+++ b/dev-python/ScientificPython/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for dev-python/ScientificPython
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ScientificPython/ChangeLog,v 1.5 2003/02/12 06:31:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ScientificPython/ChangeLog,v 1.6 2003/04/04 01:52:09 liquidx Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*ScientificPython-2.2-r1 (1 Feb 2002)
+ 04 Apr 2003; Alastair Tse <liquidx@gentoo.org>
+ ScientificPython-2.2-r1.ebuild:
+ distutil-ize ebuild
+
15 July 2002; George Shapovalov <george@gentoo.org> ScientificPython-2.2-r1.ebuild :
cleaned up and added necessary vars/headers.
diff --git a/dev-python/ScientificPython/ScientificPython-2.2-r1.ebuild b/dev-python/ScientificPython/ScientificPython-2.2-r1.ebuild
index d7aa958d4c17..0e61845e2fa6 100644
--- a/dev-python/ScientificPython/ScientificPython-2.2-r1.ebuild
+++ b/dev-python/ScientificPython/ScientificPython-2.2-r1.ebuild
@@ -1,38 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ScientificPython/ScientificPython-2.2-r1.ebuild,v 1.8 2003/02/13 11:33:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ScientificPython/ScientificPython-2.2-r1.ebuild,v 1.9 2003/04/04 01:52:09 liquidx Exp $
+inherit distutils
-S=${WORKDIR}/${P}
-DESCRIPTION="scientific python module"
+IUSE=""
+DESCRIPTION="Scientific Module for Python"
SRC_URI="http://starship.python.net/crew/hinsen/${P}.tar.gz"
HOMEPAGE="http://starship.python.net/crew/hinsen/scientific.html"
-
-DEPEND=">=dev-lang/python-2.0-r4
- >=dev-python/Numeric-19.0
- >=app-sci/netcdf-3.0"
-
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc alpha"
-
-src_compile() {
- python setup.py build || die
-}
+
+DEPEND="virtual/python
+ >=dev-python/Numeric-19.0
+ >=app-sci/netcdf-3.0"
+
src_install() {
- python setup.py install --prefix=${D}/usr || die
+ distutils_src_install
dodoc MANIFEST.in COPYRIGHT README*
cd Doc
dodoc CHANGELOG
dohtml HTML/*
- dodir /usr/share/doc/${P}/pdf
- insinto /usr/share/doc/${P}/pdf
+ dodir /usr/share/doc/${PF}/pdf
+ insinto /usr/share/doc/${PF}/pdf
doins PDF/*
- #for p in PDF/*.pdf; do
- # dodoc $p
- #done
-
}