summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-07-20 12:48:50 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-07-20 12:48:50 +0000
commitd8ea97deb9829b185b04eef76faa1a48bcb3491f (patch)
treedd9a9895d6b00e8a7492816847c886ea032b1e7c
parentKeyworded ~sparc (diff)
downloadgentoo-2-d8ea97deb9829b185b04eef76faa1a48bcb3491f.tar.gz
gentoo-2-d8ea97deb9829b185b04eef76faa1a48bcb3491f.tar.bz2
gentoo-2-d8ea97deb9829b185b04eef76faa1a48bcb3491f.zip
Version bump
(Portage version: 2.1.3_rc8)
-rw-r--r--dev-libs/opensc/ChangeLog8
-rw-r--r--dev-libs/opensc/files/digest-opensc-0.11.33
-rw-r--r--dev-libs/opensc/opensc-0.11.2.ebuild23
-rw-r--r--dev-libs/opensc/opensc-0.11.3.ebuild54
4 files changed, 79 insertions, 9 deletions
diff --git a/dev-libs/opensc/ChangeLog b/dev-libs/opensc/ChangeLog
index 8221590f73e7..50568a9969d7 100644
--- a/dev-libs/opensc/ChangeLog
+++ b/dev-libs/opensc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/opensc
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.38 2007/07/20 11:38:00 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/ChangeLog,v 1.39 2007/07/20 12:48:50 alonbl Exp $
+
+*opensc-0.11.3 (20 Jul 2007)
+
+ 20 Jul 2007; Alon Bar-Lev <alonbl@gentoo.org> opensc-0.11.2.ebuild,
+ +opensc-0.11.3.ebuild:
+ Version bump
*opensc-0.11.2 (20 Jul 2007)
diff --git a/dev-libs/opensc/files/digest-opensc-0.11.3 b/dev-libs/opensc/files/digest-opensc-0.11.3
new file mode 100644
index 000000000000..3a519666ca28
--- /dev/null
+++ b/dev-libs/opensc/files/digest-opensc-0.11.3
@@ -0,0 +1,3 @@
+MD5 10897652e1f8d08d3c953982a4237f2e opensc-0.11.3.tar.gz 1414740
+RMD160 70accbc59bbf7f8e222c56ed0b69c42b39b0d262 opensc-0.11.3.tar.gz 1414740
+SHA256 4ef75dee81a71470911eaca0e0fd3a761c8a16cb53759e443f835137d530f197 opensc-0.11.3.tar.gz 1414740
diff --git a/dev-libs/opensc/opensc-0.11.2.ebuild b/dev-libs/opensc/opensc-0.11.2.ebuild
index 5d3cb8786736..f263381f317e 100644
--- a/dev-libs/opensc/opensc-0.11.2.ebuild
+++ b/dev-libs/opensc/opensc-0.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.11.2.ebuild,v 1.1 2007/07/20 11:38:00 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.11.2.ebuild,v 1.2 2007/07/20 12:48:50 alonbl Exp $
WANT_AUTOMAKE="1.9"
@@ -13,26 +13,33 @@ SRC_URI="http://www.opensc-project.org/files/opensc/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="pcsc-lite openct"
+IUSE="pcsc-lite openct nsplugin"
RDEPEND="dev-libs/openssl
sys-libs/zlib
openct? ( >=dev-libs/openct-0.5.0 )
- pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )"
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ nsplugin? ( app-crypt/pinentry )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ nsplugin? ( dev-libs/libassuan )"
src_compile() {
- # --without-plugin-dir generates a /no directory
+ local ASSUAN_PREFIX="${T}"
+
# disable assuan stuff it create text realocation.
+ use nsplugin && ASSUAN_PREFIX=/usr
+
+ # --without-plugin-dir generates a /no directory
econf \
- --with-plugin-dir=/usr/lib/mozilla/plugins \
$(use_enable openct) \
$(use_enable pcsc-lite) \
- --with-libassuan-prefix="${T}" \
+ --with-plugin-dir=/usr/lib/mozilla/plugins \
+ --with-libassuan-prefix="${ASSUAN_PREFIX}" \
+ --with-pin-entry="/usr/bin/pinentry" \
|| die
- emake -j1 || die
+ emake || die
}
src_install() {
diff --git a/dev-libs/opensc/opensc-0.11.3.ebuild b/dev-libs/opensc/opensc-0.11.3.ebuild
new file mode 100644
index 000000000000..8b1ec2c9c8d8
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.11.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/opensc/opensc-0.11.3.ebuild,v 1.1 2007/07/20 12:48:50 alonbl Exp $
+
+WANT_AUTOMAKE="1.9"
+
+inherit eutils libtool autotools
+
+DESCRIPTION="SmartCard library and applications"
+HOMEPAGE="http://www.opensc-project.org/opensc/"
+SRC_URI="http://www.opensc-project.org/files/opensc/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="pcsc-lite openct nsplugin"
+
+RDEPEND="dev-libs/openssl
+ sys-libs/zlib
+ openct? ( >=dev-libs/openct-0.5.0 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )
+ nsplugin? ( app-crypt/pinentry )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nsplugin? ( dev-libs/libassuan )"
+
+src_compile() {
+ local ASSUAN_PREFIX="${T}"
+
+ # disable assuan stuff it create text realocation.
+ use nsplugin && ASSUAN_PREFIX=/usr
+
+ # --without-plugin-dir generates a /no directory
+ econf \
+ $(use_enable openct) \
+ $(use_enable pcsc-lite) \
+ --with-plugin-dir=/usr/lib/mozilla/plugins \
+ --with-libassuan-prefix="${ASSUAN_PREFIX}" \
+ --with-pin-entry="/usr/bin/pinentry" \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ dodoc NEWS README
+ dohtml doc/*.{html,css}
+
+ insinto /etc
+ doins etc/opensc.conf
+}
+