summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-04-06 15:57:05 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-04-06 15:57:05 +0000
commitdd1967e24b124f1c6baf21fc8e23f74dc3877022 (patch)
tree55f9d134fde88bfbd9a1bc7f6960b723539ea873
parentStable on ppc64; bug #215735 (diff)
downloadgentoo-2-dd1967e24b124f1c6baf21fc8e23f74dc3877022.tar.gz
gentoo-2-dd1967e24b124f1c6baf21fc8e23f74dc3877022.tar.bz2
gentoo-2-dd1967e24b124f1c6baf21fc8e23f74dc3877022.zip
Manually add antttasks.properties to the compiler jar. Reported in bug #216261.
(Portage version: 2.1.4.4)
-rw-r--r--dev-java/commons-attributes/ChangeLog9
-rw-r--r--dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild49
-rw-r--r--dev-java/commons-attributes/files/anttasks.properties18
-rw-r--r--dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch32
4 files changed, 57 insertions, 51 deletions
diff --git a/dev-java/commons-attributes/ChangeLog b/dev-java/commons-attributes/ChangeLog
index 41922b1de28b..e4aef7967a7c 100644
--- a/dev-java/commons-attributes/ChangeLog
+++ b/dev-java/commons-attributes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/commons-attributes
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/ChangeLog,v 1.10 2008/04/05 00:37:20 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/ChangeLog,v 1.11 2008/04/06 15:57:05 betelgeuse Exp $
+
+*commons-attributes-2.2-r1 (06 Apr 2008)
+
+ 06 Apr 2008; Petteri Räty <betelgeuse@gentoo.org>
+ -files/commons-attributes-2.1-gentoo.patch, -files/anttasks.properties,
+ +commons-attributes-2.2-r1.ebuild:
+ Manually add antttasks.properties to the compiler jar. Reported in bug #216261.
05 Apr 2008; Petteri Räty <betelgeuse@gentoo.org>
commons-attributes-2.2.ebuild:
diff --git a/dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild b/dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild
new file mode 100644
index 000000000000..4456b5281c8e
--- /dev/null
+++ b/dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild,v 1.1 2008/04/06 15:57:05 betelgeuse Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Attributes enables Java programmers to use C#/.Net-style attributes in their code."
+HOMEPAGE="http://commons.apache.org/attributes/"
+SRC_URI="mirror://apache/commons/attributes/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/xjavadoc
+ dev-java/gjdoc
+ dev-java/ant-core
+ dev-java/qdox:1.6"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="ant-core,gjdoc,qdox-1.6"
+
+src_compile() {
+ java-pkg-2_src_compile
+ # the generated build.xml is faulty
+ jar uf target/${PN}-compiler-${PV}.jar -C compiler/src/java \
+ org/apache/commons/attributes/anttasks.properties || die
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
+ java-pkg_newjar target/${PN}-compiler-${PV}.jar ${PN}-compiler.jar
+
+ java-pkg_register-ant-task
+
+ dodoc NOTICE.txt || die
+ dohtml README.html || die
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc api/src/java/org compiler/src/java/org
+}
diff --git a/dev-java/commons-attributes/files/anttasks.properties b/dev-java/commons-attributes/files/anttasks.properties
deleted file mode 100644
index 271c87b9240d..000000000000
--- a/dev-java/commons-attributes/files/anttasks.properties
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright 2003-2004 The Apache Software Foundation
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-#
-attribute-compiler=org.apache.commons.attributes.compiler.AttributeCompiler
-attribute-indexer=org.apache.commons.attributes.compiler.AttributeIndexer
-attribute-validator=org.apache.commons.attributes.validation.AttributeValidatorTask \ No newline at end of file
diff --git a/dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch b/dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch
deleted file mode 100644
index b4de400cb3a1..000000000000
--- a/dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Only in commons-attributes-patched/: .build.xml.swo
-Only in commons-attributes-patched/: .build.xml.swp
-diff -ru commons-attributes/build.xml commons-attributes-patched/build.xml
---- commons-attributes/build.xml 2004-08-01 16:18:27.000000000 -0400
-+++ commons-attributes-patched/build.xml 2005-06-24 21:31:02.000000000 -0400
-@@ -86,6 +86,9 @@
- <include name="**/*.xservice">
- </include>
- </fileset>
-+ <fileset dir="compiler/src/java">
-+ <include name="org/apache/commons/attributes/anttasks.properties"/>
-+ </fileset>
- </copy>
- <copy todir="${classesdir}">
- <fileset dir="." includes="LICENSE.txt,NOTICE.txt"/>
-@@ -100,7 +103,7 @@
- <target name="jar" description="o Create the jar" depends="compile">
- <jar jarfile="target/${final.name.api}.jar" includes="org/apache/commons/attributes/*,LICENSE.txt,NOTICE.txt" basedir="${classesdir}">
- </jar>
-- <jar jarfile="target/${final.name.compiler}.jar" excludes="org/apache/commons/attributes/*" includes="**/*" basedir="${classesdir}">
-+ <jar jarfile="target/${final.name.compiler}.jar" excludes="org/apache/commons/attributes/*.class" includes="**/*,org/apache/commons/attributes/anttasks.properties" basedir="${classesdir}">
- </jar>
- </target>
- <target name="clean" description="o Clean up the generated directories">
-@@ -162,4 +167,4 @@
- <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
- </unjar>
- </target>
--</project>
-\ No newline at end of file
-+</project>
-Only in commons-attributes-patched/: target