summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-07-10 11:14:25 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-07-10 11:14:25 +0000
commitddbe8e238e52c881f32d405bc66b239d35820b87 (patch)
treea2224cef7badb89ccd87ff548f61dee2dc1e5da7
parentDepend on =net-libs/xulrunner-1.9.0* w.r.t bug 268394 (diff)
downloadgentoo-2-ddbe8e238e52c881f32d405bc66b239d35820b87.tar.gz
gentoo-2-ddbe8e238e52c881f32d405bc66b239d35820b87.tar.bz2
gentoo-2-ddbe8e238e52c881f32d405bc66b239d35820b87.zip
Fix firefox[xulrunner] check to apply only to 3.0. 3.5 doesn't have it optional anymore, bug 268394
(Portage version: 2.2_rc33/cvs/Linux i686)
-rw-r--r--www-plugins/mplayerplug-in/ChangeLog6
-rw-r--r--www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/www-plugins/mplayerplug-in/ChangeLog b/www-plugins/mplayerplug-in/ChangeLog
index 84a165362ff1..ffc69c45dad2 100644
--- a/www-plugins/mplayerplug-in/ChangeLog
+++ b/www-plugins/mplayerplug-in/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/mplayerplug-in
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/ChangeLog,v 1.3 2009/05/31 00:47:07 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/ChangeLog,v 1.4 2009/07/10 11:14:25 nirbheek Exp $
+
+ 10 Jul 2009; <nirbheek@gentoo.org> mplayerplug-in-3.55-r1.ebuild:
+ Fix firefox[xulrunner] check to apply only to 3.0. 3.5 doesn't have it
+ optional anymore, bug 268394
31 May 2009; Ryan Hill <dirtyepic@gentoo.org>
mplayerplug-in-3.55-r1.ebuild, +files/mplayerplug-in-3.55-glibc210.patch:
diff --git a/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild b/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild
index b7235d5bd56d..5a79a71f6dfc 100644
--- a/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild
+++ b/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild,v 1.2 2009/05/31 00:47:07 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/mplayerplug-in/mplayerplug-in-3.55-r1.ebuild,v 1.3 2009/07/10 11:14:25 nirbheek Exp $
inherit eutils multilib autotools flag-o-matic
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
pkg_setup() {
### Mozilla Firefox 3.0 doesn't install the pkg config files
- if has_version ">=www-client/mozilla-firefox-3.0" &&
+ if has_version "=www-client/mozilla-firefox-3.0*" &&
! built_with_use www-client/mozilla-firefox xulrunner; then
die 'Firefox 3.0 must be built with USE="xulrunner"'
fi