summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 01:44:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 01:44:50 +0000
commite31fee59fba9a41705d9ffee35cb9a4f2e0b1875 (patch)
treedde2ac81be0a890ed44d4d3a0621e76b61b23c8b
parentRemoved old versions. Added R_HOME environment variable (diff)
downloadgentoo-2-e31fee59fba9a41705d9ffee35cb9a4f2e0b1875.tar.gz
gentoo-2-e31fee59fba9a41705d9ffee35cb9a4f2e0b1875.tar.bz2
gentoo-2-e31fee59fba9a41705d9ffee35cb9a4f2e0b1875.zip
version bump
(Portage version: 2.1.3.19)
-rw-r--r--games-server/crossfire-server/ChangeLog10
-rw-r--r--games-server/crossfire-server/crossfire-server-1.11.0.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/games-server/crossfire-server/ChangeLog b/games-server/crossfire-server/ChangeLog
index 1d8d82ba7419..6d993d5f21e0 100644
--- a/games-server/crossfire-server/ChangeLog
+++ b/games-server/crossfire-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-server/crossfire-server
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/ChangeLog,v 1.12 2007/08/25 23:38:20 tupone Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/ChangeLog,v 1.13 2008/02/11 01:44:50 mr_bones_ Exp $
+
+*crossfire-server-1.11.0 (11 Feb 2008)
+
+ 11 Feb 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +crossfire-server-1.11.0.ebuild:
+ version bump
*crossfire-server-1.10.0 (25 Aug 2007)
diff --git a/games-server/crossfire-server/crossfire-server-1.11.0.ebuild b/games-server/crossfire-server/crossfire-server-1.11.0.ebuild
new file mode 100644
index 000000000000..a230ceb99fb8
--- /dev/null
+++ b/games-server/crossfire-server/crossfire-server-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/crossfire-server-1.11.0.ebuild,v 1.1 2008/02/11 01:44:50 mr_bones_ Exp $
+
+inherit games
+
+MY_P="${P/-server/}"
+DESCRIPTION="server for the crossfire clients"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${MY_P}.tar.gz
+ mirror://sourceforge/crossfire/crossfire-${PV}.maps.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+DEPEND="
+ X? (
+ x11-libs/libXaw
+ media-libs/libpng )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_with X x) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ keepdir "${GAMES_STATEDIR}"/crossfire/{datafiles,maps,players,template-maps,unique-items}
+ dodoc AUTHORS ChangeLog DEVELOPERS NEWS README TODO
+ insinto "${GAMES_DATADIR}/crossfire"
+ doins -r "${WORKDIR}/maps" || die "doins failed"
+ prepgamesdirs
+}