summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-04-04 00:53:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-04-04 00:53:00 +0000
commite321fa0d5bdcdcdc76df176a94cf15d3b7184906 (patch)
treed04378907d97baa6851449cd41b5f0860d1aa5a7
parentstable amd64, bug 264503 (diff)
downloadgentoo-2-e321fa0d5bdcdcdc76df176a94cf15d3b7184906.tar.gz
gentoo-2-e321fa0d5bdcdcdc76df176a94cf15d3b7184906.tar.bz2
gentoo-2-e321fa0d5bdcdcdc76df176a94cf15d3b7184906.zip
EAPI=2; add gcc44 patch from Paul Mulders (bug #264739)
(Portage version: 2.1.6.7/cvs/Linux i686)
-rw-r--r--games-puzzle/pingus/ChangeLog8
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.2-gcc44.patch20
-rw-r--r--games-puzzle/pingus/pingus-0.7.2.ebuild23
3 files changed, 39 insertions, 12 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index baa41235cf56..b45333b5bbad 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/pingus
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.22 2008/09/04 16:31:25 mr_bones_ Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.23 2009/04/04 00:53:00 mr_bones_ Exp $
+
+ 04 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/pingus-0.7.2-gcc44.patch, pingus-0.7.2.ebuild:
+ EAPI=2; add gcc44 patch from Paul Mulders (bug #264739)
04 Sep 2008; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.2.ebuild:
Attempt at using a less-ugly icon (bug #236596)
diff --git a/games-puzzle/pingus/files/pingus-0.7.2-gcc44.patch b/games-puzzle/pingus/files/pingus-0.7.2-gcc44.patch
new file mode 100644
index 000000000000..7917afb4f3fa
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.2-gcc44.patch
@@ -0,0 +1,20 @@
+--- src/input/evdev_device.cpp.old 2009-04-03 12:14:25.027452635 +0200
++++ src/input/evdev_device.cpp 2009-04-03 12:14:31.672453084 +0200
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <cstdio>
+ #include <assert.h>
+ #include <linux/input.h>
+ #include <sys/ioctl.h>
+--- src/tinygettext/po_file_reader.cpp.old 2009-04-03 12:13:30.095452649 +0200
++++ src/tinygettext/po_file_reader.cpp 2009-04-03 12:13:38.117452492 +0200
+@@ -17,6 +17,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
++#include <cstdio>
+ #include <config.h>
+ #include <vector>
+ #include <iconv.h>
diff --git a/games-puzzle/pingus/pingus-0.7.2.ebuild b/games-puzzle/pingus/pingus-0.7.2.ebuild
index 4ea1cc42b54e..679a17864955 100644
--- a/games-puzzle/pingus/pingus-0.7.2.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.2.ebuild,v 1.8 2008/09/04 16:31:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.2.ebuild,v 1.9 2009/04/04 00:53:00 mr_bones_ Exp $
+EAPI=2
inherit eutils toolchain-funcs games
DESCRIPTION="free Lemmings clone"
@@ -21,12 +22,11 @@ RDEPEND="media-libs/libsdl
DEPEND="${RDEPEND}
>=dev-util/scons-0.97"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-paths.patch \
- "${FILESDIR}/${P}+gcc-4.3.patch"
+ "${FILESDIR}"/${P}+gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
sed -i \
-e "s:GENTOO_BINDIR:${GAMES_BINDIR}:" \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
@@ -34,15 +34,18 @@ src_unpack() {
|| die "sed failed"
}
-src_compile() {
- local sconsopts=$(echo "${MAKEOPTS}" | sed -e "s/.*\(-j[0-9]\+\).*/\1/")
- [[ ${MAKEOPTS/-s/} != ${MAKEOPTS} ]] && sconsopts="${sconsopts} -s"
-
+src_configure() {
scons configure \
CXX="$(tc-getCXX)" \
CCFLAGS="${CXXFLAGS}" \
LINKFLAGS="${LDFLAGS}" \
|| die "scons configure failed"
+}
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -e "s/.*\(-j[0-9]\+\).*/\1/")
+ [[ ${MAKEOPTS/-s/} != ${MAKEOPTS} ]] && sconsopts="${sconsopts} -s"
+
scons ${sconsopts} || die "scons failed"
}