summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-05 21:39:00 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-05 21:39:00 +0000
commite6018d0af46efcd342fc4d6e529e8e3b13ba3f8c (patch)
tree52193d09866c55c32c2973e08be1b4935f98172a
parentAdd prefix keywords (diff)
downloadgentoo-2-e6018d0af46efcd342fc4d6e529e8e3b13ba3f8c.tar.gz
gentoo-2-e6018d0af46efcd342fc4d6e529e8e3b13ba3f8c.tar.bz2
gentoo-2-e6018d0af46efcd342fc4d6e529e8e3b13ba3f8c.zip
Bump to EAPI=3, add prefix keywords & patch
(Portage version: -svn/cvs/Linux i686)
-rw-r--r--app-text/antiword/ChangeLog8
-rw-r--r--app-text/antiword/antiword-0.37.ebuild29
-rw-r--r--app-text/antiword/files/antiword-0.37-prefix.patch71
3 files changed, 93 insertions, 15 deletions
diff --git a/app-text/antiword/ChangeLog b/app-text/antiword/ChangeLog
index f57d658ca1d9..9a5db02e2790 100644
--- a/app-text/antiword/ChangeLog
+++ b/app-text/antiword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/antiword
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/ChangeLog,v 1.40 2009/09/06 18:43:16 idl0r Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/ChangeLog,v 1.41 2010/04/05 21:38:59 abcd Exp $
+
+ 05 Apr 2010; Jonathan Callen <abcd@gentoo.org> antiword-0.37.ebuild,
+ +files/antiword-0.37-prefix.patch:
+ Bump to EAPI=3, add prefix keywords & patch
06 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
-files/antiword-0.36.1-ppc-macos.diff, antiword-0.37.ebuild,
diff --git a/app-text/antiword/antiword-0.37.ebuild b/app-text/antiword/antiword-0.37.ebuild
index 6ef901818be9..df89cfe35c47 100644
--- a/app-text/antiword/antiword-0.37.ebuild
+++ b/app-text/antiword/antiword-0.37.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.37.ebuild,v 1.12 2009/09/06 18:43:16 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.37.ebuild,v 1.13 2010/04/05 21:38:59 abcd Exp $
+
+EAPI="3"
inherit eutils toolchain-funcs
@@ -13,32 +15,33 @@ SRC_URI="http://www.winfield.demon.nl/linux/${P}.tar.gz
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86 ~ppc-aix ~ia64-hpux ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
PATCHDIR=${WORKDIR}/gentoo-antiword/patches
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
EPATCH_SUFFIX="diff" \
epatch ${PATCHDIR}
+
+ epatch "${FILESDIR}"/${P}-prefix.patch
}
+src_configure() { :; }
+
src_compile() {
- emake OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ emake PREFIX="${EPREFIX}" OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" global_install || die
+ emake -j1 PREFIX="${EPREFIX}" DESTDIR="${D}" global_install || die
- use kde || rm -f "${D}"/usr/bin/kantiword
+ use kde || rm -f "${ED}"/usr/bin/kantiword
insinto /usr/share/${PN}/examples
- doins Docs/testdoc.doc Docs/antiword.php
+ doins Docs/testdoc.doc Docs/antiword.php || die
cd Docs
- doman antiword.1
- dodoc ChangeLog Exmh Emacs FAQ History Netscape \
- QandA ReadMe Mozilla Mutt
+ doman antiword.1 || die
+ dodoc ChangeLog Exmh Emacs FAQ History Netscape QandA ReadMe Mozilla Mutt || die
}
diff --git a/app-text/antiword/files/antiword-0.37-prefix.patch b/app-text/antiword/files/antiword-0.37-prefix.patch
new file mode 100644
index 000000000000..40053696f52e
--- /dev/null
+++ b/app-text/antiword/files/antiword-0.37-prefix.patch
@@ -0,0 +1,71 @@
+--- antiword.h
++++ antiword.h
+@@ -191,43 +191,11 @@
+ #define FONT_SANS_SERIF_ITALIC "Helvetica-Oblique"
+ #define FONT_SANS_SERIF_BOLDITALIC "Helvetica-BoldOblique"
+ /* The name of the antiword directories and the font information file */
+-#if defined(__dos)
+-#define GLOBAL_ANTIWORD_DIR "C:\\antiword"
+-#define ANTIWORD_DIR "antiword"
+-#define FONTNAMES_FILE "fontname.txt"
+-#elif defined(__amigaos)
+-#define GLOBAL_ANTIWORD_DIR "SYS:.antiword"
+-#define ANTIWORD_DIR ".antiword"
+-#define FONTNAMES_FILE "fontnames"
+-#elif defined(N_PLAT_NLM)
+-#define GLOBAL_ANTIWORD_DIR "SYS:/antiword"
+-#define ANTIWORD_DIR "antiword"
+-#define FONTNAMES_FILE "fontname.txt"
+-#elif defined(__vms)
+-#define GLOBAL_ANTIWORD_DIR "/usr/share/antiword"
+-#define ANTIWORD_DIR "antiword"
+-#define FONTNAMES_FILE "fontnames"
+-#elif defined(__BEOS__)
+-#define GLOBAL_ANTIWORD_DIR "/boot/home/config/apps/antiword"
+-#define ANTIWORD_DIR "antiword"
+-#define FONTNAMES_FILE "fontnames"
+-#elif defined(__CYGMING__)
+-#define GLOBAL_ANTIWORD_DIR "C:\\antiword"
+-#define ANTIWORD_DIR "antiword"
+-#define FONTNAMES_FILE "fontnames"
+-#elif defined(__Plan9__)
+-#define GLOBAL_ANTIWORD_DIR "/sys/lib/antiword"
+-#define ANTIWORD_DIR "lib/antiword"
+-#define FONTNAMES_FILE "fontnames"
+-#elif defined(__sun__)
+-#define GLOBAL_ANTIWORD_DIR "/usr/local/share/antiword"
++#ifndef GLOBAL_ANTIWORD_DIR
++#error "GLOBAL_ANTIWORD_DIR is unset!"
++#endif
+ #define ANTIWORD_DIR ".antiword"
+ #define FONTNAMES_FILE "fontnames"
+-#else /* All others */
+-#define GLOBAL_ANTIWORD_DIR "/usr/share/antiword"
+-#define ANTIWORD_DIR ".antiword"
+-#define FONTNAMES_FILE "fontnames"
+-#endif /* __dos */
+ /* The names of grouped mapping files */
+ /* ASCII */
+ #define MAPPING_FILE_CP437 "cp437.txt"
+--- Makefile
++++ Makefile
+@@ -36,8 +36,8 @@
+ LOCAL_INSTALL_DIR = $(HOME)/bin
+ LOCAL_RESOURCES_DIR = $(HOME)/.antiword
+
+-GLOBAL_INSTALL_DIR = /usr/bin
+-GLOBAL_RESOURCES_DIR = /usr/share/antiword
++GLOBAL_INSTALL_DIR = $(PREFIX)/usr/bin
++GLOBAL_RESOURCES_DIR = $(PREFIX)/usr/share/antiword
+
+ all: $(PROGS)
+
+@@ -83,7 +83,7 @@
+ @chmod 750 $@
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $<
++ $(CC) $(CFLAGS) '-DGLOBAL_ANTIWORD_DIR="$(GLOBAL_RESOURCES_DIR)"' -c $<
+
+ main_u.o: version.h
+ postscript.o: version.h