summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-20 06:06:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-20 06:06:04 +0000
commite61bbbef5e539232bd452f05ce8b1ec909ce45a1 (patch)
tree57915d39f3159267412e6987aa3fac9faf7935de
parentVersion bump (#144405). (diff)
downloadgentoo-2-e61bbbef5e539232bd452f05ce8b1ec909ce45a1.tar.gz
gentoo-2-e61bbbef5e539232bd452f05ce8b1ec909ce45a1.tar.bz2
gentoo-2-e61bbbef5e539232bd452f05ce8b1ec909ce45a1.zip
add a wrapper the kernel expects
(Portage version: 2.1.1_pre5-r2)
-rw-r--r--sys-devel/kgcc64/files/wrapper2
-rw-r--r--sys-devel/kgcc64/kgcc64-3.4.6.ebuild14
-rw-r--r--sys-devel/kgcc64/kgcc64-4.1.1.ebuild14
3 files changed, 26 insertions, 4 deletions
diff --git a/sys-devel/kgcc64/files/wrapper b/sys-devel/kgcc64/files/wrapper
new file mode 100644
index 000000000000..775f64b9d004
--- /dev/null
+++ b/sys-devel/kgcc64/files/wrapper
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec TARGET "$@"
diff --git a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
index 21987bb340e6..b7022d6c8c99 100644
--- a/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
+++ b/sys-devel/kgcc64/kgcc64-3.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.3 2006/08/17 15:58:25 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-3.4.6.ebuild,v 1.4 2006/08/20 06:06:04 vapier Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -30,7 +30,7 @@ DEPEND="hppa? ( sys-devel/binutils-hppa64 )
!sys-devel/gcc-mips64"
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
epatch "${GCC_FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
@@ -56,3 +56,13 @@ src_unpack() {
;;
esac
}
+
+src_install() {
+ toolchain_src_install
+
+ local x
+ for x in gcc cpp ; do
+ newbin "${FILESDIR}"/wrapper ${CTARGET%%-*}-linux-gnu-${x}
+ dosed "s:TARGET:${CTARGET}-${x}:" /usr/bin/${CTARGET%%-*}-linux-gnu-${x}
+ done
+}
diff --git a/sys-devel/kgcc64/kgcc64-4.1.1.ebuild b/sys-devel/kgcc64/kgcc64-4.1.1.ebuild
index 2b30be8c7bcd..37deb5ab6ddd 100644
--- a/sys-devel/kgcc64/kgcc64-4.1.1.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.1.1.ebuild,v 1.2 2006/08/17 15:58:25 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.1.1.ebuild,v 1.3 2006/08/20 06:06:04 vapier Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -30,8 +30,18 @@ DEPEND="hppa? ( sys-devel/binutils-hppa64 )
!sys-devel/gcc-mips64"
src_unpack() {
- gcc_src_unpack
+ toolchain_src_unpack
# Fix cross-compiling
epatch "${GCC_FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
}
+
+src_install() {
+ toolchain_src_install
+
+ local x
+ for x in gcc cpp ; do
+ newbin "${FILESDIR}"/wrapper ${CTARGET%%-*}-linux-gnu-${x}
+ dosed "s:TARGET:${CTARGET}-${x}:" /usr/bin/${CTARGET%%-*}-linux-gnu-${x}
+ done
+}