summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-09-28 19:38:38 +0000
committerDan Armak <danarmak@gentoo.org>2001-09-28 19:38:38 +0000
commite7ce1140fb8be052efdea52f276c38ab16ff96eb (patch)
treec23a11566e6796f4e5bca61181c827ff8b5823eb
parentfixes (diff)
downloadgentoo-2-e7ce1140fb8be052efdea52f276c38ab16ff96eb.tar.gz
gentoo-2-e7ce1140fb8be052efdea52f276c38ab16ff96eb.tar.bz2
gentoo-2-e7ce1140fb8be052efdea52f276c38ab16ff96eb.zip
first proof-of-concept inheritnig ebuild coming in!
-rw-r--r--kde-base/kdebase/kdebase-2.2.1-r1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/kde-base/kdebase/kdebase-2.2.1-r1.ebuild b/kde-base/kdebase/kdebase-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..07a953213abf
--- /dev/null
+++ b/kde-base/kdebase/kdebase-2.2.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-2.2.1-r1.ebuild,v 1.1 2001/09/28 19:38:38 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-base || die
+
+DESCRIPTION="KDE ${PV} - Base"
+
+SRC_PATH="kde/stable/${PV}/src/${P}.tar.bz2"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.fh-heilbronn.de/pub/mirrors/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+NEWDEPEND=">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ lame? ( =media-sound/lame-3.89b )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="$DEPEND $NEWDEPEND"
+RDEPEND="$RDEPEND $NEWDEPEND"
+
+echo $DEPEND > /1
+echo $RDEPEND > /2
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ldap && myconf="--with-ldap" || myconf="--without-ldap"
+ use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+ use motif || myconf="$myconf --without-motif"
+ use lame || myconf="$myconf --without-lame"
+ use cups || myconf="$myconf --disable-cups"
+ use vorbis || myconf="$myconf --without-vorbis"
+ use opengl || myconf="$myconf --without-gl"
+ use ssl || myconf="$myconf --without-ssl"
+
+ kde_src_compile configure make
+
+}
+
+
+src_install() {
+
+ kde_src_install all
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ cd ${D}/${KDEDIR}/bin
+ sed -e "s:^#\!/bin/sh:#\!/bin/sh --login:" \
+ -e "s/LD_BIND_NOW=true//" \
+ startkde > startkde.tmp
+ mv startkde.tmp startkde
+ chmod a+x startkde
+
+ exeinto /usr/X11R6/bin/wm
+ doexe ${FILESDIR}/{kde${PV},xsession}
+ cd ${D}/usr/X11R6/bin/wm
+ ln -sf kde${PV} kde
+
+ cd ${D}/${KDEDIR}/share/config/kdm
+ mv kdmrc kdmrc.orig
+ sed -e 's/SessionTypes=/SessionTypes=xsession,/' kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+}