summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-09-29 16:06:20 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-09-29 16:06:20 +0000
commitea3273cae1207a7f4d92430b08574c04adbe940b (patch)
tree7c4b4103e081dd525d1396b9cdbe1f191812090a
parentVersion bump, fixes download speedlimits (diff)
downloadgentoo-2-ea3273cae1207a7f4d92430b08574c04adbe940b.tar.gz
gentoo-2-ea3273cae1207a7f4d92430b08574c04adbe940b.tar.bz2
gentoo-2-ea3273cae1207a7f4d92430b08574c04adbe940b.zip
Added kolab support to cyrus-imap-admin (#231503).
(Portage version: 2.1.4.4)
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog7
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild8
-rw-r--r--net-mail/cyrus-imap-admin/files/KOLAB_cyrus-cyradm_Annotations.patch83
3 files changed, 95 insertions, 3 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index 6c1dbd67c337..58bc5bf9ddfb 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/cyrus-imap-admin
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.70 2008/06/04 19:06:51 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.71 2008/09/29 16:06:20 wrobel Exp $
+
+ 29 Sep 2008; wrobel@gentoo.org
+ +files/KOLAB_cyrus-cyradm_Annotations.patch,
+ cyrus-imap-admin-2.3.12_p2.ebuild:
+ Added kolab support to cyrus-imap-admin (#231503).
*cyrus-imap-admin-2.3.12_p2 (04 Jun 2008)
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild
index 4d1baad83cbd..47ba7e866190 100644
--- a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild,v 1.1 2008/06/04 19:06:51 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.12_p2.ebuild,v 1.2 2008/09/29 16:06:20 wrobel Exp $
inherit autotools perl-app eutils
@@ -14,7 +14,7 @@ SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${MY_PV}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa ~ppc64"
-IUSE="ssl kerberos"
+IUSE="ssl kerberos kolab"
RDEPEND=">=sys-libs/db-3.2
>=dev-lang/perl-5.6.1
@@ -45,6 +45,10 @@ src_unpack() {
# When linking with rpm, you need to link with more libraries.
sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
+ # Add kolab support.
+ if use kolab ; then
+ epatch "${FILESDIR}/KOLAB_cyrus-cyradm_Annotations.patch" || die "epatch failed"
+ fi
}
src_compile() {
diff --git a/net-mail/cyrus-imap-admin/files/KOLAB_cyrus-cyradm_Annotations.patch b/net-mail/cyrus-imap-admin/files/KOLAB_cyrus-cyradm_Annotations.patch
new file mode 100644
index 000000000000..2167f7f21874
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/files/KOLAB_cyrus-cyradm_Annotations.patch
@@ -0,0 +1,83 @@
+Allows to use arbitrary annotations with the cyradm tool.
+
+diff -r a07884e259c3 doc/man/cyradm.1.html
+--- a/doc/man/cyradm.1.html Thu Oct 25 08:24:39 2007 +0200
++++ b/doc/man/cyradm.1.html Thu Oct 25 08:29:40 2007 +0200
+@@ -241,6 +241,13 @@ The currently supported attributes are:<
+ <dd>
+ <p>Sets an email address to which messages injected into the server via NNTP
+ will be sent.</p>
++</dd>
++</li>
++<dt><strong><a NAME="item__2fexplicit_2fannotation"><code>/explicit/annotation</code></a></strong>
++
++<dd>
++<p>Sets the annotation <em>/explicit/annotation</em>
++on <em>mailbox</em> to <em>value</em>.</p>
+ </dd>
+ </li>
+ <dt><strong><a name="item_sharedseen"><code>sharedseen</code></a></strong>
+diff -r a07884e259c3 perl/imap/IMAP/Admin.pm
+--- a/perl/imap/IMAP/Admin.pm Thu Oct 25 08:24:39 2007 +0200
++++ b/perl/imap/IMAP/Admin.pm Thu Oct 25 08:29:40 2007 +0200
+@@ -796,11 +796,11 @@ sub mboxconfig {
+ return undef;
+ }
+
+- if(!exists($values{$entry})) {
+- $self->{error} = "Unknown parameter $entry";
+- }
+-
+- $entry = $values{$entry};
++ if(exists($values{$entry})) {
++ $entry = $values{$entry};
++ } else {
++ $self->{error} = "Unknown parameter $entry" unless substr($entry,0,1) eq "/";
++ }
+
+ my ($rc, $msg);
+
+diff -r a07884e259c3 perl/imap/IMAP/Shell.pm
+--- a/perl/imap/IMAP/Shell.pm Thu Oct 25 08:24:39 2007 +0200
++++ b/perl/imap/IMAP/Shell.pm Thu Oct 25 08:29:40 2007 +0200
+@@ -126,7 +126,7 @@ my %builtins = (exit =>
+ [\&_sc_info, '[mailbox]',
+ 'display mailbox/server metadata'],
+ mboxcfg =>
+- [\&_sc_mboxcfg, 'mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat] value',
++ [\&_sc_mboxcfg, 'mailbox [comment|condstore|news2mail|expire|sieve|squat|/<explicit annotation>] value',
+ 'configure mailbox'],
+ mboxconfig => 'mboxcfg',
+ reconstruct =>
+@@ -1436,7 +1436,7 @@ sub _sc_mboxcfg {
+ while (defined ($opt = shift(@argv))) {
+ last if $opt eq '--';
+ if ($opt =~ /^-/) {
+- die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat] value\n";
++ die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat|/<explicit annotation>] value\n";
+ }
+ else {
+ push(@nargv, $opt);
+@@ -1445,7 +1445,7 @@ sub _sc_mboxcfg {
+ }
+ push(@nargv, @argv);
+ if (@nargv < 2) {
+- die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat] value\n";
++ die "usage: mboxconfig mailbox [comment|condstore|expire|news2mail|sharedseen|sieve|squat|/<explicit annotation>] value\n";
+ }
+ if (!$cyrref || !$$cyrref) {
+ die "mboxconfig: no connection to server\n";
+diff -r a07884e259c3 perl/imap/cyradm.sh
+--- a/perl/imap/cyradm.sh Thu Oct 25 08:24:39 2007 +0200
++++ b/perl/imap/cyradm.sh Thu Oct 25 08:29:40 2007 +0200
+@@ -241,6 +241,10 @@ mailboxes).
+
+ Indicates that the mailbox should have a squat index created for it.
+
++=item C</explicit/annotation>
++
++Sets the annotation I</explicit/annotation> on I<mailbox> to I<value>.
++
+ =back
+
+ =item C<renamemailbox> [C<--partition> I<partition>] I<oldname> I<newname>