summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-10-15 03:05:19 +0000
committerJeroen Roovers <jer@gentoo.org>2008-10-15 03:05:19 +0000
commitebc732f7bc99261393090b07fe753d82b838f0d4 (patch)
tree200513fdcef5b2b58ef0181ebcbc614eac8c26ca
parentMarked ~hppa too. (diff)
downloadgentoo-2-ebc732f7bc99261393090b07fe753d82b838f0d4.tar.gz
gentoo-2-ebc732f7bc99261393090b07fe753d82b838f0d4.tar.bz2
gentoo-2-ebc732f7bc99261393090b07fe753d82b838f0d4.zip
Pick up CFLAGS from the environment instead of "setting them in stone" (bug #242030).
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
-rw-r--r--sys-fs/squashfs-tools/ChangeLog8
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild6
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild4
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild4
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild6
5 files changed, 17 insertions, 11 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index 60acafa7d032..dfa460e3d841 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.56 2008/08/28 03:36:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.57 2008/10/15 03:05:19 jer Exp $
+
+ 15 Oct 2008; Jeroen Roovers <jer@gentoo.org> squashfs-tools-3.1_p2.ebuild,
+ squashfs-tools-3.2_p2.ebuild, squashfs-tools-3.3.ebuild,
+ squashfs-tools-3.4.ebuild:
+ Pick up CFLAGS from the environment instead of "setting them in stone"
+ (bug #242030).
*squashfs-tools-3.4 (28 Aug 2008)
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild
index 9a688f11d2bf..e3d7c923bf19 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild,v 1.11 2007/05/15 15:13:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild,v 1.12 2008/10/15 03:05:19 jer Exp $
inherit toolchain-funcs
@@ -21,7 +21,7 @@ S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i "s:-O2:${CFLAGS}:" Makefile
+ sed -i 's:-O2:$(CFLAGS):' Makefile
}
src_compile() {
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
index 6d91c0393932..b6dec65cbbdb 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild,v 1.3 2008/06/28 09:13:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.2_p2.ebuild,v 1.4 2008/10/15 03:05:19 jer Exp $
inherit toolchain-funcs
@@ -21,7 +21,7 @@ S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i "s:-O2:${CFLAGS}:" Makefile
+ sed -i 's:-O2:$(CFLAGS):' Makefile
}
src_compile() {
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
index 1b32258087c8..1ca24229dde6 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild,v 1.4 2008/06/28 09:13:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild,v 1.5 2008/10/15 03:05:19 jer Exp $
inherit eutils toolchain-funcs
@@ -21,7 +21,7 @@ S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i "s:-O2:${CFLAGS}:" Makefile
+ sed -i 's:-O2:$(CFLAGS):' Makefile
epatch "${FILESDIR}"/squashfs-tools-3.3-posix.patch || die patching failed
}
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
index 135afc4522d8..5da6d6ace800 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild,v 1.1 2008/08/28 03:36:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild,v 1.2 2008/10/15 03:05:19 jer Exp $
inherit toolchain-funcs
@@ -22,8 +22,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
sed -i \
- -e "s:-O2:${CFLAGS}:" \
- -e 's:$(CC):$(CC) ${LDFLAGS}:' \
+ -e 's:-O2:$(CFLAGS):' \
+ -e 's:$(CC):$(CC) $(LDFLAGS):' \
Makefile || die "sed failed"
}