summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-28 14:12:30 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-28 14:12:30 +0000
commited9b610dc83dcd7f676a2ff5933835a53c6cc40c (patch)
treeaeba4650faf4ff34798032744cb5813d41be7203
parentInitial import of psybnc (diff)
downloadgentoo-2-ed9b610dc83dcd7f676a2ff5933835a53c6cc40c.tar.gz
gentoo-2-ed9b610dc83dcd7f676a2ff5933835a53c6cc40c.tar.bz2
gentoo-2-ed9b610dc83dcd7f676a2ff5933835a53c6cc40c.zip
New upstream version.
(Portage version: 2.1.1_pre5-r3)
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.10.0.ebuild36
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.10.03
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index ac4f27df2bf8..f98983333212 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.33 2006/08/16 13:59:02 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.34 2006/08/28 14:12:30 mkennedy Exp $
+
+*cl-tbnl-0.10.0 (28 Aug 2006)
+
+ 28 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.10.0.ebuild:
+ New upstream version.
*cl-tbnl-0.9.11 (16 Aug 2006)
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.10.0.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.10.0.ebuild
new file mode 100644
index 000000000000..b329e8ed4849
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.10.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.10.0.ebuild,v 1.1 2006/08/28 14:12:30 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="standalone apache2"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+RDEPEND="${DEPEND}
+ !standalone? ( apache2? ( >=www-apache/mod_lisp2-1.2 ) !apache2? ( www-apache/mod_lisp ) )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.10.0 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.10.0
new file mode 100644
index 000000000000..1c8d527afd88
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.10.0
@@ -0,0 +1,3 @@
+MD5 343b6c55cb91fed4833bf900303529a2 tbnl_0.10.0.orig.tar.gz 103897
+RMD160 6f7b96fc64f8d18cde3e3bf941bade094e8fab49 tbnl_0.10.0.orig.tar.gz 103897
+SHA256 41ee28d1975b163758d6ffbb049dc7d0c6b409e61d34666f510835468eacbebb tbnl_0.10.0.orig.tar.gz 103897