summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2005-09-01 11:59:18 +0000
committerPeter Bienstman <pbienst@gentoo.org>2005-09-01 11:59:18 +0000
commitf1962d2ec62dc389cf16c2d3c04ed2ec34dae099 (patch)
tree23318252d57140a234535c87235ac587d118666d
parentdrbd-0.7.12 masked (diff)
downloadgentoo-2-f1962d2ec62dc389cf16c2d3c04ed2ec34dae099.tar.gz
gentoo-2-f1962d2ec62dc389cf16c2d3c04ed2ec34dae099.tar.bz2
gentoo-2-f1962d2ec62dc389cf16c2d3c04ed2ec34dae099.zip
Move to virtual/blas and virtual/lapack.
(Portage version: 2.0.51.22-r2)
-rw-r--r--sys-cluster/hpl/ChangeLog7
-rw-r--r--sys-cluster/hpl/Manifest4
-rw-r--r--sys-cluster/hpl/files/digest-hpl-1.0-r21
-rw-r--r--sys-cluster/hpl/hpl-1.0-r2.ebuild56
4 files changed, 66 insertions, 2 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index 41ff475fd724..85e1f37d66c8 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/hpl
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.5 2005/07/06 01:01:52 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.6 2005/09/01 11:59:18 pbienst Exp $
+
+*hpl-1.0-r2 (01 Sep 2005)
+
+ 01 Sep 2005; Peter Bienstman <pbienst@gentoo.org> +hpl-1.0-r2.ebuild:
+ Move to virtual/blas and virtual/lapack.
*hpl-1.0-r1 (06 Jul 2005)
diff --git a/sys-cluster/hpl/Manifest b/sys-cluster/hpl/Manifest
index 75f86bb564bb..e9615e7a2b33 100644
--- a/sys-cluster/hpl/Manifest
+++ b/sys-cluster/hpl/Manifest
@@ -1,7 +1,9 @@
MD5 30aa78e4b8e7f90d12a8874ec708379e hpl-1.0-r1.ebuild 1819
MD5 87c27e6afa51d175e8088e38450a8c3d hpl-1.0.ebuild 1131
-MD5 d48bcb658b67ed94f0ad613be6e2fbca ChangeLog 907
+MD5 4e518c0ce98d0ee255bf2b21f0c47f02 ChangeLog 1050
MD5 41664043c4624dedcfeeb07950f08d13 metadata.xml 312
+MD5 22412a207b307a12690b81e532209e9d hpl-1.0-r2.ebuild 1736
MD5 6ba8acccaf6e3ca998fe7383c6765457 files/digest-hpl-1.0 52
MD5 56b70745bddaadc9125b94e1a92889e4 files/Make.gentoo_hpl_cblas_x86.diff.bz2 757
MD5 6ba8acccaf6e3ca998fe7383c6765457 files/digest-hpl-1.0-r1 52
+MD5 6ba8acccaf6e3ca998fe7383c6765457 files/digest-hpl-1.0-r2 52
diff --git a/sys-cluster/hpl/files/digest-hpl-1.0-r2 b/sys-cluster/hpl/files/digest-hpl-1.0-r2
new file mode 100644
index 000000000000..6b64c3df6adc
--- /dev/null
+++ b/sys-cluster/hpl/files/digest-hpl-1.0-r2
@@ -0,0 +1 @@
+MD5 32b432af96e674dcb657ef1d63e6d591 hpl.tgz 523139
diff --git a/sys-cluster/hpl/hpl-1.0-r2.ebuild b/sys-cluster/hpl/hpl-1.0-r2.ebuild
new file mode 100644
index 000000000000..bab5aee51830
--- /dev/null
+++ b/sys-cluster/hpl/hpl-1.0-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-1.0-r2.ebuild,v 1.1 2005/09/01 11:59:18 pbienst Exp $
+
+inherit eutils
+
+DESCRIPTION="HPL - A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
+HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
+SRC_URI="http://www.netlib.org/benchmark/hpl/hpl.tgz"
+LICENSE="HPL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S="${WORKDIR}/${PN}"
+
+DEPEND="virtual/mpi
+ virtual/blas
+ virtual/lapack"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86
+ sed -i \
+ -e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
+ -e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
+ -e '/^MPdir\>/s,= .*,=,' \
+ -e '/^MPlib\>/s,= .*,=,' \
+ -e "/^LAlib\>/s,= .*,= /usr/$(get_libdir)/libblas.so /usr/$(get_libdir)/liblapack.so," \
+ -e '/^LINKER\>/s,= .*,= mpicc,' \
+ -e '/^CC\>/s,= .*,= mpicc,' \
+ Make.gentoo_hpl_fblas_x86
+}
+
+src_compile() {
+ # do NOT use emake here
+ HOME=${WORKDIR} make arch=gentoo_hpl_fblas_x86 || die "Failed to build"
+}
+
+src_install() {
+ doman man/man3/*.3
+ dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING
+ dobin bin/gentoo_hpl_fblas_x86/xhpl || die "Failed to install bins"
+ insinto /usr/share/hpl
+ doins bin/gentoo_hpl_fblas_x86/HPL.dat || die "Failed to install HPL parameters"
+ dohtml -r www/*
+ dolib lib/gentoo_hpl_fblas_x86/libhpl.a || die "Failed to install lib"
+}
+
+pkg_postinst() {
+ einfo "Remember to copy /usr/share/hpl/HPL.dat to your working directory first!"
+ einfo "For mpich, run linpack by executing this in your working directory"
+ einfo "\"mpirun -np 4 /usr/bin/xhpl\""
+ einfo "where -np specifies the number of processes."
+ einfo "Other methods are needed lam-mpi etc."
+}