summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-12 16:23:40 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-12 16:23:40 +0000
commitf1bb6ab9d4b0f0dfb534338ccadf029e478609e9 (patch)
tree8073dd8b123c6cc0ea78e77b0ddfa341c35613b0
parentx86 stable (diff)
downloadgentoo-2-f1bb6ab9d4b0f0dfb534338ccadf029e478609e9.tar.gz
gentoo-2-f1bb6ab9d4b0f0dfb534338ccadf029e478609e9.tar.bz2
gentoo-2-f1bb6ab9d4b0f0dfb534338ccadf029e478609e9.zip
Install menu entry, bug #160245
(Portage version: 2.1.2.2)
-rw-r--r--games-arcade/rockdodger/ChangeLog7
-rw-r--r--games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild33
2 files changed, 22 insertions, 18 deletions
diff --git a/games-arcade/rockdodger/ChangeLog b/games-arcade/rockdodger/ChangeLog
index 1c9368d576df..97e593621c64 100644
--- a/games-arcade/rockdodger/ChangeLog
+++ b/games-arcade/rockdodger/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/rockdodger
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/ChangeLog,v 1.8 2006/12/06 17:06:04 wolf31o2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/ChangeLog,v 1.9 2007/03/12 16:23:40 nyhm Exp $
+
+ 12 Mar 2007; Tristan Heaven <nyhm@gentoo.org> rockdodger-0.6.0a-r1.ebuild:
+ Install menu entry, bug #160245
06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
rockdodger-0.6.0a-r1.ebuild:
diff --git a/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild b/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild
index 0c1e15c1fd64..38934ecc7f78 100644
--- a/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild
+++ b/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild,v 1.5 2006/12/06 17:06:04 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild,v 1.6 2007/03/12 16:23:40 nyhm Exp $
inherit eutils games
-DESCRIPTION="Dodge the rocks for as long as possible until you die. Kill greeblies to make the universe safe for non-greeblie life once again."
+DESCRIPTION="Dodge the rocks for as long as possible until you die"
HOMEPAGE="http://spacerocks.sourceforge.net/"
SRC_URI="mirror://sourceforge/spacerocks/${P}.tar.gz"
@@ -13,11 +13,9 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND=">=media-libs/libsdl-1.2.2
- >=media-libs/sdl-image-1.2
- >=media-libs/sdl-mixer-1.2"
-
-GAME_DEST_DIR=${GAMES_DATADIR}/${PN}
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
src_unpack() {
unpack ${A}
@@ -25,7 +23,7 @@ src_unpack() {
# Modify highscores & data directory and add our CFLAGS to the Makefile
sed -i \
- -e "s:\./data:${GAME_DEST_DIR}:" \
+ -e "s:\./data:${GAMES_DATADIR}/${PN}:" \
-e "s:/usr/share/rockdodger/\.highscore:${GAMES_STATEDIR}/rockdodger.scores:" \
-e 's:umask(0111):umask(0117):' main.c \
|| die " sed main.c failed"
@@ -37,18 +35,21 @@ src_unpack() {
sed -i \
-e "s:512:1024:" sound.c \
|| die "sed sound.c failed"
- epatch "${FILESDIR}/${PV}-sec.patch" \
- "${FILESDIR}/${P}"-gcc41.patch
+ epatch \
+ "${FILESDIR}"/${PV}-sec.patch \
+ "${FILESDIR}"/${P}-gcc41.patch
}
src_install() {
- dogamesbin rockdodger || die "dogamesbin failed"
- insinto "${GAME_DEST_DIR}"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
doins data/* || die "doins failed"
- dodir "${GAMES_STATEDIR}"
- touch "${D}/${GAMES_STATEDIR}/rockdodger.scores"
- fperms 660 "${GAMES_STATEDIR}/rockdodger.scores"
+ newicon spacerocks.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Rock Dodger" ${PN}.xpm
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}"/${PN}.scores
+ fperms 660 "${GAMES_STATEDIR}"/${PN}.scores
prepgamesdirs
}