summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-28 22:36:17 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-28 22:36:17 +0000
commitf1c67deb40b9406788ac8deab8677099f5fb30bb (patch)
tree704f693989c4c32bab5679689126d193a123b57e
parentLinux patch 3.15.7 (diff)
downloadgentoo-2-f1c67deb40b9406788ac8deab8677099f5fb30bb.tar.gz
gentoo-2-f1c67deb40b9406788ac8deab8677099f5fb30bb.tar.bz2
gentoo-2-f1c67deb40b9406788ac8deab8677099f5fb30bb.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
-rw-r--r--games-misc/katawa-shoujo/ChangeLog7
-rw-r--r--games-misc/katawa-shoujo/katawa-shoujo-1.2.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/games-misc/katawa-shoujo/ChangeLog b/games-misc/katawa-shoujo/ChangeLog
index c37fcd96e4ce..a924a7e95847 100644
--- a/games-misc/katawa-shoujo/ChangeLog
+++ b/games-misc/katawa-shoujo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/katawa-shoujo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/ChangeLog,v 1.7 2014/06/18 19:20:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/ChangeLog,v 1.8 2014/07/28 22:36:17 hasufell Exp $
+
+*katawa-shoujo-1.2 (28 Jul 2014)
+
+ 28 Jul 2014; Julian Ospald <hasufell@gentoo.org> +katawa-shoujo-1.2.ebuild:
+ version bump
18 Jun 2014; Michał Górny <mgorny@gentoo.org> katawa-shoujo-1.1-r1.ebuild:
Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug
diff --git a/games-misc/katawa-shoujo/katawa-shoujo-1.2.ebuild b/games-misc/katawa-shoujo/katawa-shoujo-1.2.ebuild
new file mode 100644
index 000000000000..584ba547e86c
--- /dev/null
+++ b/games-misc/katawa-shoujo/katawa-shoujo-1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/katawa-shoujo/katawa-shoujo-1.2.ebuild,v 1.1 2014/07/28 22:36:17 hasufell Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Bishoujo-style visual novel set in the fictional Yamaku High School for disabled children"
+HOMEPAGE="http://katawa-shoujo.com/"
+SRC_URI="http://dl.katawa-shoujo.com/gold_1.2/%5b4ls%5d_katawa_shoujo_1.2-%5blinux-x86%5d%5b8F3BA490%5d.tar.bz2 -> ${P}.tar.bz2
+ http://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-48.png
+ http://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-256.png"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc system-renpy"
+
+# make system-renpy optional due to #459742 :(
+RDEPEND="system-renpy? ( games-engines/renpy )
+ !system-renpy? (
+ || (
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+ )" #495270
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/lib/*"
+
+S="${WORKDIR}/Katawa Shoujo-linux-x86"
+
+src_install() {
+ if use system-renpy ; then
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r game/.
+ games_make_wrapper ${PN} "renpy '${GAMES_DATADIR}/${PN}'"
+ else
+ insinto "${GAMES_PREFIX_OPT}"/${PN}
+ doins -r common game lib renpy "Katawa Shoujo.py" "Katawa Shoujo.sh"
+ games_make_wrapper ${PN} "./Katawa\ Shoujo.sh" "${GAMES_PREFIX_OPT}/${PN}"
+ fperms +x "${GAMES_PREFIX_OPT}/${PN}"/lib/{python,linux-x86/python.real} \
+ "${GAMES_PREFIX_OPT}/${PN}/Katawa Shoujo.sh" \
+ "${GAMES_PREFIX_OPT}/${PN}/Katawa Shoujo.py"
+ fi
+
+ local i
+ for i in 48 256; do
+ newicon -s ${i} "${DISTDIR}"/${PN}-${i}.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} "Katawa Shoujo"
+
+ if use doc ; then
+ newdoc "Game Manual.pdf" manual.pdf
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ elog "Savegames from system-renpy and the bundled version are incompatible"
+
+ if use system-renpy; then
+ ewarn "system-renpy is unstable and not supported upstream"
+ fi
+
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}