summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2012-10-20 11:54:01 +0000
committerDaniel Pielmeier <billie@gentoo.org>2012-10-20 11:54:01 +0000
commitf28c4dc8f52e2c06cf549709e32fca7119106c65 (patch)
tree70c09019ff14b4755845d5427a2019f4ad757581
parentFix net-libs/libotr dependency wrt bug #438958 (diff)
downloadgentoo-2-f28c4dc8f52e2c06cf549709e32fca7119106c65.tar.gz
gentoo-2-f28c4dc8f52e2c06cf549709e32fca7119106c65.tar.bz2
gentoo-2-f28c4dc8f52e2c06cf549709e32fca7119106c65.zip
Inherit eutils directly. Die on rm and mv. Thanks to nimiux in bug #439032.
(Portage version: 2.1.11.9/cvs/Linux i686)
-rw-r--r--net-print/hplip/ChangeLog6
-rw-r--r--net-print/hplip/hplip-3.12.10.ebuild8
-rw-r--r--net-print/hplip/hplip-3.12.10a.ebuild8
-rw-r--r--net-print/hplip/hplip-3.12.4.ebuild8
-rw-r--r--net-print/hplip/hplip-3.12.9-r1.ebuild8
5 files changed, 21 insertions, 17 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index f43d4202101d..dedb3ba81aa0 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.246 2012/10/19 16:57:08 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.247 2012/10/20 11:54:01 billie Exp $
+
+ 20 Oct 2012; Daniel Pielmeier <billie@gentoo.org> hplip-3.12.4.ebuild,
+ hplip-3.12.9-r1.ebuild, hplip-3.12.10.ebuild, hplip-3.12.10a.ebuild:
+ Inherit eutils directly. Die on rm and mv. Thanks to nimiux in bug #439032.
19 Oct 2012; Daniel Pielmeier <billie@gentoo.org> hplip-3.12.10a.ebuild,
metadata.xml:
diff --git a/net-print/hplip/hplip-3.12.10.ebuild b/net-print/hplip/hplip-3.12.10.ebuild
index 548792ce79c3..2e88644c7a05 100644
--- a/net-print/hplip/hplip-3.12.10.ebuild
+++ b/net-print/hplip/hplip-3.12.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10.ebuild,v 1.1 2012/10/05 16:28:51 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10.ebuild,v 1.2 2012/10/20 11:54:01 billie Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit fdo-mime linux-info python autotools toolchain-funcs
+inherit eutils fdo-mime linux-info python autotools toolchain-funcs
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -119,10 +119,10 @@ src_prepare() {
# The hpcups driver does not use foomatic-rip
local i
for i in ppd/hpijs/*.ppd.gz ; do
- rm -f ${i}.temp
+ rm -f ${i}.temp || die
gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
gzip > ${i}.temp || die
- mv ${i}.temp ${i}
+ mv ${i}.temp ${i} || die
done
eautoreconf
diff --git a/net-print/hplip/hplip-3.12.10a.ebuild b/net-print/hplip/hplip-3.12.10a.ebuild
index 9547099d6cfe..883d0d9f648c 100644
--- a/net-print/hplip/hplip-3.12.10a.ebuild
+++ b/net-print/hplip/hplip-3.12.10a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10a.ebuild,v 1.2 2012/10/19 16:57:08 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.10a.ebuild,v 1.3 2012/10/20 11:54:01 billie Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit fdo-mime linux-info python autotools toolchain-funcs
+inherit eutils fdo-mime linux-info python autotools toolchain-funcs
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -120,10 +120,10 @@ src_prepare() {
# The hpcups driver does not use foomatic-rip
local i
for i in ppd/hpijs/*.ppd.gz ; do
- rm -f ${i}.temp
+ rm -f ${i}.temp || die
gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
gzip > ${i}.temp || die
- mv ${i}.temp ${i}
+ mv ${i}.temp ${i} || die
done
eautoreconf
diff --git a/net-print/hplip/hplip-3.12.4.ebuild b/net-print/hplip/hplip-3.12.4.ebuild
index abf798230d2e..114214335579 100644
--- a/net-print/hplip/hplip-3.12.4.ebuild
+++ b/net-print/hplip/hplip-3.12.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.4.ebuild,v 1.9 2012/09/18 18:10:42 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.4.ebuild,v 1.10 2012/10/20 11:54:01 billie Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit fdo-mime linux-info python autotools
+inherit eutils fdo-mime linux-info python autotools
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -117,10 +117,10 @@ src_prepare() {
# The hpcups driver does not use foomatic-rip
local i
for i in ppd/hpijs/*.ppd.gz ; do
- rm -f ${i}.temp
+ rm -f ${i}.temp || die
gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
gzip > ${i}.temp || die
- mv ${i}.temp ${i}
+ mv ${i}.temp ${i} || die
done
eautoreconf
diff --git a/net-print/hplip/hplip-3.12.9-r1.ebuild b/net-print/hplip/hplip-3.12.9-r1.ebuild
index f3e009a12069..2cfb5c5a8bb5 100644
--- a/net-print/hplip/hplip-3.12.9-r1.ebuild
+++ b/net-print/hplip/hplip-3.12.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.9-r1.ebuild,v 1.5 2012/10/17 03:19:28 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.12.9-r1.ebuild,v 1.6 2012/10/20 11:54:01 billie Exp $
EAPI=4
@@ -8,7 +8,7 @@ PYTHON_DEPEND="!minimal? 2"
PYTHON_USE_WITH="threads xml"
PYTHON_USE_WITH_OPT="!minimal"
-inherit fdo-mime linux-info python autotools toolchain-funcs
+inherit eutils fdo-mime linux-info python autotools toolchain-funcs
DESCRIPTION="HP Linux Imaging and Printing. Includes printer, scanner, fax drivers and service tools."
HOMEPAGE="http://hplipopensource.com/hplip-web/index.html"
@@ -119,10 +119,10 @@ src_prepare() {
# The hpcups driver does not use foomatic-rip
local i
for i in ppd/hpijs/*.ppd.gz ; do
- rm -f ${i}.temp
+ rm -f ${i}.temp || die
gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
gzip > ${i}.temp || die
- mv ${i}.temp ${i}
+ mv ${i}.temp ${i} || die
done
eautoreconf