summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-19 08:39:25 +0000
committerMike Frysinger <vapier@gentoo.org>2014-10-19 08:39:25 +0000
commitf3eafc58117b39b89ad9d1c6cffdf09345e96b7e (patch)
tree07ac88d292305035350ad68139478fdf9e80fd0b
parentBump to EAPI=5 (diff)
downloadgentoo-2-f3eafc58117b39b89ad9d1c6cffdf09345e96b7e.tar.gz
gentoo-2-f3eafc58117b39b89ad9d1c6cffdf09345e96b7e.tar.bz2
gentoo-2-f3eafc58117b39b89ad9d1c6cffdf09345e96b7e.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--app-misc/pax-utils/ChangeLog7
-rw-r--r--app-misc/pax-utils/pax-utils-0.9.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index b632aeb7d02a..969779b2d444 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/pax-utils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.157 2014/10/19 08:29:01 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.158 2014/10/19 08:39:25 vapier Exp $
+
+*pax-utils-0.9 (19 Oct 2014)
+
+ 19 Oct 2014; Mike Frysinger <vapier@gentoo.org> +pax-utils-0.9.ebuild:
+ Version bump.
19 Oct 2014; Mikle Kolyada <zlogene@gentoo.org> pax-utils-0.8.1.ebuild:
amd64 stable wrt bug #525842
diff --git a/app-misc/pax-utils/pax-utils-0.9.ebuild b/app-misc/pax-utils/pax-utils-0.9.ebuild
new file mode 100644
index 000000000000..37f64a4f922b
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.9.ebuild,v 1.1 2014/10/19 08:39:25 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="caps python"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ python? ( dev-python/pyelftools )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_PYTHON=$(usex python) \
+ "$@"
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux || \
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with python)
+ else
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+}