summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-11-16 02:30:55 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-11-16 02:30:55 +0000
commitf541472377dd5c653465943a31ca5543052cf398 (patch)
treed7ca63a40bf4ad13e1e21d60f13bc25e5ad5ad36
parentAssorted fixes (diff)
downloadgentoo-2-f541472377dd5c653465943a31ca5543052cf398.tar.gz
gentoo-2-f541472377dd5c653465943a31ca5543052cf398.tar.bz2
gentoo-2-f541472377dd5c653465943a31ca5543052cf398.zip
Pruning old ebuilds/support files/patches
(Portage version: 2.0.53_rc7)
-rw-r--r--gnome-base/gdm/files/2.6.0/Xsession229
-rw-r--r--gnome-base/gdm/files/2.6.0/custom.desktop10
-rw-r--r--gnome-base/gdm/files/2.6.0/pam.d/gdm8
-rw-r--r--gnome-base/gdm/files/2.6.0/pam.d/gdm-autologin8
-rw-r--r--gnome-base/gdm/files/2.6.0/pam.d/gdmconfig6
-rw-r--r--gnome-base/gdm/files/2.6.0/security/console.apps/gdmconfig5
-rw-r--r--gnome-base/gdm/files/digest-gdm-2.6.0.9-r22
-rw-r--r--gnome-base/gdm/files/digest-gdm-2.8.0.43
-rw-r--r--gnome-base/gdm/files/gdm-2.6.0.9-ipv6_config.patch12
-rw-r--r--gnome-base/gdm/gdm-2.6.0.9-r2.ebuild150
-rw-r--r--gnome-base/gdm/gdm-2.8.0.4.ebuild146
11 files changed, 0 insertions, 579 deletions
diff --git a/gnome-base/gdm/files/2.6.0/Xsession b/gnome-base/gdm/files/2.6.0/Xsession
deleted file mode 100644
index 4930bacc1c7a..000000000000
--- a/gnome-base/gdm/files/2.6.0/Xsession
+++ /dev/null
@@ -1,229 +0,0 @@
-#!/bin/sh
-#
-# This is SORT OF LIKE an X session, but not quite. You get a command as the
-# first argument (it could be multiple words, so run it with "eval"). As a
-# special case, the command can be:
-# failsafe - Run an xterm only
-# default - Run the appropriate Xclients startup (see the code below)
-# custom - Run ~/.xsession and if that's not available run 'default'
-#
-# (Note that other arguments could also follow, but only the command one is
-# right now relevant and supported)
-#
-# The output is ALREADY redirected to .xsession-errors in GDM. This way
-# .xsession-errors actually gets more output such as if the PreSession script
-# is failing. This also prevents DoS attacks if some app in the users session
-# can be prodded to dump lots of stuff on the stdout/stderr. We wish to be
-# robust don't we? In case you wish to use an existing script for other DM's,
-# you can just not redirect when GDMSESSION is set. GDMSESSION will always
-# be set from gdm.
-#
-# Also note that this is not run as a login shell, this is just executed.
-# This is why we source the profile files below.
-#
-# based on:
-# $XConsortium: Xsession /main/10 1995/12/18 18:21:28 gildea $
-
-# this will go into the .xsession-errors along with all other echo's
-# good for debugging where things went wrong
-echo "$0: Beginning session setup..."
-
-# First read /etc/profile and .profile
-test -f /etc/profile && . /etc/profile
-test -f "$HOME/.profile" && . "$HOME/.profile"
-# Second read /etc/xprofile and .xprofile for X specific setup
-test -f /etc/xprofile && . /etc/xprofile
-test -f "$HOME/.xprofile" && . "$HOME/.xprofile"
-# Third read .bash_profile for keychain to work correctly
-test -f "$HOME/.bash_profile" && . "$HOME/.bash_profile"
-
-# Translation stuff
-if [ -x "/usr/libexec/gdmtranslate" ] ; then
- gdmtranslate="/usr/libexec/gdmtranslate"
-else
- gdmtranslate=
-fi
-
-# Note that this should only go to zenity dialogs which always expect utf8
-gettextfunc () {
- if [ "x$gdmtranslate" != "x" ] ; then
- "$gdmtranslate" --utf8 "$1"
- else
- echo "$1"
- fi
-}
-
-zenity=`which zenity 2>/dev/null`
-
-command="$1"
-
-if [ -z "$command" ] ; then
- command=failsafe
-fi
-
-if [ x"$command" = xfailsafe ] ; then
- if [ -n "$zenity" ] ; then
- "$zenity" --info --text `gettextfunc "This is the failsafe xterm session. Windows now have focus only if you have your cursor above them. To get out of this mode type 'exit' in the window in the upper left corner"`
- else
- echo "$0: Starting the failsafe xterm session."
- fi
- exec xterm -geometry 80x24+0+0
-fi
-
-# Note: ~/.xsession-errors is now done in the daemon so that it
-# works for ALL sessions (except ones named 'Failsafe')
-
-# clean up after xbanner
-freetemp=`which freetemp 2>/dev/null`
-if [ -n "$freetemp" ] ; then
- "$freetemp"
-fi
-
-userresources="$HOME/.Xresources"
-usermodmap="$HOME/.Xmodmap"
-userxkbmap="$HOME/.Xkbmap"
-
-sysresources=/etc/X11/Xresources
-sysmodmap=/etc/X11/Xmodmap
-sysxkbmap=/etc/X11/Xkbmap
-
-rh6sysresources=/etc/X11/xinit/Xresources
-rh6sysmodmap=/etc/X11/xinit/Xmodmap
-
-
-# merge in defaults
-if [ -f "$rh6sysresources" ]; then
- xrdb -merge "$rh6sysresources"
-fi
-
-if [ -f "$sysresources" ]; then
- xrdb -merge "$sysresources"
-fi
-
-if [ -f "$userresources" ]; then
- xrdb -merge "$userresources"
-fi
-
-# merge in keymaps
-if [ -f "$sysxkbmap" ]; then
- setxkbmap `cat "$sysxkbmap"`
- XKB_IN_USE=yes
-fi
-
-if [ -f "$userxkbmap" ]; then
- setxkbmap `cat "$userxkbmap"`
- XKB_IN_USE=yes
-fi
-
-#
-# Eeek, this seems like too much magic here
-#
-if [ -z "$XKB_IN_USE" -a ! -L /etc/X11/X ]; then
- if grep '^exec.*/Xsun' /etc/X11/X > /dev/null 2>&1 && [ -f /etc/X11/XF86Config ]; then
- xkbsymbols=`sed -n -e 's/^[ ]*XkbSymbols[ ]*"\(.*\)".*$/\1/p' /etc/X11/XF86Config`
- if [ -n "$xkbsymbols" ]; then
- setxkbmap -symbols "$xkbsymbols"
- XKB_IN_USE=yes
- fi
- fi
-fi
-
-# xkb and xmodmap don't play nice together
-if [ -z "$XKB_IN_USE" ]; then
- if [ -f "$rh6sysmodmap" ]; then
- xmodmap "$rh6sysmodmap"
- fi
-
- if [ -f "$sysmodmap" ]; then
- xmodmap "$sysmodmap"
- fi
-
- if [ -f "$usermodmap" ]; then
- xmodmap "$usermodmap"
- fi
-fi
-
-unset XKB_IN_USE
-
-# Normalize languages, some places/distros screw us up in /etc/profile,
-# so in case the user did select a language
-if [ -n "$GDM_LANG" ]; then
- LANG="$GDM_LANG"
- export LANG
-
- if [ -n "$LC_ALL" ]; then
- if [ "$LC_ALL" != "$LANG" ]; then
- LC_ALL="$LANG"
- fi
- else
- unset LC_ALL
- fi
-
- if [ -n "$LANGUAGE" ]; then
- if [ "$LANGUAGE" != "$LANG" ]; then
- LANGUAGE="$LANG"
- fi
- else
- unset LANGUAGE
- fi
-
- if [ -n "$LINGUAS" ]; then
- if [ "$LINGUAS" != "$LANG" ]; then
- LINGUAS="$LANG"
- fi
- else
- unset LINGUAS
- fi
-fi
-
-# run all system xinitrc shell scripts.
-if [ -d /etc/X11/xinit/xinitrc.d ]; then
- for i in /etc/X11/xinit/xinitrc.d/* ; do
- if [ -x "$i" ]; then
- . "$i"
- fi
- done
-fi
-
-if [ "x$command" = "xcustom" ] ; then
- if [ -x "$HOME/.xsession" ]; then
- command="$HOME/.xsession"
- else
- echo "$0: Cannot find ~/.xsession will try the default session"
- command="default"
- fi
-fi
-
-if [ "x$command" = "xdefault" ] ; then
- if [ -x "$HOME/.Xclients" ]; then
- command="$HOME/.Xclients"
- elif [ -x /etc/X11/xinit/Xclients ]; then
- command="/etc/X11/xinit/Xclients"
- elif [ -x /etc/X11/Xclients ]; then
- command="/etc/X11/Xclients"
- else
- echo "$0: Cannot find Xclients"
- # FIXME: kind of an evil failsafe
- command="xsm"
- fi
-fi
-
-# add ssh-agent if found
-sshagent="`which ssh-agent 2>/dev/null`"
-if [ -n "$sshagent" ] && [ -x "$sshagent" ] && [ -z "$SSH_AUTH_SOCK" ]; then
- command="$sshagent -- $command"
-elif [ -z "$sshagent" ] ; then
- echo "$0: ssh-agent not found!"
-fi
-
-echo "$0: Setup done, will execute: $command"
-
-eval exec $command
-
-echo "$0: Executing $command failed, will run xterm"
-
-if [ -n "$zenity" ] ; then
- "$zenity" --info --text `gettextfunc "I could not start your session and so I have started the failsafe xterm session. Windows now have focus only if you have your cursor above them. To get out of this mode type 'exit' in the window in the upper left corner"`
-fi
-
-exec xterm -geometry 80x24+0+0
diff --git a/gnome-base/gdm/files/2.6.0/custom.desktop b/gnome-base/gdm/files/2.6.0/custom.desktop
deleted file mode 100644
index ea737608cd31..000000000000
--- a/gnome-base/gdm/files/2.6.0/custom.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-# The names/descriptions should really be better
-Name=Custom Session
-Comment=This starts a custom session
-Exec=custom
-# The "custom" Exec is a very special one and is handled specially in
-# the Xsession script and just runs "~/.xsession" directly
-Icon=
-Type=Application
diff --git a/gnome-base/gdm/files/2.6.0/pam.d/gdm b/gnome-base/gdm/files/2.6.0/pam.d/gdm
deleted file mode 100644
index e9dd91f07be9..000000000000
--- a/gnome-base/gdm/files/2.6.0/pam.d/gdm
+++ /dev/null
@@ -1,8 +0,0 @@
-#%PAM-1.0
-auth required /lib/security/pam_env.so
-auth required /lib/security/pam_stack.so service=system-auth
-auth required /lib/security/pam_nologin.so
-account required /lib/security/pam_stack.so service=system-auth
-password required /lib/security/pam_stack.so service=system-auth
-session required /lib/security/pam_stack.so service=system-auth
-session optional /lib/security/pam_console.so
diff --git a/gnome-base/gdm/files/2.6.0/pam.d/gdm-autologin b/gnome-base/gdm/files/2.6.0/pam.d/gdm-autologin
deleted file mode 100644
index 750db4773635..000000000000
--- a/gnome-base/gdm/files/2.6.0/pam.d/gdm-autologin
+++ /dev/null
@@ -1,8 +0,0 @@
-#%PAM-1.0
-auth required /lib/security/pam_env.so
-auth required /lib/security/pam_nologin.so
-auth required /lib/security/pam_permit.so
-account required /lib/security/pam_stack.so service=system-auth
-password required /lib/security/pam_stack.so service=system-auth
-session required /lib/security/pam_stack.so service=system-auth
-session optional /lib/security/pam_console.so
diff --git a/gnome-base/gdm/files/2.6.0/pam.d/gdmconfig b/gnome-base/gdm/files/2.6.0/pam.d/gdmconfig
deleted file mode 100644
index 44b01cfc759f..000000000000
--- a/gnome-base/gdm/files/2.6.0/pam.d/gdmconfig
+++ /dev/null
@@ -1,6 +0,0 @@
-#%PAM-1.0
-auth sufficient /lib/security/pam_rootok.so
-auth required /lib/security/pam_stack.so service=system-auth
-session required /lib/security/pam_permit.so
-session optional /lib/security/pam_xauth.so
-account required /lib/security/pam_permit.so
diff --git a/gnome-base/gdm/files/2.6.0/security/console.apps/gdmconfig b/gnome-base/gdm/files/2.6.0/security/console.apps/gdmconfig
deleted file mode 100644
index 5fc459648a9a..000000000000
--- a/gnome-base/gdm/files/2.6.0/security/console.apps/gdmconfig
+++ /dev/null
@@ -1,5 +0,0 @@
-USER=root
-PROGRAM=/usr/bin/gdmconfig
-SESSION=false
-FALLBACK=true
-
diff --git a/gnome-base/gdm/files/digest-gdm-2.6.0.9-r2 b/gnome-base/gdm/files/digest-gdm-2.6.0.9-r2
deleted file mode 100644
index 6e010d17c51f..000000000000
--- a/gnome-base/gdm/files/digest-gdm-2.6.0.9-r2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 d845fe205412bb101d4c66d1e88a317d gdm-2.6.0.9.tar.bz2 3484460
-MD5 02d70f412218f8da910ae6f317aae4b9 gentoo-gdm-theme-r2.tar.bz2 418934
diff --git a/gnome-base/gdm/files/digest-gdm-2.8.0.4 b/gnome-base/gdm/files/digest-gdm-2.8.0.4
deleted file mode 100644
index e03130cb896e..000000000000
--- a/gnome-base/gdm/files/digest-gdm-2.8.0.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d08cb22cfdc26f98d8b033cd8b8c48f1 gdm-2.8.0.4.tar.bz2 3866904
-MD5 02d70f412218f8da910ae6f317aae4b9 gentoo-gdm-theme-r2.tar.bz2 418934
-MD5 a23df5fecb624744c016ad2fe8ebe5e8 gdm-2.8-gentoo-files-r2.tar.bz2 3101
diff --git a/gnome-base/gdm/files/gdm-2.6.0.9-ipv6_config.patch b/gnome-base/gdm/files/gdm-2.6.0.9-ipv6_config.patch
deleted file mode 100644
index d11adcb7bec9..000000000000
--- a/gnome-base/gdm/files/gdm-2.6.0.9-ipv6_config.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -uNr gdm-2.6.0.9/configure.in gdm-2.6.0.9.patched/configure.in
---- gdm-2.6.0.9/configure.in 2005-04-12 06:35:47.000000000 +0200
-+++ gdm-2.6.0.9.patched/configure.in 2005-06-05 16:35:44.000000000 +0200
-@@ -190,7 +190,7 @@
- dnl IPv6 specific checks
- dnl *****************************
- AC_MSG_CHECKING([whether to enable IPv6])
--AC_ARG_ENABLE(enable-ipv6, [ --enable-ipv6=[yes/no] Enables compilation of IPv6 code default=[no]],, enable_ipv6=no)
-+AC_ARG_ENABLE(ipv6, [ --enable-ipv6=[yes/no] Enables compilation of IPv6 code default=[no]],, enable_ipv6=no)
- if test x$enable_ipv6 = xyes; then
- AC_TRY_COMPILE([
- #include <sys/types.h>
diff --git a/gnome-base/gdm/gdm-2.6.0.9-r2.ebuild b/gnome-base/gdm/gdm-2.6.0.9-r2.ebuild
deleted file mode 100644
index 373fc8f9cd7e..000000000000
--- a/gnome-base/gdm/gdm-2.6.0.9-r2.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/gdm-2.6.0.9-r2.ebuild,v 1.9 2005/07/12 03:13:49 geoman Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="GNOME2 Display Manager"
-HOMEPAGE="http://www.jirka.org/gdm.html"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~ia64 mips ppc ppc64 sparc x86"
-IUSE="tcpd xinerama selinux ipv6 pam"
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/gentoo-gdm-theme-r2.tar.bz2"
-MY_V="${PV%.*}"
-
-RDEPEND="pam? ( >=sys-libs/pam-0.72 )
- !pam? ( sys-apps/shadow )
- >=x11-libs/pango-1.4.1
- >=x11-libs/gtk+-2.4
- >=gnome-base/libglade-2
- >=gnome-base/librsvg-2
- >=media-libs/libart_lgpl-2.3.11
- >=dev-libs/libxml2-2.4.12
- >=gnome-base/libgnome-2
- >=gnome-base/libgnomeui-2
- >=gnome-base/libgnomecanvas-2
- selinux? ( sys-libs/libselinux )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=dev-util/intltool-0.29
- >=app-text/scrollkeeper-0.3.11
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
-
-G2CONF="${G2CONF} \
- --sysconfdir=/etc/X11 \
- --localstatedir=/var \
- --with-pam-prefix=/etc \
- --with-xdmcp \
- `use_enable ipv6` \
- `use_with tcpd tcp-wrappers` \
- `use_with xinerama` \
- `use_with selinux`"
-
-use pam && G2CONF="${G2CONF} --with-pam-prefix=/etc --enable-authentication=pam" \
- || G2CONF="${G2CONF} --enable-console-helper=no --enable-authentication-scheme=shadow"
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- # remove unneeded linker directive for selinux (#41022)
- epatch ${FILESDIR}/${PN}-2.4.4-selinux_remove_attr.patch
- # fix ipv6 flag (#90991)
- epatch ${FILESDIR}/${P}-ipv6_config.patch
-
- autoconf || die
-
-}
-
-src_install() {
-
- local pam_prefix
-
- use pam && pam_prefix="PAM_PREFIX=${D}/etc"
-
- gnome2_src_install \
- ${pam_prefix} \
- sysconfdir=${D}/etc/X11 \
- localstatedir=${D}/var
-
- # gdm-binary should be gdm to work with our init (#5598)
- rm -f ${D}/usr/bin/gdm
- mv ${D}/usr/bin/gdm-binary ${D}/usr/bin/gdm
- dosym /usr/bin/gdm /usr/bin/gdm-binary
-
- # log, etc.
- keepdir /var/log/gdm
- keepdir /var/gdm
- chown root:gdm ${D}/var/gdm
- chmod 1770 ${D}/var/gdm
-
- # use our own session script
- rm -f ${D}/etc/X11/gdm/Xsession
- exeinto /etc/X11/gdm
- doexe ${FILESDIR}/${MY_V}/Xsession
-
- # add a custom xsession .desktop by default (#44537)
- exeinto /etc/X11/dm/Sessions
- doexe ${FILESDIR}/${MY_V}/custom.desktop
-
- if use pam ; then
- # We replace the pam stuff by our own
- rm -f ${D}/etc/pam.d/gdm
-
- # pam startup
- dodir /etc/pam.d
- insinto /etc/pam.d
- doins ${FILESDIR}/${MY_V}/pam.d/gdm
- doins ${FILESDIR}/${MY_V}/pam.d/gdmconfig
- doins ${FILESDIR}/${MY_V}/pam.d/gdm-autologin
-
- # pam security
- dodir /etc/security/console.apps
- insinto /etc/security/console.apps
- doins ${FILESDIR}/${MY_V}/security/console.apps/gdmconfig
- fi
-
- # use graphical greeter local
- dosed "s:#Greeter=/usr/bin/gdmlogin:Greeter=/usr/bin/gdmgreeter:" /etc/X11/gdm/gdm.conf
-
- # Move Gentoo theme in
- mv ${WORKDIR}/gentoo-* ${D}/usr/share/gdm/themes
-
- dodoc AUTHORS ChangeLog INSTALL NEWS README* TODO
-
-}
-
-pkg_postinst() {
-
- gnome2_pkg_postinst
-
- # Soft restart, assumes Gentoo defaults for file locations
- FIFOFILE=/var/gdm/.gdmfifo
- PIDFILE=/var/run/gdm.pid
- if [ -w ${FIFOFILE} ] ; then
- if [ -f ${PIDFILE} ] ; then
- if kill -0 `cat ${PIDFILE}`; then
- (echo;echo SOFT_RESTART) >> ${FIFOFILE}
- fi
- fi
- fi
-
- einfo "To make GDM start at boot, edit /etc/rc.conf"
- einfo "and then execute 'rc-update add xdm default'."
-
-}
-
-pkg_postrm() {
-
- gnome2_pkg_postrm
-
- einfo "To remove GDM from startup please execute"
- einfo "'rc-update del xdm default'"
-
-}
diff --git a/gnome-base/gdm/gdm-2.8.0.4.ebuild b/gnome-base/gdm/gdm-2.8.0.4.ebuild
deleted file mode 100644
index 45cadc222a9d..000000000000
--- a/gnome-base/gdm/gdm-2.8.0.4.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/gdm-2.8.0.4.ebuild,v 1.1 2005/09/11 23:23:49 dang Exp $
-
-inherit eutils pam gnome2
-
-DESCRIPTION="GNOME Display Manager"
-HOMEPAGE="http://www.gnome.org/projects/gdm/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="ipv6 pam selinux static tcpd xinerama"
-
-# Name of the tarball with gentoo specific files
-GDM_EXTRA="${PN}-2.8-gentoo-files-r2"
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/gentoo-gdm-theme-r2.tar.bz2
- mirror://gentoo/${GDM_EXTRA}.tar.bz2"
-
-RDEPEND="pam? ( virtual/pam )
- !pam? ( sys-apps/shadow )
- >=dev-libs/glib-2.6
- >=x11-libs/gtk+-2.3
- >=x11-libs/pango-1.3
- >=gnome-base/libglade-1.99.2
- >=gnome-base/libgnome-1.96
- >=gnome-base/libgnomeui-1.96
- >=gnome-base/libgnomecanvas-1.109
- >=gnome-base/librsvg-1.1.1
- >=dev-libs/libxml2-2.4.12
- >=media-libs/libart_lgpl-2.3.11
- virtual/x11
- selinux? ( sys-libs/libselinux )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=dev-util/intltool-0.28
- >=app-text/scrollkeeper-0.1.4"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-USE_DESTDIR="1"
-
-
-pkg_setup() {
- G2CONF="--sysconfdir=/etc/X11 --localstatedir=/var --with-xdmcp \
- --with-pam-prefix=/etc $(use_enable ipv6) \
- $(use_with tcpd tcp-wrappers) $(use_with xinerama) \
- $(use_with selinux) $(use_enable static)"
-
-
- if use pam; then
- G2CONF="${G2CONF} --enable-authentication-scheme=pam"
- else
- G2CONF="${G2CONF} --enable-console-helper=no \
- --enable-authentication-scheme=shadow"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # remove unneeded linker directive for selinux (#41022)
- epatch ${FILESDIR}/${PN}-2.4.4-selinux_remove_attr.patch
-
- local makefiles=""
- for f in $(find docs -name Makefile.in); do
- makefiles="${makefiles} ${f}"
- done
- gnome2_omf_fix $makefiles
-}
-
-src_install() {
- gnome2_src_install
-
- local gentoodir="${WORKDIR}/${GDM_EXTRA}"
-
- # gdm-binary should be gdm to work with our init (#5598)
- rm -f ${D}/usr/sbin/gdm
- dosym /usr/sbin/gdm-binary /usr/sbin/gdm
- # our x11's scripts point to /usr/bin/gdm
- dosym /usr/sbin/gdm-binary /usr/bin/gdm
-
- # log, etc.
- keepdir /var/log/gdm
- keepdir /var/gdm
- chown root:gdm ${D}/var/gdm
- chmod 1770 ${D}/var/gdm
-
- # use our own session script
- rm -f ${D}/etc/X11/gdm/Xsession
- exeinto /etc/X11/gdm
- doexe ${gentoodir}/Xsession
-
- # add a custom xsession .desktop by default (#44537)
- exeinto /etc/X11/dm/Sessions
- doexe ${gentoodir}/custom.desktop
-
- # We replace the pam stuff by our own
- rm -rf ${D}/etc/pam.d
-
- dopamd ${gentoodir}/pam.d/*
- dopamsecurity console.apps ${gentoodir}/security/console.apps/gdmsetup
-
- # use graphical greeter local
- dosed "s:#Greeter=/usr/libexec/gdmlogin:Greeter=/usr/libexec/gdmgreeter:" \
- /etc/X11/gdm/gdm.conf
- # list available users
- dosed "s:^#MinimalUID=.*:MinimalUID=1000:" /etc/X11/gdm/gdm.conf
- dosed "s:^#IncludeAll=.*:IncludeAll=true:" /etc/X11/gdm/gdm.conf
-
- # Move Gentoo theme in
- mv ${WORKDIR}/gentoo-* ${D}/usr/share/gdm/themes
-}
-
-pkg_postinst() {
-
- gnome2_pkg_postinst
-
- # Soft restart, assumes Gentoo defaults for file locations
- FIFOFILE=/var/gdm/.gdmfifo
- PIDFILE=/var/run/gdm.pid
- if [ -w ${FIFOFILE} ] ; then
- if [ -f ${PIDFILE} ] ; then
- if kill -0 `cat ${PIDFILE}`; then
- (echo;echo SOFT_RESTART) >> ${FIFOFILE}
- fi
- fi
- fi
-
- einfo "To make GDM start at boot, edit /etc/rc.conf"
- einfo "and then execute 'rc-update add xdm default'."
-
-}
-
-pkg_postrm() {
-
- gnome2_pkg_postrm
-
- einfo "To remove GDM from startup please execute"
- einfo "'rc-update del xdm default'"
-
-}