summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-23 10:38:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-23 10:38:11 +0000
commitf6172f51410b86a7b156e6e0ba9a40da35db17fd (patch)
tree67a3e928dbf309f8843ec10a09149401cf821df8
parentstable x86, bug 305875 (diff)
downloadgentoo-2-f6172f51410b86a7b156e6e0ba9a40da35db17fd.tar.gz
gentoo-2-f6172f51410b86a7b156e6e0ba9a40da35db17fd.tar.bz2
gentoo-2-f6172f51410b86a7b156e6e0ba9a40da35db17fd.zip
Fix building with -Wl,--as-needed wrt #282426 by Kacper Kowalik. Fix missing USE="socks5" and USE="ssl" wrt #285661 by Andreis Vinogradovs.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--net-p2p/dclib/ChangeLog7
-rw-r--r--net-p2p/dclib/dclib-0.3.23.ebuild28
-rw-r--r--net-p2p/dclib/files/dclib-0.3.23-asneeded.patch16
3 files changed, 45 insertions, 6 deletions
diff --git a/net-p2p/dclib/ChangeLog b/net-p2p/dclib/ChangeLog
index 911ab6eca095..1716df795c1f 100644
--- a/net-p2p/dclib/ChangeLog
+++ b/net-p2p/dclib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/dclib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.114 2010/01/16 19:04:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.115 2010/03/23 10:38:10 ssuominen Exp $
+
+ 23 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> dclib-0.3.23.ebuild,
+ +files/dclib-0.3.23-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #282426 by Kacper Kowalik. Fix
+ missing USE="socks5" and USE="ssl" wrt #285661 by Andreis Vinogradovs.
16 Jan 2010; Raúl Porcel <armin76@gentoo.org> dclib-0.3.13.ebuild,
dclib-0.3.18.ebuild, dclib-0.3.23.ebuild:
diff --git a/net-p2p/dclib/dclib-0.3.23.ebuild b/net-p2p/dclib/dclib-0.3.23.ebuild
index 178f4f2a49c1..bc2dbbbb93b9 100644
--- a/net-p2p/dclib/dclib-0.3.23.ebuild
+++ b/net-p2p/dclib/dclib-0.3.23.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.3.23.ebuild,v 1.7 2010/01/16 19:04:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.3.23.ebuild,v 1.8 2010/03/23 10:38:10 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
DESCRIPTION="DirectConnect client library"
HOMEPAGE="http://sourceforge.net/projects/wxdcgui"
@@ -9,12 +12,27 @@ SRC_URI="mirror://sourceforge/wxdcgui/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 x86"
-IUSE=""
+IUSE="socks5 ssl"
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/libxml2
+ socks5? ( net-proxy/dante )
+ ssl? ( dev-libs/openssl )"
-DEPEND=">=app-arch/bzip2-1.0.2
- >=dev-libs/libxml2-2.4.22"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable socks5 socks) \
+ $(use_enable ssl)
+}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README TODO
}
diff --git a/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch b/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch
new file mode 100644
index 000000000000..d3634c424c2e
--- /dev/null
+++ b/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch
@@ -0,0 +1,16 @@
+Changing order allows ACX_PHTREAD to find -lthread
+before trying to use -pthread
+
+http://bugs.gentoo.org/show_bug.cgi?id=282426
+
+--- m4/acx_pthread.m4
++++ m4/acx_pthread.m4
+@@ -123,7 +123,7 @@
+ # which indicates that we try without any flags at all, and "pthread-config"
+ # which is a program returning the flags for the Pth emulation library.
+
+-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
++acx_pthread_flags="pthreads none -Kthread -kthread lthread pthread -pthread -pthreads -mthreads --thread-safe -mt pthread-config"
+
+ # The ordering *is* (sometimes) important. Some notes on the
+ # individual items follow: