summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-12-23 02:46:25 +0000
committerTim Harder <radhermit@gentoo.org>2011-12-23 02:46:25 +0000
commitf717b4315cea3585ea99f7f1f7e3fd5966bac343 (patch)
treec90931fa37e7789b7953f50a0644513127f28de0
parentalpha stable, bug #395017. (diff)
downloadgentoo-2-f717b4315cea3585ea99f7f1f7e3fd5966bac343.tar.gz
gentoo-2-f717b4315cea3585ea99f7f1f7e3fd5966bac343.tar.bz2
gentoo-2-f717b4315cea3585ea99f7f1f7e3fd5966bac343.zip
Version bump.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
-rw-r--r--x11-misc/xnee/ChangeLog7
-rw-r--r--x11-misc/xnee/xnee-3.11.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/x11-misc/xnee/ChangeLog b/x11-misc/xnee/ChangeLog
index 70b6c8e11560..03d116972847 100644
--- a/x11-misc/xnee/ChangeLog
+++ b/x11-misc/xnee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xnee
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.21 2011/12/02 22:20:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/ChangeLog,v 1.22 2011/12/23 02:46:25 radhermit Exp $
+
+*xnee-3.11 (23 Dec 2011)
+
+ 23 Dec 2011; Tim Harder <radhermit@gentoo.org> +xnee-3.11.ebuild:
+ Version bump.
02 Dec 2011; Samuli Suominen <ssuominen@gentoo.org> xnee-3.10.ebuild:
Remove support for building applet for gnome-panel-2.x (because it doesn't
diff --git a/x11-misc/xnee/xnee-3.11.ebuild b/x11-misc/xnee/xnee-3.11.ebuild
new file mode 100644
index 000000000000..3fccfd735d10
--- /dev/null
+++ b/x11-misc/xnee/xnee-3.11.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnee/xnee-3.11.ebuild,v 1.1 2011/12/23 02:46:25 radhermit Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Program suite to record, replay and distribute user actions."
+HOMEPAGE="http://www.sandklef.com/xnee/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome static-libs xosd"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXtst
+ x11-libs/libxcb
+ gnome? (
+ x11-libs/gtk+:2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gconf-2
+ )
+"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ dev-util/pkgconfig
+ sys-devel/gettext
+ gnome? ( || ( media-gfx/imagemagick[jpeg,png]
+ media-gfx/graphicsmagick[imagemagick,jpeg,png] ) )"
+
+# This needs RECORD extension from X.org server which isn't necessarily
+# enabled. Xlib: extension "RECORD" missing on display ":0.0".
+RESTRICT="test"
+
+src_configure() {
+ local myconf
+
+ if use xosd; then
+ myconf="--enable-xosd --enable-verbose --enable-buffer_verbose"
+ else
+ myconf="--disable-xosd --disable-verbose --disable-buffer_verbose"
+ fi
+
+ econf \
+ $(use_enable gnome gui) \
+ --disable-gnome-applet \
+ $(use_enable static-libs static) \
+ --enable-cli \
+ --enable-lib \
+ --disable-static-programs \
+ ${myconf}
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ default
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
+ use gnome && make_desktop_entry gnee Gnee ${PN} "Utility;GTK"
+ use static-libs || rm -f "${ED}"usr/lib*/lib*.la
+}