summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-05-14 21:49:48 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-05-14 21:49:48 +0000
commitf8216a9208fc8f905ba7798fb59f05c650f1ec13 (patch)
treee2517fc364d1f9e59b1308ac6320a59100f83259
parentRemove net-proxy/junkbuster (#174109) and net-dialup/gprs-easy-connect masks ... (diff)
downloadgentoo-2-f8216a9208fc8f905ba7798fb59f05c650f1ec13.tar.gz
gentoo-2-f8216a9208fc8f905ba7798fb59f05c650f1ec13.tar.bz2
gentoo-2-f8216a9208fc8f905ba7798fb59f05c650f1ec13.zip
Version bump.
(Portage version: 2.1.5_rc6)
-rw-r--r--x11-wm/openbox/ChangeLog7
-rw-r--r--x11-wm/openbox/openbox-3.4.7.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index 2439d2eae0dd..f76a0e00cf6a 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.163 2008/04/18 07:43:42 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.164 2008/05/14 21:49:48 omp Exp $
+
+*openbox-3.4.7.2 (14 May 2008)
+
+ 14 May 2008; David Shakaryan <omp@gentoo.org> +openbox-3.4.7.2.ebuild:
+ Version bump.
*openbox-3.4.7.1 (18 Apr 2008)
diff --git a/x11-wm/openbox/openbox-3.4.7.2.ebuild b/x11-wm/openbox/openbox-3.4.7.2.ebuild
new file mode 100644
index 000000000000..48dcfc2e0a2d
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.4.7.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.7.2.ebuild,v 1.1 2008/05/14 21:49:48 omp Exp $
+
+DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager."
+HOMEPAGE="http://icculus.org/openbox/"
+SRC_URI="http://icculus.org/openbox/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls startup-notification xinerama"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/libxml2-2.0
+ >=media-libs/fontconfig-2
+ virtual/xft
+ x11-libs/libXrandr
+ x11-libs/libXt
+ >=x11-libs/pango-1.8
+ nls? ( sys-devel/gettext )
+ startup-notification? ( >=x11-libs/startup-notification-0.8 )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_compile() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable nls) \
+ $(use_enable startup-notification) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox-session" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+}