summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-05-19 03:41:05 +0000
committerBen de Groot <yngwin@gentoo.org>2012-05-19 03:41:05 +0000
commitf93deb71eed6e5007436c04b9398e40618e047a3 (patch)
treed4186130e61fc3480e30040ffeb8b139c31397c3
parentAdd global jit USE flag per gentoo-dev discussion (http://archives.gentoo.org... (diff)
downloadgentoo-2-f93deb71eed6e5007436c04b9398e40618e047a3.tar.gz
gentoo-2-f93deb71eed6e5007436c04b9398e40618e047a3.tar.bz2
gentoo-2-f93deb71eed6e5007436c04b9398e40618e047a3.zip
Add test useflag and conditional dependency on qt-test (bug #416445)
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
-rw-r--r--x11-misc/andromeda/ChangeLog5
-rw-r--r--x11-misc/andromeda/andromeda-0.2.1.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/x11-misc/andromeda/ChangeLog b/x11-misc/andromeda/ChangeLog
index dcf81f7afbd3..d144fdbe304e 100644
--- a/x11-misc/andromeda/ChangeLog
+++ b/x11-misc/andromeda/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/andromeda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/andromeda/ChangeLog,v 1.2 2012/04/30 10:51:09 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/andromeda/ChangeLog,v 1.3 2012/05/19 03:41:05 yngwin Exp $
+
+ 19 May 2012; Ben de Groot <yngwin@gentoo.org> andromeda-0.2.1.ebuild:
+ Add test useflag and conditional dependency on qt-test (bug #416445)
30 Apr 2012; Ben de Groot <yngwin@gentoo.org> andromeda-0.2.1.ebuild:
Up the dependencies to Qt 4.8.0. Fixes bug #414093.
diff --git a/x11-misc/andromeda/andromeda-0.2.1.ebuild b/x11-misc/andromeda/andromeda-0.2.1.ebuild
index 7e54045e3f40..44b9982a7cef 100644
--- a/x11-misc/andromeda/andromeda-0.2.1.ebuild
+++ b/x11-misc/andromeda/andromeda-0.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/andromeda/andromeda-0.2.1.ebuild,v 1.2 2012/04/30 10:51:09 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/andromeda/andromeda-0.2.1.ebuild,v 1.3 2012/05/19 03:41:05 yngwin Exp $
EAPI=4
@@ -13,15 +13,22 @@ SRC_URI="https://gitorious.org/${PN}/${PN}/archive-tarball/v${PV} -> ${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
-DEPEND=">=x11-libs/qt-core-4.8.0:4
+RDEPEND=">=x11-libs/qt-core-4.8.0:4
>=x11-libs/qt-gui-4.8.0:4
>=x11-libs/qt-webkit-4.8.0:4"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? ( >=x11-libs/qt-test-4.8.0:4 )"
DOCS="TODO.txt dist/changes-*"
src_unpack() {
default
mv ${PN}-${PN} "${S}" || die
}
+
+src_prepare() {
+ if ! use test ; then
+ sed -i -e '/add_subdirectory( tests )/d' CMakeLists.txt || die
+ fi
+}