summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-27 06:01:29 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-27 06:01:29 +0000
commitfade27bb4295342cca94a6f2bf36d91e3f0ae00c (patch)
tree3c28965a9502ec8d7ead67293cb85b0d9be5721f
parentCleanup. (diff)
downloadgentoo-2-fade27bb4295342cca94a6f2bf36d91e3f0ae00c.tar.gz
gentoo-2-fade27bb4295342cca94a6f2bf36d91e3f0ae00c.tar.bz2
gentoo-2-fade27bb4295342cca94a6f2bf36d91e3f0ae00c.zip
Cleanup.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/activesupport/ChangeLog8
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.16.ebuild45
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.17.ebuild45
-rw-r--r--dev-ruby/activesupport/activesupport-3.1.10.ebuild62
-rw-r--r--dev-ruby/activesupport/activesupport-3.1.11.ebuild46
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.11.ebuild52
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.12.ebuild52
7 files changed, 7 insertions, 303 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index f7b693533914..72ce58d98841 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.227 2013/04/01 14:52:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.228 2013/04/27 06:01:29 graaff Exp $
+
+ 27 Apr 2013; Hans de Graaff <graaff@gentoo.org> -activesupport-2.3.16.ebuild,
+ -activesupport-2.3.17.ebuild, -activesupport-3.1.10.ebuild,
+ -activesupport-3.1.11.ebuild, -activesupport-3.2.11.ebuild,
+ -activesupport-3.2.12.ebuild:
+ Cleanup.
01 Apr 2013; Agostino Sarubbo <ago@gentoo.org> activesupport-2.3.18.ebuild:
Stable for ppc64, wrt bug #462452
diff --git a/dev-ruby/activesupport/activesupport-2.3.16.ebuild b/dev-ruby/activesupport/activesupport-2.3.16.ebuild
deleted file mode 100644
index d6556d4228dc..000000000000
--- a/dev-ruby/activesupport/activesupport-2.3.16.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.16.ebuild,v 1.5 2013/01/31 17:46:47 ago Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
-
-all_ruby_prepare() {
- # Remove the bundled packages!
- rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
- || die "failed to remove vendor packages"
-
- # This patch removes the fallback to local vendorized gems, as well
- # as fixing the dependencies for i18n to use the correct slot. It
- # also edits the metadata file so that the dependencies are added to
- # the specification, which is required for bundler to pick them up
- # (which in turn is required by radiant 1.0.0rc3 to
- # work). Furthermore remove the references to the vendorized copies
- # from the specification, to be safe.
- mv ../metadata . || die
- epatch "${FILESDIR}"/${PN}-2.3.16-unvendorize.patch
- mv metadata .. || die
- sed -i -e '/\/vendor\//d' ../metadata
-
- # don't support older mocha versions as the optional codepath
- # breaks JRuby
- epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
-}
diff --git a/dev-ruby/activesupport/activesupport-2.3.17.ebuild b/dev-ruby/activesupport/activesupport-2.3.17.ebuild
deleted file mode 100644
index fbe4e52219b7..000000000000
--- a/dev-ruby/activesupport/activesupport-2.3.17.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.17.ebuild,v 1.5 2013/02/24 17:37:06 ago Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
-
-all_ruby_prepare() {
- # Remove the bundled packages!
- rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
- || die "failed to remove vendor packages"
-
- # This patch removes the fallback to local vendorized gems, as well
- # as fixing the dependencies for i18n to use the correct slot. It
- # also edits the metadata file so that the dependencies are added to
- # the specification, which is required for bundler to pick them up
- # (which in turn is required by radiant 1.0.0rc3 to
- # work). Furthermore remove the references to the vendorized copies
- # from the specification, to be safe.
- mv ../metadata . || die
- epatch "${FILESDIR}"/${PN}-2.3.16-unvendorize.patch
- mv metadata .. || die
- sed -i -e '/\/vendor\//d' ../metadata
-
- # don't support older mocha versions as the optional codepath
- # breaks JRuby
- epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
-}
diff --git a/dev-ruby/activesupport/activesupport-3.1.10.ebuild b/dev-ruby/activesupport/activesupport-3.1.10.ebuild
deleted file mode 100644
index e980d643b8de..000000000000
--- a/dev-ruby/activesupport/activesupport-3.1.10.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.10.ebuild,v 1.2 2013/01/15 07:19:48 zerochaos Exp $
-
-EAPI=4
-
-# jruby fails tests.
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/${PN}"
-
-ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
- >=dev-ruby/multi_json-1.0
- dev-ruby/i18n:0.6
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# libxml-ruby, nokogiri, and builder are not strictly needed, but there
-# are tests using this code.
-ruby_add_bdepend "test? (
- virtual/ruby-test-unit
- >=dev-ruby/libxml-2.0.0
- dev-ruby/nokogiri
- dev-ruby/builder:0
- )"
-
-all_ruby_prepare() {
- # don't support older mocha versions as the optional codepath
- # breaks JRuby
- epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
-
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-
- # Remove upper restriction from gemspec. All tests pass with
- # multi_json 1.3.5. The upstream commit doesn't give details but
- # most likely this was added to avoid multi_json 1.3.0 which broke
- # compatibility. This was later fixed in 1.3.1. 1.3.0 is no longer
- # in portage so from a Gentoo point of view it is safe to depend on
- # => 1.0.
- sed -i -e "s/, '< 1.3'//" activesupport.gemspec || die
-
- # Avoid tests that do not work with newer versions of mocha.
- rm test/whiny_nil_test.rb || die
-}
diff --git a/dev-ruby/activesupport/activesupport-3.1.11.ebuild b/dev-ruby/activesupport/activesupport-3.1.11.ebuild
deleted file mode 100644
index adb7c1829978..000000000000
--- a/dev-ruby/activesupport/activesupport-3.1.11.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.1.11.ebuild,v 1.1 2013/02/11 20:46:29 graaff Exp $
-
-EAPI=4
-
-# jruby fails tests.
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/${PN}"
-
-ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
- >=dev-ruby/multi_json-1.0
- dev-ruby/i18n:0.6
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# libxml-ruby, nokogiri, and builder are not strictly needed, but there
-# are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/libxml-2.0.0
- dev-ruby/nokogiri
- dev-ruby/builder:0
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-}
diff --git a/dev-ruby/activesupport/activesupport-3.2.11.ebuild b/dev-ruby/activesupport/activesupport-3.2.11.ebuild
deleted file mode 100644
index e81605c742a7..000000000000
--- a/dev-ruby/activesupport/activesupport-3.2.11.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.11.ebuild,v 1.3 2013/02/10 09:27:53 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/multi_json-1.0
- dev-ruby/i18n:0.6
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/memcache-client-1.5.8
- dev-ruby/nokogiri
- >=dev-ruby/builder-3.0.3:3
- >=dev-ruby/tzinfo-0.3.29
- )"
-
-# libxml is not strictly needed, there are tests using this code. jruby
-# uses a different xml implementation.
-USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-}
diff --git a/dev-ruby/activesupport/activesupport-3.2.12.ebuild b/dev-ruby/activesupport/activesupport-3.2.12.ebuild
deleted file mode 100644
index 9a59d63e8d55..000000000000
--- a/dev-ruby/activesupport/activesupport-3.2.12.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.12.ebuild,v 1.1 2013/02/11 20:11:03 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="http://rubyforge.org/projects/activesupport/"
-SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-rails-*/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/multi_json-1.0
- dev-ruby/i18n:0.6
- !!<dev-ruby/activesupport-3.0.11-r1:3.0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/memcache-client-1.5.8
- dev-ruby/nokogiri
- >=dev-ruby/builder-3.0.3:3
- >=dev-ruby/tzinfo-0.3.29
- )"
-
-# libxml is not strictly needed, there are tests using this code. jruby
-# uses a different xml implementation.
-USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
-# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
-}