summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-03-30 18:24:44 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-03-30 18:24:44 +0000
commit481a7d497f90f533d5f5e6e33ef452690a204581 (patch)
tree37803c5156f134ebffb4ce212ff8b21ac5682f09 /app-accessibility/brltty
parentadd app-pda/libopensync-plugin-moto to opensync mask, pending on decision fro... (diff)
downloadgentoo-2-481a7d497f90f533d5f5e6e33ef452690a204581.tar.gz
gentoo-2-481a7d497f90f533d5f5e6e33ef452690a204581.tar.bz2
gentoo-2-481a7d497f90f533d5f5e6e33ef452690a204581.zip
finish conversion to eapi4 and fix java build failure, thanks to serkan
and cbrannon this closes bug #361341. (Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/brltty')
-rw-r--r--app-accessibility/brltty/ChangeLog6
-rw-r--r--app-accessibility/brltty/brltty-4.2.ebuild12
2 files changed, 11 insertions, 7 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index edcd18c4a290..492ff74c6f65 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/brltty
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.112 2011/03/30 18:05:22 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.113 2011/03/30 18:24:44 williamh Exp $
+
+ 30 Mar 2011; William Hubbs <williamh@gentoo.org> brltty-4.2.ebuild:
+ finish conversion to eapi4 and fix java build failure, thanks to serkan
+ and cbrannon this closes bug #361341.
30 Mar 2011; William Hubbs <williamh@gentoo.org> brltty-4.2.ebuild:
Migrate to eapi 4, remove the static use flag, and fix #361327.
diff --git a/app-accessibility/brltty/brltty-4.2.ebuild b/app-accessibility/brltty/brltty-4.2.ebuild
index 51bd2bddd5e2..e623c4095fdc 100644
--- a/app-accessibility/brltty/brltty-4.2.ebuild
+++ b/app-accessibility/brltty/brltty-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.2.ebuild,v 1.7 2011/03/30 18:05:22 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.2.ebuild,v 1.8 2011/03/30 18:24:44 williamh Exp $
EAPI="4"
FINDLIB_USE="ocaml"
@@ -83,19 +83,19 @@ src_configure() {
$(use_enable tcl tcl-bindings) \
$(use_enable X x) \
$(use_with bluetooth bluetooth-package) \
- $(use_with usb usb-package) \
- || die
+ $(use_with usb usb-package)
}
src_compile() {
local JAVAC_CONF=""
+ local OUR_JNI_FLAGS=""
if use java; then
- append-flags "$(java-pkg_get-jni-cflags)"
+ OUR_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
fi
# workaround for parallel build failure, bug #340903.
- emake -j1 JAVAC="${JAVAC_CONF}" || die
+ emake -j1 JAVA_JNI_FLAGS="${OUR_JNI_FLAGS}" JAVAC="${JAVAC_CONF}"
}
src_install() {
@@ -103,7 +103,7 @@ src_install() {
findlib_src_preinst
fi
- emake OCAML_LDCONF= install || die
+ emake OCAML_LDCONF= install
if use java; then
# make install puts the _java.so there, and no it's not $(get_libdir)