summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-12-14 15:57:42 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-12-14 15:57:42 +0000
commit0756cbc8c062710543778175c8c3490b58473ff2 (patch)
treefc5da693af6be1c56a2c2bd83ed35d69fbec7585 /app-accessibility/espeak
parentVersion bump. Cleanup (diff)
downloadgentoo-2-0756cbc8c062710543778175c8c3490b58473ff2.tar.gz
gentoo-2-0756cbc8c062710543778175c8c3490b58473ff2.tar.bz2
gentoo-2-0756cbc8c062710543778175c8c3490b58473ff2.zip
version bump
(Portage version: 2.2_rc59/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/ChangeLog7
-rw-r--r--app-accessibility/espeak/espeak-1.42.04.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index ba9a8c62a385..2e7aa75dbcdb 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.78 2009/11/01 18:49:54 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.79 2009/12/14 15:57:42 williamh Exp $
+
+*espeak-1.42.04 (14 Dec 2009)
+
+ 14 Dec 2009; William Hubbs <williamh@gentoo.org> +espeak-1.42.04.ebuild:
+ version bump
*espeak-1.41.01 (07 Oct 2009)
diff --git a/app-accessibility/espeak/espeak-1.42.04.ebuild b/app-accessibility/espeak/espeak-1.42.04.ebuild
new file mode 100644
index 000000000000..4ae940479aca
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.42.04.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.42.04.ebuild,v 1.1 2009/12/14 15:57:42 williamh Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="portaudio pulseaudio"
+RDEPEND="portaudio? ( >=media-libs/portaudio-19_pre20071207 )
+ pulseaudio? ( media-sound/pulseaudio )"
+ DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+get_audio() {
+ local MY_AUDIO
+
+ if use portaudio; then
+ MY_AUDIO=portaudio
+ elif use pulseaudio; then
+ MY_AUDIO=pulseaudio
+ else
+ MY_AUDIO=none
+ fi
+ echo ${MY_AUDIO}
+}
+
+pkg_setup() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn
+ ewarn Since portaudio and pulseaudio are not in your use flags,
+ ewarn espeak will only be able to create wav files.
+ ewarn If this is not what you want, press ctrl-c and put either
+ ewarn portaudio or pulseaudio in your use flags.
+ ebeep
+ epause 10
+ elif use portaudio && use pulseaudio; then
+ die "You must choose either portaudio or pulseaudio, but not both."
+ fi
+}
+
+src_prepare() {
+ cd src
+ # gentoo uses portaudio 19.
+ if use portaudio; then
+ mv -f portaudio19.h portaudio.h
+ fi
+}
+
+src_compile() {
+ cd src
+ emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}