summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-06-09 02:10:02 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-06-09 02:10:02 +0000
commita78410f55158e8d8125ee947dc7f84f117f19fec (patch)
tree3a7ffe10e8462e348a4b9ab1a4cc737e4918e480 /app-accessibility/espeak
parentversion bump and cleanout (diff)
downloadgentoo-2-a78410f55158e8d8125ee947dc7f84f117f19fec.tar.gz
gentoo-2-a78410f55158e8d8125ee947dc7f84f117f19fec.tar.bz2
gentoo-2-a78410f55158e8d8125ee947dc7f84f117f19fec.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/ChangeLog7
-rw-r--r--app-accessibility/espeak/espeak-1.26.ebuild61
-rw-r--r--app-accessibility/espeak/files/digest-espeak-1.263
3 files changed, 70 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index 7c08d2e0d280..cc5367bb4799 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.16 2007/06/07 10:36:03 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.17 2007/06/09 02:10:02 williamh Exp $
+
+*espeak-1.26 (09 Jun 2007)
+
+ 09 Jun 2007; William Hubbs <williamh@gentoo.org> +espeak-1.26.ebuild:
+ Version bump.
07 Jun 2007; Fernando J. Pereda <ferdy@gentoo.org> espeak-1.25.ebuild:
Added ~alpha as per bug #163285. Thanks to Brian Evans
diff --git a/app-accessibility/espeak/espeak-1.26.ebuild b/app-accessibility/espeak/espeak-1.26.ebuild
new file mode 100644
index 000000000000..0ab88d6a5429
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.26.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.26.ebuild,v 1.1 2007/06/09 02:10:02 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/portaudio-18.1-r5
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+}
+
+src_compile() {
+ cd ${S}/src
+ emake CXXFLAGS="${CXXFLAGS}" || die "Compilation failed"
+
+ einfo "Fixing byte order of phoneme data files"
+ cd ${S}/big_endian
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+
+ einfo "Compiling dict files"
+ cd "${S}/dictsource"
+ export HOME="${S}"
+ local lang
+ for l in *_rules; do
+ lang=${l/_rules/}
+ ${S}/src/speak --compile=$lang
+ done
+}
+
+src_install() {
+ cd ${S}/src
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die "Installation failed"
+
+ cd "${S}"
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}
diff --git a/app-accessibility/espeak/files/digest-espeak-1.26 b/app-accessibility/espeak/files/digest-espeak-1.26
new file mode 100644
index 000000000000..3d11813cbe73
--- /dev/null
+++ b/app-accessibility/espeak/files/digest-espeak-1.26
@@ -0,0 +1,3 @@
+MD5 dd2fc77a5b4ebdb204cf73f36c62ad01 espeak-1.26-source.zip 954674
+RMD160 256c2c63b0e934b23037ce7994870b3135d6d630 espeak-1.26-source.zip 954674
+SHA256 4c915f4fe9e37fb73b2241785ff8197cd9a3e5cae79bc9218d4866322fd0c438 espeak-1.26-source.zip 954674