summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-03-16 03:29:19 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-03-16 03:29:19 +0000
commitc521eed8b2fed14e4f08a60de17365e53738a8cd (patch)
tree33338d31ab24714384760f4c9669c4db563d8239 /app-accessibility/espeak
parentDrop bittorrent mask. (diff)
downloadgentoo-2-c521eed8b2fed14e4f08a60de17365e53738a8cd.tar.gz
gentoo-2-c521eed8b2fed14e4f08a60de17365e53738a8cd.tar.bz2
gentoo-2-c521eed8b2fed14e4f08a60de17365e53738a8cd.zip
version bump for #358965, thanks to Chris Brannon.
(Portage version: 2.2.0_alpha27/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/ChangeLog10
-rw-r--r--app-accessibility/espeak/espeak-1.45.01.ebuild73
-rw-r--r--app-accessibility/espeak/files/espeak-1.45.01-fix-libname.patch22
3 files changed, 103 insertions, 2 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index 951f0416c241..6341c12802f4 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/espeak
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.91 2010/10/30 06:56:26 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.92 2011/03/16 03:29:19 williamh Exp $
+
+*espeak-1.45.01 (16 Mar 2011)
+
+ 16 Mar 2011; William Hubbs <williamh@gentoo.org> +espeak-1.45.01.ebuild,
+ +files/espeak-1.45.01-fix-libname.patch:
+ version bump for #358965, thanks to Chris Brannon
29 Oct 2010; William Hubbs <williamh@gentoo.org> espeak-1.44.05.ebuild:
fix file name of ChangeLog. It should have been ChangeLog.txt.
diff --git a/app-accessibility/espeak/espeak-1.45.01.ebuild b/app-accessibility/espeak/espeak-1.45.01.ebuild
new file mode 100644
index 000000000000..eb228bcc0854
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.45.01.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.45.01.ebuild,v 1.1 2011/03/16 03:29:19 williamh Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="portaudio pulseaudio"
+REQUIRED_USE="portaudio? ( !pulseaudio )
+ pulseaudio? ( !portaudio )"
+ RDEPEND=" pulseaudio? ( media-sound/pulseaudio )
+ portaudio? ( >=media-libs/portaudio-19_pre20071207 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+get_audio() {
+ if use portaudio; then
+ echo portaudio
+ elif use pulseaudio; then
+ echo pulseaudio
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ cd src
+ # gentoo uses portaudio 19.
+ mv -f portaudio19.h portaudio.h
+ epatch "${FILESDIR}"/${P}-fix-libname.patch
+}
+
+src_compile() {
+ cd src
+ emake PREFIX="${EPREFIX}/usr" AUDIO="$(get_audio)" \
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" all
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="\$(PREFIX)/$(get_libdir)" AUDIO="$(get_audio)" install
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog.txt ReadMe
+ dohtml -r docs/*
+}
+
+pkg_postinst() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn "Since portaudio and pulseaudio are not in your use flags,"
+ ewarn "espeak will only be able to create wav files."
+ ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
+ ewarn "with either portaudio or pulseaudio USE flag enabled."
+ fi
+}
diff --git a/app-accessibility/espeak/files/espeak-1.45.01-fix-libname.patch b/app-accessibility/espeak/files/espeak-1.45.01-fix-libname.patch
new file mode 100644
index 000000000000..8188c4dc9ff4
--- /dev/null
+++ b/app-accessibility/espeak/files/espeak-1.45.01-fix-libname.patch
@@ -0,0 +1,22 @@
+diff --git a/src/Makefile b/src/Makefile
+index a184e85..a884f6f 100755
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -75,7 +75,6 @@ CXXFLAGS=-O2
+
+
+ all: $(BIN_NAME) $(LIB_NAME) $(STATIC_LIB_NAME) $(BIN2_NAME)
+- mv $(LIB_NAME) $(LIB_NAME).$(LIBTAG)
+
+ .cpp.o:
+ $(CXX) $(CXXFLAGS) $(USE_AUDIO) -D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -pedantic -I. -c -fno-exceptions $<
+@@ -95,6 +94,9 @@ x_%.o: %.cpp
+ $(LIB_NAME): $(OBJS2)
+ $(CXX) $(LDFLAGS) -shared $(SONAME_OPT)$(LIB_NAME).$(LIB_VERSION) -o $@ \
+ $(OBJS2) $(LIBS2)
++ mv $(LIB_NAME) $(LIB_NAME).$(LIBTAG)
++ $(LN_SF) $(LIB_NAME).$(LIBTAG) $(LIB_NAME).$(LIB_VERSION)
++ $(LN_SF) $(LIB_NAME).$(LIB_VERSION) $(LIB_NAME)
+
+ $(STATIC_LIB_NAME): $(OBJS2)
+ $(AR) cqs $(STATIC_LIB_NAME) $(OBJS2)