summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-04-26 05:26:16 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-04-26 05:26:16 +0000
commitf9e3f3e477f3785cfca828d137b5e9b60fb508b2 (patch)
treed4597eeb595086063805e991ebbb3f012c90dfe9 /app-accessibility/espeak
parentwhitespace (diff)
downloadgentoo-2-f9e3f3e477f3785cfca828d137b5e9b60fb508b2.tar.gz
gentoo-2-f9e3f3e477f3785cfca828d137b5e9b60fb508b2.tar.bz2
gentoo-2-f9e3f3e477f3785cfca828d137b5e9b60fb508b2.zip
Rev bump to install the dictsource directory for bug #218597.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/ChangeLog8
-rw-r--r--app-accessibility/espeak/espeak-1.37-r1.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index 339c7b657ecc..9f3fba0b75aa 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.43 2008/04/20 19:30:49 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.44 2008/04/26 05:26:16 williamh Exp $
+
+*espeak-1.37-r1 (26 Apr 2008)
+
+ 26 Apr 2008; William Hubbs <williamh@gentoo.org> +espeak-1.37-r1.ebuild:
+ Rev bump to install dictsource directory in /usr/share/espeak-data for
+ #218597.
*espeak-1.37 (20 Apr 2008)
diff --git a/app-accessibility/espeak/espeak-1.37-r1.ebuild b/app-accessibility/espeak/espeak-1.37-r1.ebuild
new file mode 100644
index 000000000000..2f1df16561b9
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.37-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.37-r1.ebuild,v 1.1 2008/04/26 05:26:16 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="portaudio pulseaudio"
+DEPEND="portaudio? ( >=media-libs/portaudio-18.1-r5 )
+ pulseaudio? ( media-sound/pulseaudio )
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+get_audio() {
+ local MY_AUDIO
+
+ MY_AUDIO=none
+ if use portaudio; then
+ MY_AUDIO=portaudio
+ elif use pulseaudio; then
+ MY_AUDIO=pulseaudio
+ fi
+ echo ${MY_AUDIO}
+}
+
+pkg_setup() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn
+ ewarn Since portaudio and pulseaudio are not in your use flags,
+ ewarn espeak will only bbe able to create wav files.
+ ewarn If this is not what you want, press ctrl-c and put either
+ ewarn portaudio or pulseaudio in your use flags.
+ ebeep
+ epause 10
+ elif use portaudio && use pulseaudio; then
+ die "You must choose either portaudio or pulseaudio, but not both."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if use portaudio; then
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+ fi
+}
+
+src_compile() {
+ cd src
+ emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}